Seite 1 von 1

HM-MOD-UART überprüfen - wie?

Verfasst: 09.03.2019, 13:48
von Gelegenheitsbastler
Ich habe aus einem Qivicon HomeBase einen HM-MOD-UART ausgebaut und mit einem RasPi verbunden. Die Installation von RaspberryMatic verlief erfolgreich. Trotzdem kann ich kein Gerät anlernen. Wie kann ich feststellen, ob die richtige Firmware auf dem HM-MOD-UART ist? Jerome hat mir ein paar Tipps gegeben, ist aber zeitlich eingespannt, so dass ich die Frage hier im Forum stelle. Was ich bislang versucht habe:

Code: Alles auswählen

# ps -ef|grep rfd
  650 root      0:02 /bin/rfd -f /var/etc/rfd.conf -l 5
 1530 root      0:00 grep rfd
#


Code: Alles auswählen

# eq3configcmd update-coprocessor -p /dev/raw-uart -c -v -d /firmware
2019/03/09 13:46:03.323 <Info> CCU2CommControllerMod::sendSystemCommand(): failed
2019/03/09 13:46:03.323 <Error> CCU2CommControllerMod::performIdentify(): Unable to determine coprocessor state.
2019/03/09 13:46:05.324 <Info> CCU2CommControllerMod::sendSystemCommand(): failed
2019/03/09 13:46:05.324 <Error> CCU2CommControllerMod::performIdentify(): Unable to determine coprocessor state.
2019/03/09 13:46:07.324 <Info> CCU2CommControllerMod::sendSystemCommand(): failed
2019/03/09 13:46:07.324 <Error> CCU2CommControllerMod::performIdentify(): Unable to determine coprocessor state.
2019/03/09 13:46:08.325 <Error> CoprocessorUpdate::startApplication():Could not start Coprocessor application.

2019/03/09 13:46:08.325 <Error> Could not start Application, maybe no application on device, do update with dummy Version: 0.0.0

# 
Wie kann ich feststellen, ob "raw-uart" das richtige Device ist?

Da ich keinen Plan habe, wie ich weiter vorgehen könnte, hoffe ich auf fachkundige Hilfe von euch.

Re: HM-MOD-UART überprüfen - wie?

Verfasst: 09.03.2019, 13:57
von jp112sdl
Hi,

da der rfd läuft, scheint zumindest das Funkmodul richtig initialisiert worden zu sein.
Gelegenheitsbastler hat geschrieben:
09.03.2019, 13:48
Trotzdem kann ich kein Gerät anlernen.
Auch kein orignales von HM? Also nicht dass es am CC1101-Frequenzproblem scheitert...

Du könntest mal den RFD anhalten (/etc/init.d/S61rfd stop) und mit Consolen-Debug starten:

Code: Alles auswählen

/bin/rfd -f /var/etc/rfd.conf -c -l 1
Da sollte beim Start dann zuerst sowas kommen:

Code: Alles auswählen

2019/03/09 13:55:48.042 <Debug> CCU2CommController::init() - Improved initialization.
2019/03/09 13:55:48.042 <Debug> CCU2CommController::improvedInit() - Coprocessor is in application.
2019/03/09 13:55:48.293 <Info> CCU2CommController::init(): Coprocessor Bootloader Version is: 1.0.3
2019/03/09 13:55:48.293 <Info> CCU2CommController::init(): Coprocessor Firmware Version is: 2.8.6
2019/03/09 13:55:48.294 <Info> () CCU2CommController::setCSMACAEnabled(): CSMA/CA disabled.
2019/03/09 13:55:48.295 <Debug> Default interface is now LEQ0556383
2019/03/09 13:55:48.296 <Info> Current AES key=0, previous AES key=0
2019/03/09 13:55:48.296 <Debug> (LEQ0556383) Response status: OK.
2019/03/09 13:55:48.297 <Debug> CCU2BidcosRemoteInterface::StartInterface(): addr=4c e1 91 
2019/03/09 13:55:48.297 <Debug> (LEQ0556383) Response status: OK.

Re: HM-MOD-UART überprüfen - wie?

Verfasst: 09.03.2019, 14:04
von Gelegenheitsbastler
Das sieht dann so aus:

Code: Alles auswählen

# 
# /etc/init.d/S61rfd stop
Stopping rfd: OK
# 
# /bin/rfd -f /var/etc/rfd.conf -c -l 1
2019/03/09 14:02:52.759 <Info> BidCoS-Service started
2019/03/09 14:02:52.760 <Info> XmlRpc Server is listening on TCP port 32001
2019/03/09 14:02:52.761 <Warning> opendir(/etc/config/firmware//) failed
2019/03/09 14:02:52.761 <Debug> CCU2CommController::init() - Improved initialization.
2019/03/09 14:02:52.762 <Debug> CCU2CommController::improvedInit() - Coprocessor is in application.
2019/03/09 14:02:53.012 <Info> CCU2CommController::init(): Coprocessor Bootloader Version is: 1.0.3
2019/03/09 14:02:53.012 <Info> CCU2CommController::init(): Coprocessor Firmware Version is: 2.8.6
2019/03/09 14:02:53.013 <Info> () CCU2CommController::setCSMACAEnabled(): CSMA/CA disabled.
2019/03/09 14:02:53.013 <Debug> Default interface is now LEQ0555794
2019/03/09 14:02:53.013 <Info> Current AES key=0, previous AES key=0
2019/03/09 14:02:53.014 <Debug> (LEQ0555794) Response status: OK.
2019/03/09 14:02:53.014 <Debug> CCU2BidcosRemoteInterface::StartInterface(): addr=2b e3 99 
2019/03/09 14:02:53.014 <Debug> (LEQ0555794) Response status: OK.
2019/03/09 14:02:53.019 <Debug> Device description rf_rd_le_v1_3.xml loaded (1)
2019/03/09 14:02:53.024 <Debug> Device description rf_sen_mdir_v1_5.xml loaded (2)
edit: Nach gefühlt einhundert Versuchen hat es nun mit einem Original HM-Gerät geklappt.
Trotzdem scheint mir der Eintrag in der dritten Zeile nicht okay zu sein:
"2019/03/09 14:02:52.761 <Warning> opendir(/etc/config/firmware//) failed"

Das Verzeichnis gibt es offenbar nicht.

Code: Alles auswählen

# cd etc/config
# ls
InterfacesList.xml          firewall.conf               ids                         nut                         shadow
TZ                          firewallConfigured          legacyAPIMigrationAccepted  random-seed                 snmp
addons                      hm_addons.cfg               localtime                   rc.d                        sshEnabled
authEnabled                 hmip_address.conf           log4j.xml                   rfd                         syslog
crRFD                       homematic.regadom           measurement                 rfd.conf                    timezone
crypttool.cfg               homematic.regadom.bak       netconfig                   server.pem                  userAckSecurityHint
eshlight                    hs485d                      ntpclient                   server.pem_20190309         userprofiles
# 

Re: HM-MOD-UART überprüfen - wie?

Verfasst: 09.03.2019, 14:22
von jp112sdl
Der Eintrag ist in Ordnung so und hat keinerlei Auswirkungen

Re: HM-MOD-UART überprüfen - wie?

Verfasst: 09.03.2019, 14:24
von jp112sdl
Evtl hast du ein Problem mit der Antenne oder auch dein anzulernendes Gerät ist zu dicht dran.

Re: HM-MOD-UART überprüfen - wie?

Verfasst: 09.03.2019, 17:31
von Gelegenheitsbastler
Ich gehe mal davon aus, dass genau das das Problem war. Die Geräte lagen nebeneinander auf dem Tisch. Danke für den Tipp!