ATMEGA - Bootloader - Fuses

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
Benutzeravatar
WRadebeul
Beiträge: 44
Registriert: 29.01.2018, 13:53

ATMEGA - Bootloader - Fuses

Beitrag von WRadebeul » 11.05.2019, 14:25

Ich versuche schon seit geraumer Zeit div. 328P AU Chip mit einem Bootloader zu versehen.
https://www.ebay.de/itm/1-5-Stk-ATmega3 ... 3pPyIeEyFw

ich verwende einen USBASP sowie den nachfolgenden Programm Adapter in den der Chip eingelegt werden kann.
1111.jpg
Zuvor hatte ich es mit verschiedenen Lötversuchen probiert, aber ohne Erfolg.

Ich verwende die AVRDUDE Komandozeile:

Code: Alles auswählen

D:\>avrdude -c usbasp -p m328p -P usb -e -U flash:w:D:\ATmegaBOOT_168_atmega328_pro_8MHz.hex:i
mit dem Bootloader von TomMayor
https://github.com/TomMajor/AskSinPP/tr ... loader/avr

Es gibt dann folgende Ausgabe:

Code: Alles auswählen

avrdude: error: program enable: target doesn't answer. 1
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude done.  Thank you.
Wahrscheinlich ist die Komandozeile falsch, oder ich verwende die falsche HEX Datei.

Über Arduino 1.8.6 habe ich es auch versucht, ohne Erfolg mit den folgenden Einstellungen und Fehlermeldung:
22.png

Code: Alles auswählen

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\W\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino14/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer        : usbasp
avrdude: Warning: cannot query manufacturer for device: No such file or directory
avrdude: Warning: cannot query product for device: No such file or directory
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'

avrdude done.  Thank you.

Fehler beim Brennen des Bootloaders.
Der USBASP scheint i.O.: div. China Atmega 328 Pro Mini 3,3V 8MHz mit den Fuses zu versehen klappt dagegen einwandfrei.
Wo liegen meine Fehler ?
Raspberry, CUL 868, NeoCreator

jp112sdl
Beiträge: 2593
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: ATMEGA - Bootloader - Fuses

Beitrag von jp112sdl » 11.05.2019, 14:40

WRadebeul hat geschrieben:
11.05.2019, 14:25
Ich verwende die AVRDUDE Komandozeile:
D:\>avrdude -c usbasp -p m328p -P usb -e -U flash:w:D:\ATmegaBOOT_168_atmega328_pro_8MHz.hex:i
Muss es nicht so sein?

Code: Alles auswählen

avrdude –c usbasp –p m328p –u –U flash:w:D:\ATmegaBOOT_168_atmega328_pro_8MHz.hex:i
http://www.elecrom.com/avrdude-tutorial ... d-avrdude/

VG,
Jérôme

Benutzeravatar
WRadebeul
Beiträge: 44
Registriert: 29.01.2018, 13:53

Re: ATMEGA - Bootloader - Fuses

Beitrag von WRadebeul » 11.05.2019, 14:56

Leider kein Erfolg, gleiche Fehlermeldung.
Raspberry, CUL 868, NeoCreator

Benutzeravatar
WRadebeul
Beiträge: 44
Registriert: 29.01.2018, 13:53

Re: ATMEGA - Bootloader - Fuses

Beitrag von WRadebeul » 11.05.2019, 15:30

Habe mir das Tutorial einmal durchgeschaut.
http://www.elecrom.com/avrdude-tutorial ... d-avrdude/

Grundsätzliche Frage: ich hatte es so verstanden, dass ich nebem dem USBARV und dem 328P keine weitere Harware wie Quarz,
Kerkos, Widerstände, etc. benötige. Der Schaltplan im Link zeugt aber etwas anderes (Ist aber auch kein 328P im Tutorial.

Ist also ein Aufspielen des Bootloaders direkt ohne weitere Bauteile möglich ?
Raspberry, CUL 868, NeoCreator

jp112sdl
Beiträge: 2593
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: ATMEGA - Bootloader - Fuses

Beitrag von jp112sdl » 11.05.2019, 15:34

Wenn der AVR auf "ext Clock" eingestellt ist, muss auch der externe Takt da sein.
Hab mich auch schon mal ausgesperrt. Der DIAMEX ISP liefert zum Glück direkt schon einen 1MHz Takt auf einer separaten Leitung mit.
https://classbproject.com/recovering-a-bricked-avr/

VG,
Jérôme

jp112sdl
Beiträge: 2593
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: ATMEGA - Bootloader - Fuses

Beitrag von jp112sdl » 11.05.2019, 15:35

Vielleicht hast du auch nur ein Verdrahtungsproblem... evtl mal in AVR-Foren recherchieren.
Auf https://www.mikrocontroller.net hab ich bisher fast alle meine Probleme lösen können (bzw. Antworten/Erklärungen gefunden)

VG,
Jérôme

Benutzeravatar
WRadebeul
Beiträge: 44
Registriert: 29.01.2018, 13:53

Re: ATMEGA - Bootloader - Fuses

Beitrag von WRadebeul » 11.05.2019, 15:56

Hab ein bis gelesen. Es hatte tatsächlich mit dem Takt zu tun.
Der USBAVR liefert einen viel zu hohen Takt. Einen fungfräulichen 328P ist mit einem geringeren Takt (8 Mhz) zu flaschen.
Hierzu gibt es auf dem USBARV den Jumper 3 welche zu schließen ist und danach ging es.

Stand auch im README File

Code: Alles auswählen

JUMPER
    J3 SCK option
      If the target clock is lower than 1,5 MHz, you have to set this jumper.
      Then SCK is scaled down from 375 kHz to about 8 kHz.
Problem ENDLICH gelöst !!
Raspberry, CUL 868, NeoCreator

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“