HB-UNI-SenAct-4-4 sendet ständig

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

heidepower
Beiträge: 32
Registriert: 26.12.2018, 20:32

HB-UNI-SenAct-4-4 sendet ständig

Beitrag von heidepower » 27.06.2019, 21:38

Hey Zusammen, ich habe mir den HB-UNI-SenAct-4-4 nachgebaut. Ich benutze ihn für mein elk. Beamerleinwand. Ich verwende 3 Aktoren (Runter/Stopp/Hoch). Da die Leinwandsteuerung jeweils nur einen kurzen Impuls benötig, habe ich dies über 3 Systemprogarmme realisiert. Über Cuxd habe ich mir dann ein neuen virtuellen Aktor erstellt mit den jeweiligen Tastern.

Deswegen benutze ich einen Tastereingang für einen Wechselschaltung die direct verknüpft ist.

Jetzt habe ich in der CCU Log festgestellt das der Aktor ständig sendet ohne das ich etwas ansteuere? Warum ist das so ??
Bild

und im serial Monitor im Arduino seht es so aus.
Bild

Leider sagt mir das nicht wirklich was und würde mich freuen wenn jemand mir da weiter helfen könnte.

Gruß heidepower

jp112sdl
Beiträge: 3168
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 21 Mal
Danksagung erhalten: 43 Mal
Kontaktdaten:

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von jp112sdl » 27.06.2019, 22:27

Ist 00FFFF eine tatsächlich von dir verwendete Peering-Adresse?
Im seriellen Monitor sieht man, dass 3x was gesendet wird... das wars dann aber auch.

Du könntest mal einen kompletten Reset durchführen. Anlerntaster gedrückt halten bis im seriellen Monitor "RESET" erscheint.
Danach das Gerät neu an die CCU anlernen

VG,
Jérôme

heidepower
Beiträge: 32
Registriert: 26.12.2018, 20:32

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von heidepower » 27.06.2019, 22:45

jp112sdl hat geschrieben:
27.06.2019, 22:27
st 00FFFF eine tatsächlich von dir verwendete Peering-Adresse?
Im seriellen Monitor sieht man, dass 3x was gesendet wird... das wars dann aber auch.
weis nicht genau was du damit meinst, aber diese Einstellungen hat der Aktor

{0xf3, DEV_MODEL, 0x01},// Device ID
"AskSinPP003", // Device Serial
{0xf3, DEV_MODEL}, // Device Model
0x10, // Firmware Version
as::DeviceType::Switch, // Device Type
{0x01, 0x00} // Info Bytes

De reset werde ich mal testen...

heidepower
Beiträge: 32
Registriert: 26.12.2018, 20:32

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von heidepower » 27.06.2019, 23:26

sowie ich das seh hat sich nix geändert...

nach dem löschen aud der CCU und Reset
Bild

Nach dem neu anlernen
Bild

Bild

jp112sdl
Beiträge: 3168
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 21 Mal
Danksagung erhalten: 43 Mal
Kontaktdaten:

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von jp112sdl » 27.06.2019, 23:34

heidepower hat geschrieben:
27.06.2019, 23:26
sowie ich das seh hat sich nix geändert...
Also ich kann da keinen Fehler sehen.
Nach dem Starten senden alle 4 Aktorkanäle ihren Status, daher kommen da 4 Telegramme nacheinander - und das wars.

Kannst du noch mal das Problem schildern?

P.S.: In dem Moment, wo du den seriellen Monitor öffnest, wird auch ein Neustart des 328P durchgeführt und es werden wieder 4 Telegramme gesendet

VG,
Jérôme

heidepower
Beiträge: 32
Registriert: 26.12.2018, 20:32

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von heidepower » 29.06.2019, 12:35

Hey, ok das wuste ich nicht mit dem öffnen des serial Monitor... aber trotzdem sendet er dauert.

AskSinPP04 ist ein Bewegungsmelder der auch sehr oft sendet, das sollte aber in Ordnung sein, da er ja den Helligkeitswert übermittelt.
AskSinPP03 ist der 4x4 Aktor der sehr oft sendet...obwohl er bis dato nur an die CCU angelernt worden ist.

ich denke mit dem größeren Ausschnit der Log file sollte das Probelm gut ersichtlich sein, so wie ich es zuvor geschildert habe war es ja nicht zu erkennem, da ich das mit dem serial Monitor nicht wuste :?

https://pastebin.com/n2mLLQem

jp112sdl
Beiträge: 3168
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 21 Mal
Danksagung erhalten: 43 Mal
Kontaktdaten:

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von jp112sdl » 29.06.2019, 16:20

Ja, da sieht man, dass viel gesendet wird... aber nicht warum

VG,
Jérôme

heidepower
Beiträge: 32
Registriert: 26.12.2018, 20:32

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von heidepower » 29.06.2019, 17:41

kann es sein das im Sektch ein Bug drin ist? denn wenn der Aktor nach dem anlernen schon viel sendet muss ja etwas Grundlegendes nicht stimmen!?

jp112sdl
Beiträge: 3168
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 21 Mal
Danksagung erhalten: 43 Mal
Kontaktdaten:

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von jp112sdl » 29.06.2019, 17:49

Am Code habe ich ewig nichts geändert und ich kenne einige, die den Sketch problemlos einsetzen.

Ausschließen kann ich einen Bug natürlich nicht... aber ich wüsste nicht, wo der auf einmal herkommen sollte.

VG,
Jérôme

heidepower
Beiträge: 32
Registriert: 26.12.2018, 20:32

Re: HB-UNI-SenAct-4-4 sendet ständig

Beitrag von heidepower » 29.06.2019, 18:30

Ja probleme habe ich dadurch auch nicht. Wahrscheinlich haben die anderen die den aktor einsetzten auch so ein hohen funkverkehr, haben bloss nich nie danach geschaut!

Wäre gut wenn andere User die den aktor einsetzten mal schauen könnten ob sie das gleiche (ich nenn es mal ) Problem haben.

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“