HM-LC-SWX-SM wird nicht von der CCU erkannt.

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
Beowolf
Beiträge: 355
Registriert: 15.07.2006, 12:50
Wohnort: Greven

HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von Beowolf » 12.08.2019, 09:44

Hallo,
eine Frage zum "HM-LC-SWX-SM". Wenn ich das so wie es bei github liegt auf den Arduino lade, bekomme ich es nicht angelernt.
Muß im Sketch noch etwas eingestellt werden?

Grüße
Manfred

klassisch
Beiträge: 3487
Registriert: 24.03.2011, 04:32
Hat sich bedankt: 4 Mal
Danksagung erhalten: 9 Mal

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von klassisch » 12.08.2019, 10:01

Ist die neuste Beschreibungs- Datei bereits auf der CCU? Siehe https://asksinpp.de/Grundlagen/03_ccu.h ... omponenten . Stichwort "Addon"

jp112sdl
Beiträge: 3603
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 56 Mal
Danksagung erhalten: 106 Mal
Kontaktdaten:

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von jp112sdl » 12.08.2019, 10:14

klassisch hat geschrieben:
12.08.2019, 10:01
Ist die neuste Beschreibungs- Datei bereits auf der CCU? Siehe https://asksinpp.de/Grundlagen/03_ccu.h ... omponenten . Stichwort "Addon"
Der HM-LC-SWX-SM benötigt kein Addon. Agiert als ein natives HM Gerät.

VG,
Jérôme

jp112sdl
Beiträge: 3603
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 56 Mal
Danksagung erhalten: 106 Mal
Kontaktdaten:

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von jp112sdl » 12.08.2019, 10:20

Beowolf hat geschrieben:
12.08.2019, 09:44
Wenn ich das so wie es bei github liegt auf den Arduino lade, bekomme ich es nicht angelernt.
Bekommst du andere Geräte angelernt? Oder liegts vielleicht daran?
https://asksinpp.de/Grundlagen/FAQ/Fehl ... C1101.html

VG,
Jérôme

Beowolf
Beiträge: 355
Registriert: 15.07.2006, 12:50
Wohnort: Greven

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von Beowolf » 12.08.2019, 10:33

Danke für die Antworten.

1. Es ist das aktuelle Addon auf der CCU. (gut, wird dann wohl nicht benötigt)
2. Wenn ich z.B. das HB-UNI-SenAct-4-4-SC aufspiele, wird alles direkt ohne Probleme erkannt.
3. Also sollte die "Sendefrequenzgeschichte" funktionieren.

Grüße

PS
Wenn ich auf den "Anlernetaster" drücke, blinkt die kleine LED nur ganz kurz auf. Bei anderen Sketches die von der CCU erkannt werden, blinkt die LED deutlich länger.

papa
Beiträge: 367
Registriert: 22.05.2018, 10:23
Danksagung erhalten: 15 Mal

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von papa » 12.08.2019, 11:39

Anlernen ist bei diesem Gerät LongPress, wenn HM_SENSOR_RELAY nicht definiert ist. Also 3 Sekunden drücken.
Anfragen zur AskSin++ werden nur im Forum beantwortet

Beowolf
Beiträge: 355
Registriert: 15.07.2006, 12:50
Wohnort: Greven

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von Beowolf » 12.08.2019, 11:58

Das war die richitge Hilfe. Vielen Dank. :D

Woran erkenne ich das im Sketch?

jp112sdl
Beiträge: 3603
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 56 Mal
Danksagung erhalten: 106 Mal
Kontaktdaten:

Re: HM-LC-SWX-SM wird nicht von der CCU erkannt.

Beitrag von jp112sdl » 12.08.2019, 12:38

Daran, ob

Code: Alles auswählen

ConfigButton<SwitchType> cfgBtn(sdev);
https://github.com/pa-pa/AskSinPP/blob/ ... SM.ino#L85

oder

Code: Alles auswählen

ConfigToggleButton<SwitchType> cfgBtn(sdev);
https://github.com/pa-pa/AskSinPP/blob/ ... SM.ino#L91

genutzt wird.

Letztgenannter ist Toggle(kurzer Druck) und Config(langer Druck) in einem Button.

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“