HB-UNI-Sensor1 vs HM-Sen-Li-O

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von Garagenloeter » 23.09.2019, 21:47

Hab nun beide Sensoren gebaut.
Wie kann es kommen, das beide Sensoren mit Faktor 10 bei den LUX Werten auseinander liegen?
in beiden Fällen Max44009.
Ist evtl. in einer der beiden Software noch ein Bug drinne?

Der Sensor kanns nicht sein, weil ich den Arduino mit jeweiliger Firmware tausche.

jp112sdl
Beiträge: 3360
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von jp112sdl » 23.09.2019, 22:33

Vielleicht kann Tom was dazu sagen. Habe keine Möglichkeit zum Testen.

VG,
Jérôme

TomMajor
Beiträge: 455
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 6 Mal
Danksagung erhalten: 27 Mal
Kontaktdaten:

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von TomMajor » 24.09.2019, 12:19

Garagenloeter hat geschrieben:
23.09.2019, 21:47
Hab nun beide Sensoren gebaut.
Wie kann es kommen, das beide Sensoren mit Faktor 10 bei den LUX Werten auseinander liegen?
in beiden Fällen Max44009.
Ist evtl. in einer der beiden Software noch ein Bug drinne?

Der Sensor kanns nicht sein, weil ich den Arduino mit jeweiliger Firmware tausche.
Beim HB-UNI-Sensor1 wird LUX mit Faktor 100 skaliert, das war mal eine Idee von einem user auf github um auch bei Dunkelheit <1Lux Aktionen zu triggern. Müsste irgendwann im Frühjahr 2019 geändert worden sein, eventuell hast du ein mismatch Problem zwischen Firmware, xml usw.
Am besten Sensor löschen, AddOn nochmal neu installieren, Sensor neu anlernen.
Viele Grüße,
Tom

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von Garagenloeter » 24.09.2019, 16:04

Ist alles frisch runtergeladen, Addon u Firmware.

Dann zeigt der Unisensor1 richtig an, der HM-Sen-Li-O hat die kommastelle eine ziffer weiter rechts.

Hab ich in der FW vom HM-Sen-Li schon geändert, nun sind beide gleich. :D

Danke für die Mühe.

jp112sdl
Beiträge: 3360
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von jp112sdl » 24.09.2019, 17:07

Wer zeigte denn zu viel mehr an?
Der UNI oder der Sen-Li-O?

VG,
Jérôme

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von Garagenloeter » 24.09.2019, 18:25

Der Sen-Li-O.

wie geschrieben, der unisensor zb. 1425.55 Lux, der Sen-Li-O 14255.5.

Im Sketch wird irgendwo Lux * 100 gerechnet, hab das auf Lux *10 gesetzt u schon stimmte es.

Hab im Netz dann mal geschaut, was so an Lux Werten in Räumen richtig ist.
Da sollte dann der Unisensor1 eher richtig liegen.

http://www.cine4home.de/Specials/BlackS ... abelle.jpg

TomMajor
Beiträge: 455
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 6 Mal
Danksagung erhalten: 27 Mal
Kontaktdaten:

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von TomMajor » 24.09.2019, 20:29

Jeromes HM-Sen-Li-O hat doch eine eigene Lux Skalierung die in seinem JP-HB-Devices-addon eigentlich berücksichtigt werden sollte?
Das sollte völlig unabhängig vom HB-UNI-Sensor1 funktionieren.
Viele Grüße,
Tom

jp112sdl
Beiträge: 3360
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-Sensor1 vs HM-Sen-Li-O

Beitrag von jp112sdl » 24.09.2019, 21:01

Der Sensor funktioniert unabhängig vom Addon.
Ist ein natives Gerät.

Habe gesehen, dass die asksin eigene Sensorklasse nur 1 Dezimalstelle liefert.

Wenn ich mal dran denke ändere ich das.

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“