AVRdude Fuse-Bit Arduino Mini klappt nicht

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
Jasimo
Beiträge: 3
Registriert: 20.10.2019, 12:06

AVRdude Fuse-Bit Arduino Mini klappt nicht

Beitrag von Jasimo » 20.10.2019, 12:19

Hallo,

ich hoffe ihr könnt mir helfen.
Ich versuche auf einem Arduino Mini das Fuse Bit nach dieser Anleitung zu setzen, da ich Probleme mit Babbling Devices habe
https://asksinpp.de/Grundlagen/FAQ/babb ... ml#avrdude.

Ich nutze Win10 64bit, LibUSB hab ich installiert und er Programmer USBAsp wir im Gerätemanager angezeigt.

Bekomme aber dann bei dem Versuch avrdude zu nutzen die folgende Meldung.

Code: Alles auswählen

C:\Users\Simon\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17\bin>avrdude -C C:\Users\Simon\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17\etc\avrdude.conf -v -pm328p -cusbasp -Ulfuse:w:0xFF:m -Uhfuse:w:0xD2:m -Uefuse:w:0xFF:m

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\Simon\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17\etc\avrdude.conf"

         Using Port                    : usb
         Using Programmer              : usbasp
avrdude: Warning: cannot query manufacturer for device: No such file or directory
avrdude: Warning: cannot query product for device: No such file or directory
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'

avrdude done.  Thank you.
Ich komme leider nicht weiter und brauche wohl eine Tipp vom Profi?

Gruß
Jan

stan23
Beiträge: 684
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Hat sich bedankt: 58 Mal
Danksagung erhalten: 29 Mal
Kontaktdaten:

Re: AVRdude Fuse-Bit Arduino Mini klappt nicht

Beitrag von stan23 » 20.10.2019, 13:34

Hi Jan,
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'
mit welcher VID/PID taucht denn der USBasp im Gerätemanager auf?

Das siehst du unter Eigenschaften -> Details -> Geräteinstanzpfad.
Viele Grüße
Marco

RaspberryMatic
~70 Geräte (HM, HmIP, HMW, HBW, AskSin)

Jasimo
Beiträge: 3
Registriert: 20.10.2019, 12:06

Re: AVRdude Fuse-Bit Arduino Mini klappt nicht

Beitrag von Jasimo » 20.10.2019, 17:41

Hallo Marco,

das passt, die VID/PID ist im Gerätemanager identisch.

Hab das eben einfach unter Raspbian probiert und da gings auf Anhieb, zumindest konnte ich die Fuses so setzen.
Am Ende mit der Meldung:

Code: Alles auswählen

avrdude: safemode: Fuses OK (E:FF, H:D2, L:FF)

avrdude done.   Thank you.
Nun hoffen mir mal das meine Selbstbausensoren mir nicht wieder den Funkverkehrt hier zubabbeln ;-)

Sollte also passen. DANKE!

stan23
Beiträge: 684
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Hat sich bedankt: 58 Mal
Danksagung erhalten: 29 Mal
Kontaktdaten:

Re: AVRdude Fuse-Bit Arduino Mini klappt nicht

Beitrag von stan23 » 20.10.2019, 20:58

Viele Grüße
Marco

RaspberryMatic
~70 Geräte (HM, HmIP, HMW, HBW, AskSin)

Jasimo
Beiträge: 3
Registriert: 20.10.2019, 12:06

Re: AVRdude Fuse-Bit Arduino Mini klappt nicht

Beitrag von Jasimo » 21.10.2019, 11:40

Ja, hatte ich alles so gemacht, war wirklich komisch. Jedoch hab ich es ja nun für meine paar Sensoren unter Linux hin bekommen.
Danke Dir für Deine Hilsbereitschaft.
Cya
Jan

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“