Botschaftswiederholungen mit unklarem Grund

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Matsch
Beiträge: 496
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 6 Mal
Danksagung erhalten: 32 Mal

Botschaftswiederholungen mit unklarem Grund

Beitrag von Matsch » 23.01.2020, 11:03

Bei der Beschäftigung mit Eigenbauprojekten ist mir immer wieder aufgefallen, dass selbst unter sehr guten Kommunikationsbedingungen ( 2... 3m Entfernung zur Zentrale CCU3) die CCU zeitweise (nicht immer) ihre Sendebotschaften im Abstand von ca. 160 ms mehrfach wiederholt, obwohl im Aktor alle Botschaften korrekt interpretiert und beantwortet werden. Es ist auch zu sehen, dass alle Wiederholungen identischen Inhalt haben, kein Bit anders. Das betrifft sowohl Empfangs- wie Sendebotschaften (jedenfalls beobachtet auf einem zusätzlichen Transceiver zur Überwachung des Funkverkehrs).

Code: Alles auswählen

10:50:48.681 -> ignore 10 3C B0 11 BAA13F 00BE00 02 08 C8 00 00 7D 00  - 183003
10:50:48.800 -> ignore 0E 3C 80 02 00BE00 BAA13F 01 08 C8 00 23  - 183132
10:50:48.840 -> ignore 10 45 A0 11 BAA13F 00BE00 02 08 C8 00 00 7D 00  - 183181
10:50:48.959 -> ignore 0E 45 80 02 00BE00 BAA13F 01 08 C8 00 23  - 183302
10:50:48.999 -> ignore 10 4E A0 11 BAA13F 00BE00 02 08 C8 00 00 7D 00  - 183345
10:50:49.118 -> ignore 0E 4E 80 02 00BE00 BAA13F 01 08 C8 00 23  - 183472
00BE00: Aktor
BAA13F: Zentrale

Nach der 2. oder 3. (manchmal auch 4.) Wiederholung endet dann die Kommunikation, ohne Störungsmeldung.

Weiß jemand, ob es plausible Gründe dafür geben kann oder ob das normal ist und ich das einfach so hinnnehmen muß bzw. kann?
Andernfalls muß ich ja immer noch ein Software-Problem in dem Aktor vermuten und weitersuchen.

jp112sdl
Beiträge: 4746
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 156 Mal
Danksagung erhalten: 330 Mal
Kontaktdaten:

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von jp112sdl » 23.01.2020, 11:29

Hast du den FreqTest laufen lassen?
Evtl. kommt die Quittung vom Gerät nur manchmal/gerade so bei der CCU an.

Hab es schon oft erlebt, dass es nur in eine Richtung funktioniert - bis die Frequenz angepasst wurde

VG,
Jérôme

Matsch
Beiträge: 496
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 6 Mal
Danksagung erhalten: 32 Mal

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von Matsch » 23.01.2020, 11:41

Das könnte ich mal probieren. Ich hatte ja zunächst alles auf dem Steckbrett aufgebaut und dort den Frequenztest gemacht.
Nun ist es aber auf einer LP aufgebaut, die Bauteile sind natürlich andere. Wenngleich der Transceiver aus der gleichen Charge stammt.
Aber das probiere ich dann mal mit aus.

jp112sdl
Beiträge: 4746
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 156 Mal
Danksagung erhalten: 330 Mal
Kontaktdaten:

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von jp112sdl » 23.01.2020, 11:49

Matsch hat geschrieben:
23.01.2020, 11:41
Wenngleich der Transceiver aus der gleichen Charge stammt.
Das muss nix heißen 8) :wink:

VG,
Jérôme

Matsch
Beiträge: 496
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 6 Mal
Danksagung erhalten: 32 Mal

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von Matsch » 23.01.2020, 15:22

Inzwischen hab ich den FreqTest mal drüber laufen lassen. Es hat nichts bewirkt, genau das gleiche Verhalten.
Es spielt auch keine Rolle, ob der Aktor relativ nah an der Zentrale ist oder 2 Zimmer entfernt. Die Zentrale sendet dann kaum mehr oder öfter Botschaftswiederholungen als wenn er näher dran ist.

Ich könnte jetzt sagen, na gut, drück ich in den Skat, solange es keine Kommunikationsfehler gibt - und die gab es bisher nicht.
Trotzdem wäre es mir wohler, ich wüßte, warum das so ist und ob ich daran noch was verbessern könnte. Aber habe ich mit dem Aktor darauf überhaupt einen Einfluss? M.E. hat der doch mit seiner zeitlich korrekten Antwort seine Schuldigkeit getan.

Zufälliges Zusammentreffen mit anderen Geräten? Dann wäre es womöglich doch normal. Andere Funkstörungen? Die aber scheinbar nur die Zentrale betreffen?

papa
Beiträge: 429
Registriert: 22.05.2018, 10:23
Danksagung erhalten: 31 Mal

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von papa » 23.01.2020, 15:37

Vielleicht ist es auch ein Timingproblem. Du kannst ja mal etwas mit den SENDDELAY vom Radio experimentieren.
https://github.com/pa-pa/AskSinPP/blob/ ... dio.h#L648
Bitte vorher nochmal pullen - der Parameter wurde noch nicht an allen Stellen genutzt.
Anfragen zur AskSin++ werden nur im Forum beantwortet

Matsch
Beiträge: 496
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 6 Mal
Danksagung erhalten: 32 Mal

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von Matsch » 23.01.2020, 17:58

Danke für den Hinweis, jetzt läuft es anscheinend, es gibt so gut wie nie mehr eine Sendewiederholung.

Was den Parameter SENDDELAY betrifft, so wird der ja nur wirksam, wenn das aufrufende Programm keinen Wert für die Verzögerung übergibt, das tut es aber in MultiChannelDevice:

Code: Alles auswählen

   bool process(Message& msg) {
     uint8_t answer = REPLAY_NO;
     ChannelType* ch = 0;
     HMID devid;
     this->getDeviceID(devid);
     if( msg.to() == devid || this->isBroadcastMsg(msg) ) {
       // we got a message - we do not answer before 100ms
       this->radio().setSendTimeout(100);
So kann ich den Parameter ändern wie ich will, die Verzögerungszeit bleibt. Wahrscheinlich müßte ich sie an obiger Stelle ändern.
Wie es aussieht, hat aber allein das Update von AskSin++ auf die aktuelle Version geholfen - was auch immer darin sich diesbezüglich geändert hat.

Ob es dauerhaft so bleibt, ist abzuwarten, jetzt habe ich erstmal 100% Duty Cycle erreicht ...
Testreihe ist vorerst zwangsweise beendet

papa
Beiträge: 429
Registriert: 22.05.2018, 10:23
Danksagung erhalten: 31 Mal

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von papa » 23.01.2020, 19:36

Danke - habe ich auch gleich mal noch angepasst.
Anfragen zur AskSin++ werden nur im Forum beantwortet

Matsch
Beiträge: 496
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 6 Mal
Danksagung erhalten: 32 Mal

Re: Botschaftswiederholungen mit unklarem Grund [gelöst]

Beitrag von Matsch » 28.01.2020, 09:58

Auch nach mehreren Tagen kann ich bestätigen: Ja, es funktioniert noch immer.

papa
Beiträge: 429
Registriert: 22.05.2018, 10:23
Danksagung erhalten: 31 Mal

Re: Botschaftswiederholungen mit unklarem Grund

Beitrag von papa » 28.01.2020, 10:30

Könntest Du bitte mal etwas ausprobieren?
Den Code nochmal aktualisieren, compilieren, flashen und testen, ob Wiederholungen auftreten oder nicht.
Dann bitte mal im Sketch folgende Zeile vor allen #include Anweeisungen einfügen:

Code: Alles auswählen

#define USE_CCA
Dannach wieder compilieren, flashen und testen, ob sich im Verhalten etwas ändert.
Danke
Anfragen zur AskSin++ werden nur im Forum beantwortet

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“