ASKSIN Modul kein Anlernen möglich

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

sixpack_de
Beiträge: 34
Registriert: 27.09.2019, 19:52
Hat sich bedankt: 8 Mal

ASKSIN Modul kein Anlernen möglich

Beitrag von sixpack_de » 16.05.2020, 16:58

Hi,

ich habe eines der AKSSIN Module (Pooltemperatur) auf einer Platine von smarthometricks "nachgebaut" und geflasht.

das Gerät leuchtet (LED noch dran) und lässt sich nicht anlernen.
Serieller Monitor (auf 115200) zeigt:

Code: Alles auswählen

AskSin++ V4.1.5 (May 16 2020 16:30:42)
ID: F30101  Serial: UNITEMP001
Address Space: 32 - 358
CC init1
kein Ready, wenn ich auf meiner raspberrymatic (JP HB Device Addon 2.24 installiert) schaue sehe ich nix (anlernen und dann knopf gerückt nach 5 und nach 20s:

Code: Alles auswählen

May 16 16:49:10 homematic-raspi user.debug rfd: Entering install mode for 60 s
May 16 16:49:16 homematic-raspi user.debug multimac: C<: #180 TRX GetDutyCycle
May 16 16:49:16 homematic-raspi user.debug multimac: C< @94482957: bin:FD 00 03 01 B4 03 20 17
May 16 16:49:17 homematic-raspi user.debug multimac: C> @94483060: #180 TRX Response Ack 0B
May 16 16:49:17 homematic-raspi user.debug multimac: SubsystemBidcos::CheckDutyCycleEventThreshold( 5.5, 5.5 ) = 0
May 16 16:49:24 homematic-raspi user.debug multimac: C> @94490190: #84 LLMAC RX @24346ms -71dBm 35 86 53 5C 2B AD 00 00 00 00 41 00 D2 42 00 CB 43 00 07 44 FF F9
May 16 16:49:24 homematic-raspi user.debug multimac: Bidcos RX: #35[BC|Ren|WMup] 5C2BAD->000000 MeasurementCyclic: 00 41 00 D2 42 00 CB 43 00 07 44 FF F9
May 16 16:49:24 homematic-raspi user.debug multimac: GetAckActionForIncomingTelegram() ackAction=AckAction_NotForUs, wakeup=None
May 16 16:49:24 homematic-raspi user.debug multimac: A<: #114 HmBidcos RxTelegram AuthNone #35[BC|Ren|WMup] 5C2BAD->000000 MeasurementCyclic: 00 41 00 D2 42 00 CB 43 00 07 44 FF F9
May 16 16:49:24 homematic-raspi user.debug rfd: RX for OEQ0675332: @502664681 RSSI=-71dB 0x5C2BAD -> 0x000000 Generic [PEQ1946695]:   CNT=53,RPTEN=1,RPTED=0,BIDI=0,BURST=0,WAKEUP=0,WAKEMEUP=1,BCAST=1,TYPE=0x53   DATA = 00 41 00 D2 42 00 CB 43 00 07 44 FF F9
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:1.TEMPERATURE=21.000000
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:2.TEMPERATURE=20.300000
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:3.TEMPERATURE=0.700000
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 2 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:4.TEMPERATURE=-0.700000
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:0.LOWBAT=false
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 3 events
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:1.LOWBAT=false
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:2.LOWBAT=false
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:3.LOWBAT=false
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:4.LOWBAT=false
May 16 16:49:24 homematic-raspi user.debug rfd: Event: OEQ0675332:5.LOWBAT=false
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 5 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 2 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 9 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 8 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 8 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 7 events
May 16 16:49:24 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:26 homematic-raspi user.debug multimac: C<: #181 TRX GetDutyCycle
May 16 16:49:26 homematic-raspi user.debug multimac: C< @94492958: bin:FD 00 03 01 B5 03 A6 14
May 16 16:49:27 homematic-raspi user.debug multimac: C> @94493062: #181 TRX Response Ack 0B
May 16 16:49:27 homematic-raspi user.debug multimac: SubsystemBidcos::CheckDutyCycleEventThreshold( 5.5, 5.5 ) = 0
May 16 16:49:29 homematic-raspi user.debug multimac: C> @94495125: #85 LLMAC RX @29282ms -69dBm A4 86 10 2D B9 77 00 00 00 0A A0 DF 0A 00 40
May 16 16:49:29 homematic-raspi user.debug multimac: Bidcos RX: #A4[BC|Ren|WMup] 2DB977->000000 Info: 0A A0 DF 0A 00 40
May 16 16:49:29 homematic-raspi user.debug multimac: GetAckActionForIncomingTelegram() ackAction=AckAction_NotForUs, wakeup=None
May 16 16:49:29 homematic-raspi user.debug multimac: A<: #117 HmBidcos RxTelegram AuthNone #A4[BC|Ren|WMup] 2DB977->000000 Info: 0A A0 DF 0A 00 40
May 16 16:49:29 homematic-raspi user.debug rfd: RX for LEQ0779432: @502669616 RSSI=-69dB 0x2DB977 -> 0x000000 Generic [PEQ1946695]:   CNT=36,RPTEN=1,RPTED=0,BIDI=0,BURST=0,WAKEUP=0,WAKEMEUP=1,BCAST=1,TYPE=0x10   DATA = 0A A0 DF 0A 00 40
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.CONTROL_MODE=1
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.FAULT_REPORTING=0
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.BATTERY_STATE=2.500000
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.VALVE_STATE=0
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.BOOST_STATE=0
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.ACTUAL_TEMPERATURE=22.300000
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.SET_TEMPERATURE=20.000000
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_TEMPERATURE=5.000000
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_START_TIME=0
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_START_DAY=1
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_START_MONTH=1
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_START_YEAR=0
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_STOP_TIME=0
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_STOP_DAY=1
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_STOP_MONTH=1
May 16 16:49:29 homematic-raspi user.debug rfd: Event: LEQ0779432:4.PARTY_STOP_YEAR=0
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 14 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 15 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 15 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 15 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 15 events
May 16 16:49:29 homematic-raspi user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
May 16 16:49:33 homematic-raspi user.debug multimac: C> @94499354: #145 HMIP CMD=07  45 10 00 8E B5 61 0B B5 61 0B 00 00 00 00 00 00 00 00 85 6D 00 45 06 00
May 16 16:49:33 homematic-raspi user.debug multimac: A<: #136 HMIP CMD=07  45 10 00 8E B5 61 0B B5 61 0B 00 00 00 00 00 00 00 00 85 6D 00 45 06 00
May 16 16:49:36 homematic-raspi user.debug multimac: C<: #182 TRX GetDutyCycle
May 16 16:49:36 homematic-raspi user.debug multimac: C< @94502958: bin:FD 00 03 01 B6 03 AC 14
May 16 16:49:37 homematic-raspi user.debug multimac: C> @94503062: #182 TRX Response Ack 0B
May 16 16:49:37 homematic-raspi user.debug multimac: SubsystemBidcos::CheckDutyCycleEventThreshold( 5.5, 5.5 ) = 0
Das Freq Test ino geflasht:

Code: Alles auswählen

AskSin++ V4.1.5 (May 16 2020 16:53:14)
CC init1
Dann Sensor ab, gleiches unbefriedigendes Ergebnis, wahrscheinlich was triviales und ich bin zu doof es zu sehen :(

Danke und Gruß,

Jan

jp112sdl
Beiträge: 5122
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 190 Mal
Danksagung erhalten: 404 Mal
Kontaktdaten:

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von jp112sdl » 16.05.2020, 17:17

sixpack_de hat geschrieben:
16.05.2020, 16:58
Serieller Monitor (auf 115200) zeigt:
Der serielle Monitor muss bei 57600 Baud was zeigen.
Stimmt also schon mal was mit deinem Pro Mini nicht.
Scheint, als hättest du einen 16 MHz Pro Mini, der mit 5V arbeitet.
Und diese 5V können dann auch schnell mal das CC1101 kaputt machen.

VG,
Jérôme ☕️

sixpack_de
Beiträge: 34
Registriert: 27.09.2019, 19:52
Hat sich bedankt: 8 Mal

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von sixpack_de » 16.05.2020, 20:15

Hallo,

also auf der Packung steht 3,3V, kann man das am Arduino sehen?
IMG_3563.jpg
Aber seid du das geschrieben hast,macht die Arduino Umgebung auch den COM Port nicht mehr auf ... (Also er steht nicht mehr zur Verfügung)... :cry: manchmal mag ich meinen Computer nicht ....

Danke schonmal,

Jan

stan23
Beiträge: 1023
Registriert: 13.12.2016, 21:14
System: Alternative CCU (RaspberryMatic etc.)
Wohnort: Altmühltal
Hat sich bedankt: 157 Mal
Danksagung erhalten: 95 Mal
Kontaktdaten:

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von stan23 » 16.05.2020, 21:32

Kannst du erkennen ob auf dem Resonator (das siberne Teil da in der Nähe des gelben Drahtes) eine 8 oder 16 steht?
Viele Grüße
Marco

RaspberryMatic als VM auf einem NUC mit Proxmox und USB-Funkmodul
~80 Geräte (HM, HmIP, HMW, HBW, AskSin)

Matsch
Beiträge: 688
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 11 Mal
Danksagung erhalten: 66 Mal

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von Matsch » 16.05.2020, 21:53

Als Spannungsregler ist ein 4B2X bestückt, das ist ein 3,3V Regler.

sixpack_de
Beiträge: 34
Registriert: 27.09.2019, 19:52
Hat sich bedankt: 8 Mal

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von sixpack_de » 16.05.2020, 23:01

stan23 hat geschrieben:
16.05.2020, 21:32
Kannst du erkennen ob auf dem Resonator (das siberne Teil da in der Nähe des gelben Drahtes) eine 8 oder 16 steht?
80.Z würde ich behaupten, habe das Photo ja in „gut“.

TomMajor
Beiträge: 953
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 52 Mal
Danksagung erhalten: 161 Mal
Kontaktdaten:

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von TomMajor » 17.05.2020, 01:02

sixpack_de hat geschrieben:
16.05.2020, 23:01
stan23 hat geschrieben:
16.05.2020, 21:32
Kannst du erkennen ob auf dem Resonator (das siberne Teil da in der Nähe des gelben Drahtes) eine 8 oder 16 steht?
80.Z würde ich behaupten, habe das Photo ja in „gut“.
Aus meiner Erinnerung eines Beitrags im Netz, stackoverflow o.ä., der 16 MHz Resonator wird nicht unbedingt mit 16 codiert, können auch Buchstaben sein, aber die 8 ist ein sicheres Zeichen das du einen 8 MHz Resonator hast.
Sollte also passen.
Viele Grüße,
Tom

sixpack_de
Beiträge: 34
Registriert: 27.09.2019, 19:52
Hat sich bedankt: 8 Mal

UPDATE: Re: ASKSIN Modul kein Anlernen möglich

Beitrag von sixpack_de » 18.05.2020, 10:13

Hi,

nachdem mein Programmer auf einmal keine COM Schnittstelle mehr geöffnet hat:

frischer Programmer, frister arduino (sicher 3,3V)

Programmiert:
a- ebenfalls 115200 baud (!)

b - ebenfalls kein Ready (kein Funkmodul connected, NUR der ARDUINO

Code: Alles auswählen

AskSin++ V4.1.5 (May 18 2020 10:08:20)
ID: F30101  Serial: UNITEMP002
Address Space: 32 - 358
FFFFFFFF
Init Storage: CAFE5FC8
CC init1
Ich weiss nicht weiter :(

Danke und Gruß,

Jan

FrankenKai
Beiträge: 24
Registriert: 04.05.2020, 21:31
System: CCU

Re: ASKSIN Modul kein Anlernen möglich

Beitrag von FrankenKai » 19.05.2020, 09:23

Hast du die Spannung an VCC gemessen?
Sie ist 3.3V wenn du an Raw ca. 6V anlegs?

Stelle mal Dein Target auf 328P 5V 16MHz um.
Kommt dann was mit 57600 Bps auf der seriellen?

Gruß
Kai

jp112sdl
Beiträge: 5122
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 190 Mal
Danksagung erhalten: 404 Mal
Kontaktdaten:

Re: UPDATE: Re: ASKSIN Modul kein Anlernen möglich

Beitrag von jp112sdl » 21.05.2020, 08:51

sixpack_de hat geschrieben:
18.05.2020, 10:13
Hi,

nachdem mein Programmer auf einmal keine COM Schnittstelle mehr geöffnet hat:

frischer Programmer, frister arduino (sicher 3,3V)

Programmiert:
a- ebenfalls 115200 baud (!)

b - ebenfalls kein Ready (kein Funkmodul connected, NUR der ARDUINO

Code: Alles auswählen

AskSin++ V4.1.5 (May 18 2020 10:08:20)
ID: F30101  Serial: UNITEMP002
Address Space: 32 - 358
FFFFFFFF
Init Storage: CAFE5FC8
CC init1
Ich weiss nicht weiter :(

Danke und Gruß,

Jan
Ich kann dein Problem reproduzieren.
Wenn ich einen Sketch den FreqTest mit der Arduino IDE 1.8.13 hochlade (egal ob AVR Boards 1.8.1 oder 1.8.2), bleibt die Ausgabe bei "CC init1" stehen und nix passiert.

Lade ich einen anderen Sketch hoch, verhält sich das Gerät seltsam. Kein Anlernen möglich, wirre Messwertausgaben,...

Mit Sloeber gehts.

Ich vermute mal, mit PlatformIO wird es auch keine Probleme geben.

Keine Ahnung, was da in der Arduino IDE zurzeit klemmt.

VG,
Jérôme ☕️

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“