HM-LC-SWX-SM: Schlechte RSSI Werte bei bidirektionalem Verkehr

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
Wolli1963
Beiträge: 10
Registriert: 23.09.2017, 14:08
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 3 Mal

HM-LC-SWX-SM: Schlechte RSSI Werte bei bidirektionalem Verkehr

Beitrag von Wolli1963 » 16.06.2020, 23:22

Hallo,

ich bin erst wenige Wochen mit dem Thema beschäftigt, aber bereits eifrig beim Basteln. Mit dem HM-LC-SWX-SM habe ich nun allerdings ein Problem mit der Qualität der Funkverbindung, getestet auf mehreren frei verdrahteten Funk/ProMini Modulen die zuvor mittels FreqTest abgeglichen wurden.
Problem: Die Senderichtung aus Sicht des Moduls zeigt extrem schlechte RSSI Werte im Bereich von -175 dBm oder übler, allerdings nur bei bidirektionalem Verkehr! Wenn ich also ein Relay von der CCU aus schalte, dann ist der Empfang des Moduls gut, das zurück gegebene Ergebnis jedoch sehr schlecht und unzuverlässig. Schalte ich nun das Relay über einen Pin am ProMini, dann ist die Sende-RSSI jedoch gut. Es scheint mir also, dass sich Empfang und Antwort irgendwie in die Quere kommen.

Intuitiv hätte ich nun versucht Rx und Tx zeitlich etwas auseinander zu ziehen, bin aber noch nicht so tief in die AskSin Sourcen abgetaucht um dafür einen einfachen Test aufzusetzen ...

Kennt jemand dieses Problem?

Danke und Grüße
Wolfgang

jp112sdl
Beiträge: 5456
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 218 Mal
Danksagung erhalten: 451 Mal
Kontaktdaten:

Re: HM-LC-SWX-SM: Schlechte RSSI Werte bei bidirektionalem Verkehr

Beitrag von jp112sdl » 17.06.2020, 07:27

Wolli1963 hat geschrieben:
16.06.2020, 23:22
Kennt jemand dieses Problem?
Hi. Das ist überhaupt gar kein Problem.
Das ist normales Homematic Verhalten.
ACK Level werden von der CCU nicht gemessen.
Erst wenn du das Gerät am Gerät selbst bedienst.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Wolli1963
Beiträge: 10
Registriert: 23.09.2017, 14:08
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 3 Mal

Re: HM-LC-SWX-SM: Schlechte RSSI Werte bei bidirektionalem Verkehr

Beitrag von Wolli1963 » 17.06.2020, 19:56

Hi Jérôme,

das finde ich nun allerdings ein wenig verwirrend:
Warum werden denn dann die RSSI Werte in der RaspberryMatic Gui direkt nach dem Event aktualisiert?
Das suggeriert dem unbedarften User doch, dass es hier ein Problem gibt, welches gar nicht exisitiert.
Und warum liefert zB ein Wassermelder in der Gui immer nur Sendewerte (aus Sicht des Melders), aber keine Empfangswerte?
Die Rolladenaktoren werden anscheinend komplett anders behandelt, hier zeigen manche Rx und Tx RSSI Werte und andere nur Rx ..
Tatsächlich zeigt aber auch mein Orginal HM-LC-sw1-LC die gleichen kruden Werte und auch hier hatte ich bereits einen Defekt vermutet.

Ist das dann ein Fehler in der RaspberryMatic?

Danke und Grüße
Wolfgang

jp112sdl
Beiträge: 5456
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 218 Mal
Danksagung erhalten: 451 Mal
Kontaktdaten:

Re: HM-LC-SWX-SM: Schlechte RSSI Werte bei bidirektionalem Verkehr

Beitrag von jp112sdl » 17.06.2020, 20:33

Wolli1963 hat geschrieben:
17.06.2020, 19:56
die RSSI Werte in der RaspberryMatic Gui
Wolli1963 hat geschrieben:
17.06.2020, 19:56
Das suggeriert dem unbedarften User doch, dass es hier ein Problem gibt, welches gar nicht exisitiert.
Ich persönlich mag da auch nichts weiter zu der Diskussion beitragen, denn ich war damals vor der Einführung der "RSSI Spalte" genau aus deinem genannten Grund strikt dagegen.


Die Spalte kommt ohne Erklärung daher und verleitet die User noch mehr rumzubasteln oder unnötig zu optimieren, was in den meisten Fällen nicht notwendig ist.

So lange es keine Probleme gibt, soll da stehen was will... meine Meinung.

Und bei der originalen CCU Firmware ist die Spalte auch nicht vorhanden.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Wolli1963
Beiträge: 10
Registriert: 23.09.2017, 14:08
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 3 Mal

Re: HM-LC-SWX-SM: Schlechte RSSI Werte bei bidirektionalem Verkehr

Beitrag von Wolli1963 » 17.06.2020, 21:26

Hi Jérôme,
vielen Dank für die schnellen Antworten.

Tatsächlich fand ich die RSSI Spalte eigentlich ziemlich hilfreich beim Optimieren der Antennenausrichtung meiner Zentrale und wollte sie nicht mehr missen. Vermutlich wäre es auch kein Hexenwerk diese Acks nicht zur Aktualiserung der Werte zu verwenden und das Problem zu fixen..
.. ich stimme allerdings zu, dass mich die Werte beim Schalter (und nur dort sehe solch schlechten Werte) tatsächlich dazu gebracht haben alles nochmal zu hinterfragen, hatte allerdings auch tatsächlich Probleme mit der Rückmeldung des Schalters.
Das hat sich nun nach Tausch der Spiralantenne gegen die 83mm Leitung merklich verbessert, wenngleich die gemeldeten RSSI Werte mit -85dBm immer noch nicht soo berauschend gut sind.

Viele Grüße
Wolfgang

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“