Probleme mit Arduino und CC1101

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

SaWo
Beiträge: 3
Registriert: 23.09.2019, 14:04

Probleme mit Arduino und CC1101

Beitrag von SaWo » 16.06.2020, 23:49

Hallo Zusammen,

vielleicht kann mir einer von euch helfen, oder eine Tip geben.
Ich bekomme den / die Arduinos nicht mit dem CC1101 Modulen zum laufen.
Versuche mich gerade an dem HB-UNI-RGB-LED-CTRL,
Habe es mit einem Arduino 2560 und 2560 Pro versucht, bekomme immer wieder diese Meldungen:

AskSin++ V4.1.5 (Jun 10 2020 20:57:13)
Address Space: 32 - 844
CC init1
Error at 00 expected: 2E read: 00
Error at 02 expected: 06 read: 00
Error at 03 expected: 0D read: 00
Error at 04 expected: E9 read: 00
Error at 05 expected: CA read: 00
Error at 07 expected: 0C read: 00
Error at 0B expected: 06 read: 00
Error at 0D expected: 21 read: 00
Error at 0E expected: 65 read: 00
Error at 0F expected: 6A read: 00
Error at 10 expected: C8 read: 00
Error at 11 expected: 93 read: 00
Error at 12 expected: 03 read: 00
Error at 15 expected: 34 read: 00
Error at 17 expected: 03 read: 00
Error at 18 expected: 18 read: 00
Error at 19 expected: 16 read: 00
Error at 1B expected: 43 read: 00
Error at 1E expected: 2F read: 00
Error at 1F expected: 65 read: 00
Error at 20 expected: 78 read: 00
Error at 23 expected: E9 read: 00
Error at 24 expected: 2A read: 00
Error at 25 expected: 1F read: 00
Error at 26 expected: 11 read: 00
Error at 3E expected: 03 read: 00
CC Version: 00
Error at 3E expected: C0 read: 00
- ready
SetLevel: 00 0000 FFFF
SetLevel: 00 0000 FFFF
SetLevel: 00 0000 FFFF
* Config Changed : List0
<- 0F 01 86 10 F34101 000000 06 01 00 00 00 00 - 237077

das war es auch, kein Anlernen des Aktor möglich.

- Arduino 2560 / Arduino 2560 PRO
- Levelshifter
- CC1101 Modul

Habe insgesamt 3 Aufbauten, mit Litzenkabel und Fädeldraht genutzt, bei allen das gleiche Problem.

Vielleicht hat ja jemand einen Tip.

Danke
Sawo

Wolli1963
Beiträge: 10
Registriert: 23.09.2017, 14:08
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 3 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von Wolli1963 » 16.06.2020, 23:58

Hi,
nach meiner (sehr kurzen) Erfahrung ein Problem mit der SPI Schnittstelle zum Funkmodul. Hatte das bei mir wenn der SPI-Flasher beim Betrieb noch aufgesteckt war. Mit einem Oszilloskop sieht man eigentlich recht schnell, wo es hakt .. sind ja nicht soo viele Leitungen .. ;-)
Grüße
Wolfgang

SaWo
Beiträge: 3
Registriert: 23.09.2019, 14:04

Re: Probleme mit Arduino und CC1101

Beitrag von SaWo » 17.06.2020, 00:04

Hallo Wolfgang,

dank für deine Antwort.
Einen SPI-Flasher habe ich nicht.
Habe die Konfig über den USB Port und Arduino aufgespielt.

sawo

TomMajor
Beiträge: 1010
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 55 Mal
Danksagung erhalten: 168 Mal
Kontaktdaten:

Re: Probleme mit Arduino und CC1101

Beitrag von TomMajor » 17.06.2020, 00:33

- checke noch mal alle Verb. zwischen AVR, Levelshifter und CC1101 auf Durchgang und Kurzschluß
- sicher das der verwendete Levelshifter für die Aufgabe geeignet ist?
- eventuell für den AskSinPP Start ein 3,3V AVR wie den Pro Mini ohne Shifter nehmen um sich so der Sache etwas langsamer zu nähern.. :)
Viele Grüße,
Tom

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 9 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 19.06.2020, 20:36

Ich habe die selben Probleme obwohl der Sketch bereits in dieser Konfiguration funktionierte. Egal ob V4 oder Master. Tastendruck wird auch nicht erkannt.

jp112sdl
Beiträge: 5433
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 216 Mal
Danksagung erhalten: 445 Mal
Kontaktdaten:

Re: Probleme mit Arduino und CC1101

Beitrag von jp112sdl » 19.06.2020, 20:47

maxx3105 hat geschrieben:
19.06.2020, 20:36
Ich habe die selben Probleme obwohl der Sketch bereits in dieser Konfiguration funktionierte.
Dass beim Init es CC1101 nur 00 gelesen wird?
maxx3105 hat geschrieben:
19.06.2020, 20:36
Tastendruck wird auch nicht erkannt.
Du meinst den Configtaster zum Anlernen?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 9 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 19.06.2020, 23:21

jp112sdl hat geschrieben:
19.06.2020, 20:47
Du meinst den Configtaster zum Anlernen?
Ja genau.

Code: Alles auswählen

AskSin++ V4.0.3 (Jun 19 2020 20:32:26)
Address Space: 32 - 844
CC init1
CC Version: 14
 - ready
SetLevel: 00 0000 FFFF
SetLevel: 00 0000 FFFF
SetLevel: 00 0000 FFFF
* Config Changed       : List0
<- 0F 01 86 10 F34101 000000 06 01 00 00 00 00  - 1520
<- 0E 02 86 10 F34101 000000 06 02 00 00 00  - 1618
<- 0E 03 86 10 F34101 000000 06 03 00 00 00  - 1719
ignore 0C 49 84 70 345678 596FB9 00 E2 39  - 2828
ignore 0C 66 86 5A 64CBAE 000000 A0 DC 33  - 4373
ignore 0C B4 84 70 64CF5D 000000 00 EF 30  - 5036

jp112sdl
Beiträge: 5433
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 216 Mal
Danksagung erhalten: 445 Mal
Kontaktdaten:

Re: Probleme mit Arduino und CC1101

Beitrag von jp112sdl » 20.06.2020, 06:31

FreqTest mal laufen lassen

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 9 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 20.06.2020, 11:01

Code: Alles auswählen

AskSin++ V4.0.3 (Jun 20 2020 10:49:14)
CC init1
Error at 00 expected: 2E read: FF
Error at 02 expected: 06 read: FF
Error at 03 expected: 0D read: FF
Error at 04 expected: E9 read: FF
Error at 05 expected: CA read: FF
Error at 07 expected: 0C read: FF
Error at 0B expected: 06 read: FF
Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: 6A read: FF
Error at 10 expected: C8 read: FF
Error at 11 expected: 93 read: FF
Error at 12 expected: 03 read: FF
Error at 15 expected: 34 read: FF
Error at 17 expected: 03 read: FF
Error at 18 expected: 18 read: FF
Error at 19 expected: 16 read: FF
Error at 1B expected: 43 read: FF
Error at 1E expected: 2F read: FF
Error at 1F expected: 65 read: FF
Error at 20 expected: 78 read: FF
Error at 23 expected: E9 read: FF
Error at 24 expected: 2A read: FF
Error at 25 expected: 1F read: FF
Error at 26 expected: 11 read: FF
Error at 3E expected: 03 read: FF
CC Version: FF
Error at 3E expected: C0 read: FF
 - ready
Start searching ...
Freq 0x21656A: Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: 6A read: FF
  0/0
Freq 0x2165BA: Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: BA read: FF
  0/0
Freq 0x21651A: Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: 1A read: FF
Der Aufbau funktionierte bis vor kurzem noch als HB-UNI-RGB-LED-CTRL, habe dann den HB-OU-RGB-STACKFIRE geflasht, seit dem geht nichts mehr. Es befindet sich zwar kein Level-Shift dazwischen, aber das selbst der Config-Taster nicht erkannt wird hatte ich noch nicht.

jp112sdl
Beiträge: 5433
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 216 Mal
Danksagung erhalten: 445 Mal
Kontaktdaten:

Re: Probleme mit Arduino und CC1101

Beitrag von jp112sdl » 20.06.2020, 11:15

maxx3105 hat geschrieben:
20.06.2020, 11:01
Error at 00 expected: 2E read: FF
Hast du den FreqTest aus dem Stackfire-Repo genommen?
Dort sind die Pins scheinbar entsprechend dem 2560 angepasst.

Mehr fällt mir sonst auch nicht ein. Wenn nichts an der Hardware verändert wurde, könnte tatsächlich ein Defekt vorliegen

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“