Probleme mit Arduino und CC1101

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 10 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 20.06.2020, 11:27

[/quote]
Hast du den FreqTest aus dem Stackfire-Repo genommen?
Dort sind die Pins scheinbar entsprechend dem 2560 angepasst.

Mehr fällt mir sonst auch nicht ein. Wenn nichts an der Hardware verändert wurde, könnte tatsächlich ein Defekt vorliegen
[/quote]

Bei beiden Sketches das selbe. Auch wenn ich den HB-UNI-RGB-LED-CTRL darauf habe. Ob das wieder mit der Arduino IDE zusammen hängt?
Der HB-RC-12-EP kompiliert auch nicht mehr. Welche Software verwendet ihr?
Zuletzt geändert von maxx3105 am 20.06.2020, 12:30, insgesamt 1-mal geändert.

jp112sdl
Beiträge: 5439
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 217 Mal
Danksagung erhalten: 445 Mal
Kontaktdaten:

Re: Probleme mit Arduino und CC1101

Beitrag von jp112sdl » 20.06.2020, 12:24

maxx3105 hat geschrieben:
20.06.2020, 11:27
Der HB-RC-12-EP kompiliert auch nicht mehr.
Welche Meldung kommt denn da?
Ggf. diesbezüglich einen neuen Thread öffnen.

Das ist jetzt hier ziemlich wild durcheinander
maxx3105 hat geschrieben:
20.06.2020, 11:27
wieder mit der Arduino IDE zusammen hängt?
Warum wieder?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 10 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 20.06.2020, 12:39

jp112sdl hat geschrieben:
20.06.2020, 12:24
Das ist jetzt hier ziemlich wild durcheinander
Sorry mich nerft die Arduino IDE
jp112sdl hat geschrieben:
20.06.2020, 12:24
Welche Meldung kommt denn da?
Ggf. diesbezüglich einen neuen Thread öffnen.
Da gehe ich zum entsprechenden Thread.
jp112sdl hat geschrieben:
20.06.2020, 12:24
Warum wieder?
Seit den Update auf 1.8.11 bzw 1.8.13 habe Probleme mit der Arduino IDE. Sketches funken nicht die davor noch gingen usw.

jp112sdl
Beiträge: 5439
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 217 Mal
Danksagung erhalten: 445 Mal
Kontaktdaten:

Re: Probleme mit Arduino und CC1101

Beitrag von jp112sdl » 20.06.2020, 12:46

maxx3105 hat geschrieben:
20.06.2020, 12:39
Seit den Update auf 1.8.11 bzw 1.8.13 habe Probleme mit der Arduino IDE. Sketches funken nicht die davor noch gingen usw.
Hmm, auf dem Mac hatte ich mit keiner Version da bis jetzt ein Problem.
Zumal die IDE selbst nix macht... sondern der Compiler. Und da gibt es (unabhängig von der IDE Version) unterschiedliche "AVR Boards" Versionen.
Naja, wie auch immer...
Primär nutze ich jedoch Sloeber.

Btw.: Travis kompiliert die hier aufgeführten Sketche regelmäßig.
So lange dort "Build passing" Bild steht, ist grundsätzlich erstmal der Sketch in Verbindung mit dem master-Branch "kompilierfähig".

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 10 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 21.06.2020, 18:05

So bin nun zufällig auf etwas gestoßen. Habe den Config Button mit dem Messgerät unter Spannung auf Durchgang gemessen. Ohne den Button zu drücken wurde im Serial Monitor der Tastendruck erkannt. Kann es sein das hier High und Low vertauscht sind?

Martin62
Beiträge: 135
Registriert: 09.12.2019, 21:24
Hat sich bedankt: 17 Mal
Danksagung erhalten: 8 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von Martin62 » 21.06.2020, 19:39

Die Eingänge sind sehr empfindlich. Bei offenen Eingängen reicht schon das berühren mit den Fingern aus. Dazu kommt, wenn du auf Widerstand misst, das Messgerät eine Spannung abgibt und dadurch auch ein umschalten von LOW auf HIGH provoziert wird oder umgekehrt.
Gruß Martin
Gruß Martin

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 10 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 29.06.2020, 11:15

Frequenztest mit Arduino Mega Core und Level-Shifter.

Code: Alles auswählen

AskSin++ V4.1.5 (Jun 29 2020 11:09:21)
CC init1
Error at 00 expected: 2E read: FF
Error at 02 expected: 06 read: FF
Error at 03 expected: 0D read: FF
Error at 04 expected: E9 read: FF
Error at 05 expected: CA read: FF
Error at 07 expected: 0C read: FF
Error at 0B expected: 06 read: FF
Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: 6A read: FF
Error at 10 expected: C8 read: FF
Error at 11 expected: 93 read: FF
Error at 12 expected: 03 read: FF
Error at 15 expected: 34 read: FF
Error at 17 expected: 03 read: FF
Error at 18 expected: 18 read: FF
Error at 19 expected: 16 read: FF
Error at 1B expected: 43 read: FF
Error at 1E expected: 2F read: FF
Error at 1F expected: 65 read: FF
Error at 20 expected: 78 read: FF
Error at 23 expected: E9 read: FF
Error at 24 expected: 2A read: FF
Error at 25 expected: 1F read: FF
Error at 26 expected: 11 read: FF
Error at 3E expected: 03 read: FF
CC Version: FF
Error at 3E expected: C0 read: FF
 - ready
Start searching ...
Freq 0x21656A 868.300 MHz: Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: 6A read: FF
  0
Freq 0x2165BA 868.332 MHz: Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: BA read: FF
  0
Freq 0x21651A 868.268 MHz: Error at 0D expected: 21 read: FF
Error at 0E expected: 65 read: FF
Error at 0F expected: 1A read: FF
  0
Freq 0x21660A 868.363 MHz: Error at 0D expected: 21 read: FF
Error at 0E expected: 66 read: FF
Error at 0F expected: 0A read: FF

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 10 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 29.06.2020, 11:30

Frequenztest Arduino Mega Core ohne Level-Shifter.

Code: Alles auswählen

AskSin++ V4.1.5 (Jun 29 2020 11:24:41)
CC init1
Error at 00 expected: 2E read: 00
Error at 02 expected: 06 read: 00
Error at 03 expected: 0D read: 00
Error at 04 expected: E9 read: 00
Error at 05 expected: CA read: 00
Error at 07 expected: 0C read: 00
Error at 0B expected: 06 read: 00
Error at 0D expected: 21 read: 00
Error at 0E expected: 65 read: 00
Error at 0F expected: 6A read: 02
Error at 10 expected: C8 read: 00
Error at 11 expected: 93 read: 00
Error at 12 expected: 03 read: 00

maxx3105
Beiträge: 106
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 10 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit Arduino und CC1101

Beitrag von maxx3105 » 29.06.2020, 12:05

Die Verbindung vom Mega Core zum CC1101 ist identisch. Config Button wird an beiden nicht erkannt. Anlernmodus lässt sich nur auslösen per externer Spannung auf Pin 13. Nach erfolgtem Anlernen Funktionieren beide Geräte (HB-UNI-RGB-LED-CTRL, HB-OU-RGB-STACKFIRE) normal.

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“