Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von jp112sdl » 31.07.2020, 14:52

Kann ich leider nicht reproduzieren.
Dateianhänge
Bildschirmfoto 2020-07-31 um 14.52.36.png

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von jp112sdl » 31.07.2020, 14:55

Direkt nach dem Anlernen war das Gerät auch noch nicht da.
Aber nach einem Reboot.

Es wird doch wohl nicht an dem °C liegen?
Das hab ich bei mir schon gefixt.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von jp112sdl » 31.07.2020, 14:59

Du kannst dir die neue XML mal holen. Per SSH auf der CCU:

Code: Alles auswählen

wget -O /usr/local/addons/jp-hb-devices-addon/firmware/rftypes/hb-wds40-thp-o.xml https://raw.githubusercontent.com/jp112sdl/JP-HB-Devices-addon/master/src/addon/firmware/rftypes/hb-wds40-thp-o.xml
Anschließend noch mal neustarten

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

magnum1795
Beiträge: 86
Registriert: 13.05.2020, 17:56
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 14 Mal
Danksagung erhalten: 7 Mal

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von magnum1795 » 31.07.2020, 15:05

Merkwürdig, habe nun auch noch ein anderes Problem. Wenn ich in Systemsteuerung > XML-API und nun versuche die statelist.cgi zu öffnen, kommt folgender Fehler. Das ist erst nach den Anlernen des HB-WDS40 und Neustart des Raspberry. Vorher ging noch alles und ich konnte die Liste öffnen.

PS: oh, Sorry. Unsere Beiträge haben sich überschnitten. habe nun mal per ssh das ausgeführt. Raspberry startet gerade neu. mal schauen was dann ist

PSS: mhhh??? Irgendwie hat das mit ssh nicht geklappt, wird immer noch das "Viereck" angezeigt. Also ich habe Putty geöffnet, mich mit der CCU3 verbunden (root und Passwort) dann deine komplette Zeile von oben eingegeben und Enter gedrückt.. Anschließend habe ich die CCU komplett neu gestartet.

Was habe ich denn da schon wieder falsch gemacht?
Dateianhänge
fehler 1.jpg
Zuletzt geändert von magnum1795 am 31.07.2020, 15:17, insgesamt 2-mal geändert.

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von jp112sdl » 31.07.2020, 15:08

"invalid character" könnte wirklich mit dem °C zu tun haben

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

magnum1795
Beiträge: 86
Registriert: 13.05.2020, 17:56
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 14 Mal
Danksagung erhalten: 7 Mal

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von magnum1795 » 31.07.2020, 15:17

immer noch selber Fehler, Grad wird nicht angezeigt (siehe oben PSS)

Habe es nun insgesamt 3 mal so probiert, immer noch der selbe Fehler. Müsste also doch noch an was anderen hängen oder ich mache es Grundsätzlich falsch.
Dateianhänge
fehler 3.jpg
fehler 2.jpg
Zuletzt geändert von magnum1795 am 31.07.2020, 15:29, insgesamt 1-mal geändert.

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von jp112sdl » 31.07.2020, 15:26

Browsercache gelöscht?
Gerät mal neu anlernen?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von jp112sdl » 31.07.2020, 15:28

Wenn der Download korrekt war, dann muss das so aussehen:

Code: Alles auswählen

[email protected]:~# grep unit /firmware/rftypes/hb-wds40-thp-o.xml

      <logical type="integer" min="0" max="10000" default="0" unit="m" />
          <logical type="float" min="-40.0" max="80.0" unit="?C" />
          <logical type="integer" min="0" max="99" unit="%" />
          <logical type="float" min="500.0" max="1100.0" unit="hPa" />

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Hackertomm
Beiträge: 239
Registriert: 18.04.2018, 12:32
Danksagung erhalten: 5 Mal

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von Hackertomm » 31.07.2020, 15:29

jp112sdl hat geschrieben:
30.07.2020, 21:59
Keinen der 3 Werte? Oder nur Luftdruck nicht?
Den kompletten Sensor!
Der erscheint gar nicht in der Auswahl für die Diagramme.
Trotz aktualisierter XML.
Für mich ist das aber wichtig, da ich mir die Daten meiner 3 Sensoren als Diagramm darstellen lasse.
Weshalb ich den HB-WDS40-THP-O-BME280 Sketch wieder runter geschmissen habe.
Es läuft wieder der HM-WDS40-TH-I-BME280 Sketch, der wieder Daten ins Diagramm bringt.
Gruß
Hackertomm

Virtual Image auf einer Qnap TS-453pro, 2GHZ Celeron u. 8GB RAM, aktuell Raspberry X86, Vers. 3.51.6.20200621

magnum1795
Beiträge: 86
Registriert: 13.05.2020, 17:56
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 14 Mal
Danksagung erhalten: 7 Mal

Re: Für was ist der Sketch "HB-WDS40-THP-O-BME280"?

Beitrag von magnum1795 » 31.07.2020, 15:32

neu ab und angelernt habe ich nicht. Aber bei mir sieht es auch etwas anders aus als bei deinen Screen.

PS: so sieht meine .xml datei aus.

Könntest du bitte mal die komplette .xml hier mit anhängen? Die kann ich ja dann komplett ersetzen. Mache das mit WinSCP

Code: Alles auswählen

<?xml version="1.0" encoding="ISO-8859-1"?>
<device version="1" rx_modes="CONFIG,WAKEUP" cyclic_timeout="900">
  <supported_types>
    <type name="HB-WDS40-THP-O" id="HB-WDS40-THP-O">
      <parameter index="10.0" size="2.0" const_value="0xF307" />
    </type>
  </supported_types>
  <paramset type="MASTER" id="ash550_dev_master">
    <parameter id="HBWEA_ALTITUDE">
      <logical type="integer" min="0" max="10000" default="0" unit="m" />
      <physical type="integer" interface="config" list="0" index="34" size="2" />
    </parameter>
  </paramset>
  <channels>
    <channel index="0" type="MAINTENANCE" ui_flags="internal" class="maintenance" count="1">
      <paramset type="MASTER" id="maint_ch_master" />
      <paramset type="VALUES" id="maint_ch_values">
        <parameter id="UNREACH" operations="read,event" ui_flags="service">
          <logical type="boolean" />
          <physical type="integer" interface="internal" value_id="UNREACH" />
        </parameter>
        <parameter id="STICKY_UNREACH" operations="read,write,event" ui_flags="service,sticky">
          <logical type="boolean" />
          <physical type="integer" interface="internal" value_id="STICKY_UNREACH" />
        </parameter>
        <parameter id="CONFIG_PENDING" operations="read,event" ui_flags="service">
          <logical type="boolean" />
          <physical type="integer" interface="internal" value_id="CONFIG_PENDING" />
        </parameter>
        <parameter id="LOWBAT" operations="read,event" ui_flags="service">
          <logical type="boolean" />
          <physical type="integer" interface="internal" value_id="LOWBAT" />
        </parameter>
        <parameter id="RSSI_DEVICE" operations="read,event">
          <logical type="integer" />
          <physical type="integer" interface="internal" value_id="RSSI_DEVICE" />
        </parameter>
        <parameter id="RSSI_PEER" operations="read,event">
          <logical type="integer" />
          <physical type="integer" interface="internal" value_id="RSSI_PEER" />
        </parameter>
      </paramset>
    </channel>
    <channel index="1" type="WEATHER">
      <link_roles>
        <source name="WEATHER_TH" />
      </link_roles>
      <paramset type="MASTER" id="ash550_ch_master" />
      <paramset type="VALUES" id="ash550_ch_values">
        <parameter id="TEMPERATURE" operations="read,event">
          <logical type="float" min="-40.0" max="80.0" unit="°C" />
          <physical type="integer" interface="command" value_id="TEMPERATURE">
            <event frame="WEATHER_EVENT" />
          </physical>
          <conversion type="float_integer_scale" factor="10.0" />
          <description>
            <field id="AutoconfRoles" value="WEATHER" />
          </description>
        </parameter>
        <parameter id="HUMIDITY" operations="read,event">
          <logical type="integer" min="0" max="99" unit="%" />
          <physical type="integer" interface="command" value_id="HUMIDITY">
            <event frame="WEATHER_EVENT" />
          </physical>
          <description>
            <field id="AutoconfRoles" value="WEATHER" />
          </description>
        </parameter>
        <parameter id="AIR_PRESSURE" operations="read,event">
          <logical type="float" min="500.0" max="1100.0" unit="hPa" />
          <physical type="integer" interface="command" value_id="AIR_PRESSURE">
            <event frame="WEATHER_EVENT" />
          </physical>
          <conversion type="float_integer_scale" factor="10.0" />
          <description>
            <field id="AutoconfRoles" value="WEATHER" />
          </description>
        </parameter>
      </paramset>
      <paramset type="LINK" id="ash550_ch_link" />
    </channel>
  </channels>
  <frames>
    <frame id="WEATHER_EVENT" direction="from_device" event="true" fixed_channel="1" type="0x70">
      <parameter type="integer" signed="true" index="9.0" size="1.7" param="TEMPERATURE" />
      <parameter type="integer" index="11.0" size="1.0" param="HUMIDITY" />
      <parameter type="integer" index="12.0" size="2.0" param="AIR_PRESSURE" />
    </frame>
  </frames>
  <paramset_defs />
</device>
Dateianhänge
fehler 4.jpg
Zuletzt geändert von magnum1795 am 31.07.2020, 15:43, insgesamt 2-mal geändert.

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“