Selbstbausensor wird immer wieder zum BI

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

firefox_i
Beiträge: 158
Registriert: 04.10.2018, 19:07
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Selbstbausensor wird immer wieder zum BI

Beitrag von firefox_i » 26.01.2021, 12:14

Hallo zusammen,
ich hab 2 der Bausätze von Smartkram im Einsatz : https://smartkram.de/diy-bausatze/#luft ... -bausaetze

Beide sind als Außensensor in Betrieb - und somit aktuell den recht tiefen Temperaturen ausgesetzt.
Bei beiden habe ich normale 1V5 Alkaline Batterien drin.

Ich habe nun zum wiederholten mal den Effekt, dass die zum BI werden.
Die Seite https://github.com/TomMajor/SmartHome/t ... Protection hab ich mir schon angeschaut.

Ich hab momentan noch folgendes Verständnisproblem:
Ich habe am BOD nichts verändert, sollte also deaktiviert sein.
Der Arduino Pro Mini hat nen 8MHz Takt, also ist der doch nur bis knapp 2V8 gespekt....

Ist es da nicht schon generell etwas vermessen, das nur mit 3V zu betreiben. Da ist ja doch recht wenig Luft zu der "offspec"

Oder wo ist hier mein Denkfehler?

Was würdet ihr machen, um den BI zu verhindern?

Bin grad ehrlich gesagt verunsichert was ich tun soll...

Danke
S.
Gruß Sven

Produktivsytem mit CCU2, knapp 60 Geräte, Visu per HPCL; Automatisierung einer Praxis bzgl. Überwachung, Heizung usw.
Experimentalsystem mit Raspi B3+, dort aktuell dran eigene Sensoren zu bauen (Serverschranküberwachung)

Hardwareentwickler und bisschen Ahnung von Programmierung.

jp112sdl
Beiträge: 8130
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 447 Mal
Danksagung erhalten: 1010 Mal
Kontaktdaten:

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von jp112sdl » 26.01.2021, 12:21

firefox_i hat geschrieben:
26.01.2021, 12:14
Ich habe am BOD nichts verändert, sollte also deaktiviert sein.
Nein, die BOD ist default auf 2.7V eingestellt.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Martin62
Beiträge: 400
Registriert: 09.12.2019, 21:24
Hat sich bedankt: 77 Mal
Danksagung erhalten: 27 Mal

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von Martin62 » 26.01.2021, 12:29

Ersteinmal würde ich den Strom messen den die Schaltung verbraucht. Normalerweise halten die Batterien eine ganze Weile je nach Anwendung natürlich. Alternativ kann man einen Lithium Ion Akku nehmen und mit einem DC DC Regler (der MCP 1703 ist z.B. sehr Strom sparend) die Schaltung versorgen. Zum laden nehme ich dabei ein USB Lader mit Akkuüberwachung.
Der Schaltet bei unterschreiten einer Spannung einfach den Akku ab. Zum aufladen dann einfach ein USB Ladegerät oder Powerbank und es läuft wieder. Den Uni Sensor von Tom habe ich so seit einem 1/2 Jahr draußen ohne nachladen bisher.
Nachtrag: Der BME 280 ist etwas Strom "hungrig" Diese Fühler habe ich auch mit LI Akku versorgt und USB Laderegler. Laufen bei mir aber erst seit 2 Monaten.
Zuletzt geändert von Martin62 am 26.01.2021, 12:34, insgesamt 1-mal geändert.
Gruß Martin

HMSteve
Beiträge: 149
Registriert: 20.08.2019, 06:23
Hat sich bedankt: 5 Mal
Danksagung erhalten: 23 Mal

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von HMSteve » 26.01.2021, 12:32

Hallo,

BOD disablen waere der erste Schritt. Allerdings hatte ich auch schon einen BI, waehrend der AVR durch einen MCP111 im Reset gehalten wurde. Der CC1101 sendete einfach munter weiter. Darum setze ich bei neuen Projekten auch immer die Vcc-Abschaltung des CC1101 mittels FET um, bspw hier: https://github.com/HMSteve/PCBs/tree/ma ... 1284_Board. Geht natuerlich nicht mit Deiner fertigen Platine, aber als Idee fuer die Zukunft.
TomMajor hat dazu sehr schoene Ausfuehrungen aufgeschrieben: https://github.com/TomMajor/SmartHome/t ... Protection


Viele Gruesse,
Stephan

jp112sdl
Beiträge: 8130
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 447 Mal
Danksagung erhalten: 1010 Mal
Kontaktdaten:

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von jp112sdl » 26.01.2021, 12:42

HMSteve hat geschrieben:
26.01.2021, 12:32
Allerdings hatte ich auch schon einen BI, waehrend der AVR durch einen MCP111 im Reset gehalten wurde.
Bei der BOD-Auslösung des AVR selbst (bei Unterschreiten der BOD Schwelle) passiert ja letztendlich nichts anderes.
HMSteve hat geschrieben:
26.01.2021, 12:32
Der CC1101 sendete einfach munter weiter.
Das hatte ich auch mal reproduziert... sieht man in Toms Link schön. :)
HMSteve hat geschrieben:
26.01.2021, 12:32
immer die Vcc-Abschaltung des CC1101 mittels FET
halte ich auch für die sinnvollste Lösung. So hat es eQ-3 bei einigen Geräten auch gemacht

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Martin62
Beiträge: 400
Registriert: 09.12.2019, 21:24
Hat sich bedankt: 77 Mal
Danksagung erhalten: 27 Mal

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von Martin62 » 26.01.2021, 12:53

Sowas nehme ich z.B. .Kann man auch eine Solarzelle anklemmen, ideal für draußen.
https://www.ebay.de/itm/1S-Lithium-Lipo ... %3A2334524
Gruß Martin

firefox_i
Beiträge: 158
Registriert: 04.10.2018, 19:07
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von firefox_i » 26.01.2021, 12:54

jp112sdl hat geschrieben:
26.01.2021, 12:21
Nein, die BOD ist default auf 2.7V eingestellt.
Sicher ?
Laut ATmega328p Datenblatt sind die Fuses ab Werk auf 111 gesetzt was einem disabled entspricht.
Oder werden die vom Bootloader gesetzt?

Ich frag deshalb, weil ich den Bootloader nicht geflasht habe....
Gruß Sven

Produktivsytem mit CCU2, knapp 60 Geräte, Visu per HPCL; Automatisierung einer Praxis bzgl. Überwachung, Heizung usw.
Experimentalsystem mit Raspi B3+, dort aktuell dran eigene Sensoren zu bauen (Serverschranküberwachung)

Hardwareentwickler und bisschen Ahnung von Programmierung.

firefox_i
Beiträge: 158
Registriert: 04.10.2018, 19:07
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von firefox_i » 26.01.2021, 12:59

Martin62 hat geschrieben:
26.01.2021, 12:53
Sowas nehme ich z.B. .Kann man auch eine Solarzelle anklemmen, ideal für draußen.
https://www.ebay.de/itm/1S-Lithium-Lipo ... %3A2334524
Danke für den Link

Der schaltet aber den Ausgang bei unter 2V5 ab....läuft denn der Arduino da noch?
Wie gesagt ist doch der bei 8MHz garnicht so weit runter spezifiziert...

S.
Gruß Sven

Produktivsytem mit CCU2, knapp 60 Geräte, Visu per HPCL; Automatisierung einer Praxis bzgl. Überwachung, Heizung usw.
Experimentalsystem mit Raspi B3+, dort aktuell dran eigene Sensoren zu bauen (Serverschranküberwachung)

Hardwareentwickler und bisschen Ahnung von Programmierung.

jp112sdl
Beiträge: 8130
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 447 Mal
Danksagung erhalten: 1010 Mal
Kontaktdaten:

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von jp112sdl » 26.01.2021, 13:01

firefox_i hat geschrieben:
26.01.2021, 12:54
jp112sdl hat geschrieben:
26.01.2021, 12:21
Nein, die BOD ist default auf 2.7V eingestellt.
Sicher ?
Laut ATmega328p Datenblatt sind die Fuses ab Werk auf 111 gesetzt was einem disabled entspricht.
Oder werden die vom Bootloader gesetzt?

Ich frag deshalb, weil ich den Bootloader nicht geflasht habe....
Sofern du einen Pro Mini verwendest, wie in dem Bausatz auf Smartkram abgebildet bin ich mir ganz sicher

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Martin62
Beiträge: 400
Registriert: 09.12.2019, 21:24
Hat sich bedankt: 77 Mal
Danksagung erhalten: 27 Mal

Re: Selbstbausensor wird immer wieder zum BI

Beitrag von Martin62 » 26.01.2021, 13:05

Ja
firefox_i hat geschrieben:
26.01.2021, 12:59
Martin62 hat geschrieben:
26.01.2021, 12:53
Sowas nehme ich z.B. .Kann man auch eine Solarzelle anklemmen, ideal für draußen.
https://www.ebay.de/itm/1S-Lithium-Lipo ... %3A2334524
Danke für den Link

Der schaltet aber den Ausgang bei unter 2V5 ab....läuft denn der Arduino da noch?
Wie gesagt ist doch der bei 8MHz garnicht so weit runter spezifiziert...

Ja, Fuse habe ich geändert.
Gruß Martin

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“