[Gelöst] Falsche Fuse gesetzt, Atmega328P nicht mehr ansprechbar

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Benutzeravatar
stan23
Beiträge: 1940
Registriert: 13.12.2016, 21:14
System: Alternative CCU (auf Basis OCCU)
Wohnort: Altmühltal
Hat sich bedankt: 500 Mal
Danksagung erhalten: 301 Mal
Kontaktdaten:

Re: [Gelöst] Falsche Fuse gesetzt, Atmega328P nicht mehr ansprechbar

Beitrag von stan23 » 01.09.2022, 17:03

didik1968 hat geschrieben:
01.09.2022, 13:50
Oder gibt es noch eine Einstellung die gemacht werden muss?
Hast du diese Einstellung vorgenommen?
Wenn der angeschlossene AVR-Controller trotzdem nicht antworten will, kontrollieren Sie bitte zunächst die Leitungsverbindungen. MISO an MISO und MOSI an MOSI, das wird häufig vertauscht. Hat der angeschlossene Microcontroller eine Stromversorgung? Eventuell fehlt dem AVR-Controller der Systemtakt, weil die Fuses auf externen Takt eingestellt sind. In diesem Fall kann ein Quarz zur Takterzeugung an die XTAL-Pins des Controllers angeschlossen werden oder das Taktsignal von PIN3 (OSC) der 10-poligen Stiftleiste auf XTALIN oder XTAL1 (siehe Datenblatt des Controllers) gelegt werden. Die Taktfrequenz kann mit ATMEL-Studio über die Funktion „Board-Setting – Clock Generator“ eingestellt werden.
AtmelStudio_Clock_Generator.png
AtmelStudio_Clock_Generator.png (19.25 KiB) 141 mal betrachtet
Viele Grüße
Marco

RaspberryMatic als VM auf einem NUC mit Proxmox und USB-Funkmodul
~80 Geräte (HM, HmIP, HMW, HBW, AskSin)

didik1968
Beiträge: 53
Registriert: 16.05.2018, 17:07
Hat sich bedankt: 1 Mal

Re: [Gelöst] Falsche Fuse gesetzt, Atmega328P nicht mehr ansprechbar

Beitrag von didik1968 » 02.09.2022, 08:10

Ja gerade nocheinmal alle Verbindungen überprüft und auch die Einstellungen.
Funktioniert nicht :cry:

Benutzeravatar
stan23
Beiträge: 1940
Registriert: 13.12.2016, 21:14
System: Alternative CCU (auf Basis OCCU)
Wohnort: Altmühltal
Hat sich bedankt: 500 Mal
Danksagung erhalten: 301 Mal
Kontaktdaten:

Re: [Gelöst] Falsche Fuse gesetzt, Atmega328P nicht mehr ansprechbar

Beitrag von stan23 » 02.09.2022, 14:13

Dann habe ich auch keine anderen Idee mehr :(
Viele Grüße
Marco

RaspberryMatic als VM auf einem NUC mit Proxmox und USB-Funkmodul
~80 Geräte (HM, HmIP, HMW, HBW, AskSin)

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“