Asksin Geräte nach Update CCU3 keine Verbindung

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
botti
Beiträge: 11
Registriert: 15.12.2020, 09:00
System: CCU
Hat sich bedankt: 1 Mal

Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von botti » 20.11.2021, 11:26

Hallo zusammen,

ich habe heute die CCU3 Firmware auf 3.61.5 geupdated.

Es lief alles nach Plan. Nur die Asksin Geräte (HM-SEC-MDIR) funktionieren nicht mehr.

Sie scheinen nicht mehr mit der CCU zu kommunizieren.

Hab dann mal einen gelöscht und versucht ihn neu anzulernen. Leider ohne Erfolg.
Technisch müssen sie ok sein, weil alle drei vor dem Update ohne Probleme gelaufen haben.

Habt Ihr eine Idee?

Benutzeravatar
Baxxy
Beiträge: 4552
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 308 Mal
Danksagung erhalten: 822 Mal

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von Baxxy » 20.11.2021, 11:40

botti hat geschrieben:
20.11.2021, 11:26
die CCU3 Firmware auf 3.61.5 geupdated
Von welcher Version kamst du denn?

botti
Beiträge: 11
Registriert: 15.12.2020, 09:00
System: CCU
Hat sich bedankt: 1 Mal

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von botti » 20.11.2021, 11:43

das weiß ich nicht mehr genau. Ich glaube es war 3.53.x

Benutzeravatar
Baxxy
Beiträge: 4552
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 308 Mal
Danksagung erhalten: 822 Mal

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von Baxxy » 20.11.2021, 11:50

botti hat geschrieben:
20.11.2021, 11:43
Ich glaube es war 3.53.x
Ok, mit 3.57.4 gab es eine neue Firmware für das Funkmodul der CCU3.
Da wurden die Funkfrequenzen etwas "korrigiert" was vermutlich dazu führt das deine Selbstbaugeräte und die CCU3 nun aneinander vorbeireden.
Du musst die betroffenen Geräte mit dem sogenannten FreqTest neu "kalibrieren"

Grüße, Baxxy

botti
Beiträge: 11
Registriert: 15.12.2020, 09:00
System: CCU
Hat sich bedankt: 1 Mal

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von botti » 20.11.2021, 12:10

Ah, danke für die Info! Dann schaue ich mir Freqtest mal an.

botti
Beiträge: 11
Registriert: 15.12.2020, 09:00
System: CCU
Hat sich bedankt: 1 Mal

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von botti » 20.11.2021, 13:11

jo, hat geklappt. Neuer Wert:

Calculated Freq: 0x2165CA 868.338 MHz
Store into config area: 65CA...stored!

Kann man den neuen Wert bei den anderen beiden eigentlich per serieller Console reinschießen oder muss ich über ein Sketch gehen?

TomMajor
Beiträge: 1614
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 150 Mal
Danksagung erhalten: 327 Mal
Kontaktdaten:

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von TomMajor » 20.11.2021, 17:05

botti hat geschrieben:
20.11.2021, 13:11
jo, hat geklappt. Neuer Wert:

Calculated Freq: 0x2165CA 868.338 MHz
Store into config area: 65CA...stored!

Kann man den neuen Wert bei den anderen beiden eigentlich per serieller Console reinschießen oder muss ich über ein Sketch gehen?
Jedes CC1101 Modul kann individuelle Toleranzen durch seinen Quarz und andere Bauelemente haben. Deswegen sollte der FreqTest für jedes Gerät gemacht werden.
Viele Grüße,
Tom

botti
Beiträge: 11
Registriert: 15.12.2020, 09:00
System: CCU
Hat sich bedankt: 1 Mal

Re: Asksin Geräte nach Update CCU3 keine Verbindung

Beitrag von botti » 20.11.2021, 18:25

Ja, hab ich mir gedacht und dann alle mit FreqTest bearbeitet. Sind aber alle drei beim gleichen Wert gelandet.

Seit dem Update habe ich keine Systemmeldungen mehr. Es kam hin und wieder mal vor dass das eine oder andere Gerät Kommunikationsprobleme hatte.

Nun habe ich seit mehreren Stunden keine Störungen mehr.

Die Frequenzanpassung scheint eine gute Verbesserung zu bringen. War schon drauf und dran eine externe Antenne an die CCU3 anzuschließen.

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“