HB-UNI-Sensor1-THPD-BME280 lässt sich nicht verbinden

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
kdu
Beiträge: 2
Registriert: 01.01.2022, 15:33
System: CCU

HB-UNI-Sensor1-THPD-BME280 lässt sich nicht verbinden

Beitrag von kdu » 01.01.2022, 16:24

Moin,
habe mich mal über die Tage mit dem HB-UNI-Sensor1-THPD-BME280-Selbstbau beschäftigt.
Lief soweit auf Anhieb. Nur das Anlernen an die Homematic CCU3 V.3.61.7 klappert nicht. :(
Ich bekomme weder über "HM-Gerät anlernen" noch über "HMIP-Gerät anlernen" eine Verbindung hin.
Lediglich HM-Gerät über Seriennummer scheint sich was zu verbinden, LED wird sofort dunkel,
es taucht aber kein Gerät im Postkasten auf. Ich bin mir auch nicht schlüssig, ob ich das "hb-ep-devices-addon" brauche.
In der Vergangenheit habe ich mal ein HM-WDS40-TH-I gebaut. Das lief ohne Addon.
Habe es mal auf verdacht in die CCU reingeladen, es taucht aber nach dem Reset nicht auf.
Ich bin ein wenig ratlos! :| Habe ich was übersehen? :oops: Was kann das sein? :?:

Wenn ich über Serial ( BME280THP1) anfrage kommt:
bekomme aber keine Antwort im Briefkasten


debounce
pressed
released
<- 1A 02 84 00 F60401 000000 10 F6 04 42 4D 45 32 38 30 54 48 50 31 70 01 01 01 - 2357

ignore 1C 10 00 8E 37CA5C BDFBF1 00 00 00 E2 89 3D 86 68 E9 2E 2C 5E 33 A8 CD A2 97 04 18 - 2420
ignore 1A 10 00 8E BDFBF1 37CA5C 06 D3 81 3F 27 EB 51 41 EB 5F F5 E9 9D B5 4C 03 65 - 2539
-> 15 00 84 01 FCFFFF 000000 01 0A 42 4D 45 32 38 30 54 48 50 31 - 3977
<- 1A 15 80 00 F60401 FCFFFF 10 F6 04 42 4D 45 32 38 30 54 48 50 31 70 01 01 01 - 4114

ignore 19 50 00 8F 7894C0 F00001 00 03 B5 09 41 1D 5A 3A 5F 97 AA A0 AE 60 5C 5A - 6246


Hier die Firmware (ich weiß, ich habe keinen BME280):

skSin++ v5.0.0 (Jan 1 2022 15:13:07)
BME280 sensor NOT found
Sensor setup done
Serial: BME280THP1
Clock SYSCLOCK
Address Space: 32 - 46
CC init1
CC Version: 14
- ready
tmBattery Voltage: 2972
Battery set low: 26
Battery set crit: 23
Config Freq: 0x216612
Config Changed: List0
ledMode: 1
lowBatLimit: 26
Battery set low: 26
transmitDevTryMax: 6
updCycle: 240
altitude: 84
txPower: 7
* Config Changed : List1
* Temperature Offset x10 : 0
* Humidity Offset x10 : 0
* Pressure Offset x10 : 0
BME280 sensor NOT found
T/H/P/D/V (x10, aH x100) = 0/0/0/0/0
tmBattery Voltage: 3060
battery voltage x1000 = 3060
msg T/H/P/D/V/O (x10, ah x100) = 0/0/0/0/0/3060
msgcnt : 1
<- 15 01 84 70 F60401 000000 00 00 00 00 00 00 00 00 00 00 0B F4 - 2281


Hier die Daten vom Frequenztest:

AskSin++ v5.0.0 (Jan 1 2022 14:59:36)
CC init1
CC Version: 14
- ready
Active ping is NOT enabled, looking for any telegram
Start searching ...
Freq 0x21656A 868.300 MHz: 0
Freq 0x2165BA 868.332 MHz: 4E9543. 1 / -48dBm
Search for upper bound
Freq 0x2165CA 868.338 MHz: 4E9543. 1 / -47dBm
Freq 0x2165DA 868.344 MHz: 75B5D2. 1 / -55dBm
Freq 0x2165EA 868.351 MHz: BDFBF1. 1 / -79dBm
Freq 0x2165FA 868.357 MHz: 6085D3. 1 / -75dBm
Freq 0x21660A 868.363 MHz: 4E9543. 1 / -47dBm
Freq 0x21661A 868.370 MHz: 309488. 1 / -71dBm
Freq 0x21662A 868.376 MHz: BDFBF1. 1 / -79dBm
Freq 0x21663A 868.382 MHz: 7894C0. 1 / -61dBm
Freq 0x21664A 868.389 MHz: 4E9543. 1 / -47dBm
Freq 0x21665A 868.395 MHz: 4E9543. 1 / -48dBm
Freq 0x21666A 868.401 MHz: BDFBF1. 1 / -77dBm
Freq 0x21667A 868.408 MHz: BDFBF1. 1 / -79dBm
Freq 0x21668A 868.414 MHz: 0
Search for lower bound
Freq 0x2165AA 868.325 MHz: 309488. 1 / -66dBm
Freq 0x21659A 868.319 MHz: 0

Done: 0x2165AA - 0x21667A
Calculated Freq: 0x216612 868.367 MHz
Store into config area: 6612...stored!

Old Config Freq was: 0x2165EA 868.351 MHzGoing to sleep...

FUEL4EP
Beiträge: 437
Registriert: 01.11.2017, 17:26
Hat sich bedankt: 64 Mal
Danksagung erhalten: 52 Mal

Re: HB-UNI-Sensor1-THPD-BME280 lässt sich nicht verbinden

Beitrag von FUEL4EP » 01.01.2022, 16:42

Moin und ein gutes neues Jahr,

bitte installiere das Addon hb-ep-devices-addon in der neuesten Version. Im README.md des HB-UNI-Sensor1-THPD-BME280 Sketches stehen dazu Details.

Meine Einschätzung Deines Frequenztestergebnisses ist, dass das CC1101 Modul nichts taugt. Es werden keine Telegramme für Frequenzen <= 868.3 MHz gefunden (search for lower bound). Der Empfangsfrequenzbereich scheint zu stark nach oben verschoben zu sein. Ich würde den CC1101 austauschen, wenn es nach der Installation des Addons immer noch nicht geht.

Ein Referenzlog eines guten Moduls ist hier zu finden:

FreqTest_328P.log

Siehe auch hier:

https://github.com/pa-pa/AskSinPP/blob/ ... nPP.h#L253

Was ist die Meinung der Experten?
Zuletzt geändert von FUEL4EP am 01.01.2022, 21:32, insgesamt 1-mal geändert.
Grüße

Ewald

kdu
Beiträge: 2
Registriert: 01.01.2022, 15:33
System: CCU

Re: HB-UNI-Sensor1-THPD-BME280 lässt sich nicht verbinden

Beitrag von kdu » 01.01.2022, 16:58

Danke für die Hilfe,
irgendwie hatte ich ein falsches Addon zu fassen, läuft jetzt. :D

FUEL4EP
Beiträge: 437
Registriert: 01.11.2017, 17:26
Hat sich bedankt: 64 Mal
Danksagung erhalten: 52 Mal

Re: HB-UNI-Sensor1-THPD-BME280 lässt sich nicht verbinden

Beitrag von FUEL4EP » 01.01.2022, 17:05

Prima!

Also war Dein Frequenztestergebnis doch noch gut!
Grüße

Ewald

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“