hmlangw auf ESP32 läuft leider nicht

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

mariol
Beiträge: 11
Registriert: 27.08.2022, 20:30
System: Alternative CCU (auf Basis OCCU)

hmlangw auf ESP32 läuft leider nicht

Beitrag von mariol » 29.08.2022, 15:35

Hallo
ich bin auf folgende Umsetzung gestoßen, das Projekt ist ein Port von "hmlangw" auf ESP32, zu finden unter https://github.com/andyboeh/esphome-hmlgw

Ich habe das Projekt versucht auf einen ESP32 von Az-Delivery zum laufen zu bekommen, aber leider funktioniert es nicht. Ich kann es compilieren und auch auf den ESP übertragen, aber ich bekomme die ganze zeit vom Logger (Logger in ESPhome über das Netzwerk) Sync Fehler angezeigt. Hat einer von euch das Projekt schonmal auf einen ESP32 mit WLAN zum laufen bekommen?

Habe mich an das Beispiel gehalten als Config:
https://github.com/andyboeh/esphome-hml ... hmlgw.yaml

Habe auch schon unterschiedliche ESPhome Versionen ausprobiert. Leider jedoch immer mit dem gleichen Fehlerbild:

[13:28:10][E][hmlgw:202]: readBidcosFrame sync error 00

[13:28:10][D][hmlgw:255]: read from UART
[13:28:10][E][hmlgw:202]: readBidcosFrame sync error ff

[13:28:10][D][hmlgw:255]: read from UART
[13:28:10][E][hmlgw:202]: readBidcosFrame sync error 00

[13:28:10][D][hmlgw:255]: read from UART
[13:28:10][E][hmlgw:202]: readBidcosFrame sync error 00


Das rappelt so durch die Konsole.

Hat einer von euch das schon auf einen ESP32 mit wlan am laufen ?

Grüße
mario

t0mk
Beiträge: 218
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 21 Mal

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von t0mk » 29.08.2022, 21:49

Ja, läuft hier seit einiger Zeit im 24/7-Betrieb ohne Aussetzer.
Was hast du für ein Funkmodul, ist auch die richtige Firmware-Version geflasht?

mariol
Beiträge: 11
Registriert: 27.08.2022, 20:30
System: Alternative CCU (auf Basis OCCU)

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von mariol » 29.08.2022, 22:59

Hi,
Habe folgendes Funkmodul: HM-MOD-RPI-PCB.

Firmware habe ich angeblich folgende geflashed:

https://raw.githubusercontent.com/eq-3/ ... update.eq3

Habe das laut folgendem Eintrag gemacht:

Firmware Update des UART-Moduls ohne FHEM
https://wiki.fhem.de/wiki/HM-MOD-RPI-PC ... spberry_Pi


Welche Firmware Version nutzt du?

Schöne Grüsse

Mario

jp112sdl
Beiträge: 10762
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 714 Mal
Danksagung erhalten: 1722 Mal
Kontaktdaten:

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von jp112sdl » 30.08.2022, 06:16

Du brauchst die coprocessor_update_hm_only.eq3
https://github.com/eq-3/occu/blob/maste ... m_only.eq3

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

mariol
Beiträge: 11
Registriert: 27.08.2022, 20:30
System: Alternative CCU (auf Basis OCCU)

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von mariol » 30.08.2022, 09:23

Hi, die habe ich versucht zu flashen, aber bekomme folgenden fehler:

root@raspberrypi:/home/pi/hmcfgusb# ./flash-hmmoduart -U /dev/ttyAMA0 coprocessor_update_hm_only.eq3
HM-MOD-UART flasher version 0.103-git

Reading firmware from coprocessor_update_hm_only.eq3...
Firmware with 123 blocks successfully read.

Initializing HM-MOD-UART...
HM-MOD-UART opened.

Flashing 123 blocks: -

Error flashing block 0, status: 0400

gruß
mario

t0mk
Beiträge: 218
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 21 Mal

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von t0mk » 30.08.2022, 10:46

jp112sdl hat geschrieben:
30.08.2022, 06:16
Du brauchst die coprocessor_update_hm_only.eq3
https://github.com/eq-3/occu/blob/maste ... m_only.eq3
Das ist die Firmware für das CCU2-Funkmodul, die entsprechende Firmware für HM_MOD_UART ist laut FHEM:
Version 1.4.1

Code: Alles auswählen

"wget -qO ./FHEM/firmware/coprocessor_update.eq3 https://raw.githubusercontent.com/eq-3/occu/28045df83480122f90ab92f7c6e625f9bf3b61aa/firmware/HM-MOD-UART/coprocessor_update.eq3"

mariol
Beiträge: 11
Registriert: 27.08.2022, 20:30
System: Alternative CCU (auf Basis OCCU)

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von mariol » 30.08.2022, 12:28

Danke schonmal für die ganzen Infos, aber leider bekomme ich damit den gleichen Fehler :(

ich verwende einen ESP32-wroom-32 von az delivery, was habt ihr im Einsatz? welche Pins verwendet ihr? welche esphome version?

anbei meine yaml:

esphome:
name: homematic-gateway1
platform: ESP32
board: nodemcu-32s

# Enable logging
logger:
baud_rate: 0
hardware_uart: UART1

# Enable Home Assistant API
api:
encryption:
key: ""

ota:
password: ""

wifi:
ssid: !secret wifi_ssid
password: !secret wifi_password

# Optional manual IP
manual_ip:
static_ip: 192.168.250.123
gateway: 192.168.254.1
subnet: 255.255.192.0

# Enable fallback hotspot (captive portal) in case wifi connection fails
ap:
ssid: "Homematic-Gateway1"
password: ""

captive_portal:

external_components:
- source: github://andyboeh/esphome-hmlgw
components: hmlgw

uart:
id: uart_bus
baud_rate: 115200
tx_pin: 17
rx_pin: 5

hmlgw:
port: 2000
keepalive_port: 2001
reset_pin: 33

t0mk
Beiträge: 218
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 21 Mal

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von t0mk » 30.08.2022, 13:02

Hier meine Config, ist nicht die aktuellste (an die komme ich gerade nicht dran), aber sollte auch laufen:

Code: Alles auswählen

esphome:
  name: homematic-gateway1
  platform: ESP32
  board: esp-wrover-kit

# Example configuration entry
debug:

# Logger must be at least debug (default)
logger:
  level: debug

# Enable Home Assistant API
api:

ota:

ethernet:
  type: LAN8720
  mdc_pin: GPIO23
  mdio_pin: GPIO18
  clk_mode: GPIO0_IN
  phy_addr: 1
  power_pin: GPIO16

time:
  - platform: sntp
    id: sntp_time
    timezone: Europe/Berlin

external_components:
  - source: github://andyboeh/esphome-hmlgw
    components: hmlgw

uart:
  id: uart_bus
  baud_rate: 115200
  tx_pin: 17
  rx_pin: 5

hmlgw:
  port: 2000
  keepalive_port: 2001
  reset_pin: 33
Ich nutze WT32-ETH01 am LAN-Port, deswegen der "ethernet"-Abschnitt
"time" sollte irrelevant sein, ist nur ein Überbleibsel aus einer Bespiel-Config

mariol
Beiträge: 11
Registriert: 27.08.2022, 20:30
System: Alternative CCU (auf Basis OCCU)

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von mariol » 30.08.2022, 17:25

ich bekomme es einfach nicht zum laufen :(
hat jemand vielleicht von euch ne bin, die ich mal flashen kann und die einen ap aufmacht, wo ich prüfen kann, ob dort der port 2000 aktiviert ist.
ich weiß mir leider nicht anders mehr zuhelfen :(

oder liegt das an der wlan implementierung? ich versuche es nämlich über die wlan schnittstelle und nicht über eine lan..

gruß
mario

t0mk
Beiträge: 218
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 21 Mal

Re: hmlangw auf ESP32 läuft leider nicht

Beitrag von t0mk » 30.08.2022, 21:09

Verstehe nicht ganz, wie ich dir helfen kann... Kompilieren kannst du doch offenbar, was nützt dann meine .hex, die ich zwar für WLAN kompilieren aber nicht testen kann?

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“