CC1101 - mit der Zeit zunehmender Ruhestrom

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
HMSteve
Beiträge: 458
Registriert: 20.08.2019, 06:23
Hat sich bedankt: 11 Mal
Danksagung erhalten: 82 Mal

CC1101 - mit der Zeit zunehmender Ruhestrom

Beitrag von HMSteve » 11.12.2022, 18:09

Hallo zusammen,

moechte folgende Beobachtung teilen, vielleicht kann die jemand bestaetigen oder auch widerlegen, oder sie hilft bestenfalls jemandem bei der Fehlerbehebung:

Ich habe einen Aussensensor (i.W. MAX1724, ATMega328P und uebliches gruenes CC1101-Modul, Elektronik sehr gut vor Wasser geschuetzt), der seit ueber 2 Jahren laeuft, aber juengst Batterien zu fressen begann. Neulich mass ich einen Ruhestrom von gut 1mA, hatte aber keine Zeit fuer eine Reparatur und tauschte deswegen nur rasch die Batterien. Heute holte sich den Sensor herein und liess ihn erstmal etwas aufwaermen. Erneute Ruhestrommessung ergab dann gut 500uA. Nach weiterem Trocknen der Platine mit Warmluft Ruhestrom etwa 50uA. Test mit Kaeltespray: Keine Reaktion. Genaue Betrachtung zeigte weissliche Ausbluehungen rund um das Huehnerfutter auf dem CC1101-Modul. Die Platine wurde vor Inbetriebnahme von mir gruendlich mit reinem IPA gewaschen. Heute wusch ich das Teil mit ca 50% IPA in bidest. Wasser und siehe da: Ruhestrom der Schaltung nach erneutem Trocknen mit Warmluft wieder etwa 2uA, also exakt wie erwartet. Einmal Ausloeten gespart. 8)

Meine Vermutung: Die Chinesen nutzen Flussmittel, dessen Rueckstaende hygroskopisch und nicht alkoholloeslich sind.
Fazit: Ich werde kuenftig mit verduenntem IPA waschen.

Viele Gruesse,
Stephan

Benutzeravatar
Psi
Beiträge: 510
Registriert: 09.08.2018, 19:58
Wohnort: Nürnberg
Hat sich bedankt: 27 Mal
Danksagung erhalten: 87 Mal

Re: CC1101 - mit der Zeit zunehmender Ruhestrom

Beitrag von Psi » 11.12.2022, 19:44

Ich hab die Sensoren für außen mit Lack überzogen. Ich selbst hab zwar nur noch einen in der Garage aber der war zuvor am Gartenhaus, dürfte jetzt ca 3 jahre alt sein und Batterie hab ich getauscht weil ausgelaufen

ivo-int
Beiträge: 195
Registriert: 13.04.2020, 08:55
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 23 Mal
Danksagung erhalten: 11 Mal

Re: CC1101 - mit der Zeit zunehmender Ruhestrom

Beitrag von ivo-int » 12.12.2022, 09:26

Hallo Stephan

Eine sehr interessante Info.

Bis jetzt hatte ich ein paar ausfälle eines proMini, auch solche ohne den weissen Punkt.

Ebenfalls hat ein Funkmodul den Geist aufgegeben. Bei einem Gerät war in der Tat der Ruhestrom zu hoch. Bei diesem Gerät war es ebenfalls der proMini.

Bei einem neuen Fall werde ich das dann auch einmal mit dem Reinigen versuchen.

Gruss Ivo
_______________________________________________________________________________________________________
Raspberrymatic auf einem Raspi 4 4GB (HB-RF-USB-2) mit 2 LAN Gateways,
42 RF Geräte, 5 IP Geräte und 21 Cuxd Geräte, 22 RF Eigenbau Geräte
hm_pdetect, E-Mail, XML-API, JB HB Devices, HB-TM-Devices-AddOn, CUx-Daemon, CCU-Historian auf einem separaten Raspi

rih
Beiträge: 122
Registriert: 09.05.2019, 23:04
System: keine Zentrale (nur Pairing, FHEM etc.)
Wohnort: Nürtingen
Hat sich bedankt: 19 Mal
Danksagung erhalten: 10 Mal

Re: CC1101 - mit der Zeit zunehmender Ruhestrom

Beitrag von rih » 12.12.2022, 21:49

Hallo Stephan,

vielen Dank für das Teilen deiner Beobachtung. Kann ich nun voll und ganz bestätigen. Hatte aktuell auch einen Außensensor (Lichtsensor mit MAX44009), dessen Batterielaufzeit im Laufe der Zeit stetig sank. Am Schluß betrug die Batterielaufzeit nur noch ca. 3 Monate. Habe ihn dann vor ein paar Tagen deaktiviert. Hat im Ruhezustand 0.2mA gezogen. Wobei ich jetzt nicht sagen kann, ob das am ProMini oder am Funkmodul lag. Am MAX44009 lags nicht, den hatte ich probeweise ausgesteckt bei der Messung.

Nach dem Lesen deines Beitrags habe ich ProMini und Funkmodul ebenfalls mit verdünntem IPA gereinigt. Was soll ich sagen: der Strom im Ruhezustand beträgt jetzt 0.01mA! Der Sensor ist nun wieder in Betrieb :D.

Anmerkung: weissliche Ausblühungen konnte ich unter der Lupe keine erkennen. Mein Sensor ist allerdings auch in einem Klarsichtdeckelgehäuse mit IP65 oder 67.
Viele Grüße,
Hans

Martin62
Beiträge: 674
Registriert: 09.12.2019, 21:24
Hat sich bedankt: 146 Mal
Danksagung erhalten: 59 Mal

Re: CC1101 - mit der Zeit zunehmender Ruhestrom

Beitrag von Martin62 » 14.12.2022, 10:19

Ich hatte bei ca. 50 Nachbauten 3 Fälle mit zu hohem Ruhestrom. Fällt natürlich nur bei den Batteriebetriebenen auf. Bei mir waren es die Elkos auf dem Promini 3,3V 8mHz (laut Schaltplan C13). Nach austauschen war der Verbrauch wieder im Normbereich.

Nachtrag: Bei Verwendung mit Batterie und Versorgung über VCC kann man die Elkos C19 und C13 gleich mit ablöten, wenn man schon dabei ist LDO und LEDs abzulöten. Damit beseitigt man die Fehlerquelle schon im Vorfeld.
Gruß Martin

ivo-int
Beiträge: 195
Registriert: 13.04.2020, 08:55
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 23 Mal
Danksagung erhalten: 11 Mal

Re: CC1101 - mit der Zeit zunehmender Ruhestrom

Beitrag von ivo-int » 14.12.2022, 11:33

Martin62 hat geschrieben:
14.12.2022, 10:19
Bei mir waren es die Elkos auf dem Promini 3,3V 8mHz (laut Schaltplan C13). Nach austauschen war der Verbrauch wieder im Normbereich.
Danke für den Hinweis. Wenn ich wieder ein Ruhestrom Problem habe tausche ich diesen auch einmal aus.
_______________________________________________________________________________________________________
Raspberrymatic auf einem Raspi 4 4GB (HB-RF-USB-2) mit 2 LAN Gateways,
42 RF Geräte, 5 IP Geräte und 21 Cuxd Geräte, 22 RF Eigenbau Geräte
hm_pdetect, E-Mail, XML-API, JB HB Devices, HB-TM-Devices-AddOn, CUx-Daemon, CCU-Historian auf einem separaten Raspi

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“