Node Red stürzt immer wieder ab

Node-RED als CCU3/RaspberryMatic Addon, WebApp, HomeKit, ...

Moderator: Co-Administratoren

Blanco24
Beiträge: 27
Registriert: 22.08.2020, 16:17
System: CCU und Access Point
Hat sich bedankt: 2 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von Blanco24 » 22.11.2020, 16:07

Hab die aktuellste Raspberrymatic Version (3.53.34...). Ports habe ich keine freigegeben und unter "IP Adressen für den eingeschränkten Zugriff" habe ich folgende IP Adressen:

192.168.0.1;
192.168.0.0/16;
192.168.0.158;
192.168.137.1;
fc00::/7;
fe80::/10

HenningK
Beiträge: 178
Registriert: 22.09.2012, 20:56
Hat sich bedankt: 2 Mal
Danksagung erhalten: 9 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von HenningK » 22.11.2020, 16:34

hmmm. Da hast du die neueste Raspberrymatic Version installiert. Redmatic ist auch aktuell.

Ich würde jetzt nochmal Redmatic deinstallieren, die neueste Redmatic installieren und wenn das dann nicht funktioniert im Raspberrymatic Forum einen Eintrag einstellen.

Blanco24
Beiträge: 27
Registriert: 22.08.2020, 16:17
System: CCU und Access Point
Hat sich bedankt: 2 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von Blanco24 » 23.11.2020, 21:19

Leider hat im Raspberrymatic bisher niemand geantwortet. Kann es sein, dass meine Einstellungen falsch sind?
Screenshot 2020-11-23 211613.png
Die IP Adresse meiner CCU ist nämlich 192.168.0.143 und nicht 127.0.0.1.

HenningK
Beiträge: 178
Registriert: 22.09.2012, 20:56
Hat sich bedankt: 2 Mal
Danksagung erhalten: 9 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von HenningK » 24.11.2020, 09:37

Das ist bei mir auch so - 127.0.0.1 heisst einfach nur "local". Mein IP adresse ist 192.168.178.25
Ich nutze nur noch HmIP - deshalb ist alles andere ausgeschaltet.

Wie sieht "configure firewall" in der CCU aus? Ist dort "Homematic XML-RPC API:" full access?
Screenshot 2020-11-24 093201.png

Blanco24
Beiträge: 27
Registriert: 22.08.2020, 16:17
System: CCU und Access Point
Hat sich bedankt: 2 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von Blanco24 » 24.11.2020, 10:39

Ja, habe alles auf full access. Könnte es vielleicht daran liegen, dass mein HM Funkmodul defekt oder nicht korrekt eingebaut ist? Kann man irgendwo nachprüfen ob das Funkmodul erkannt wird bzw. funktioniert?

HenningK
Beiträge: 178
Registriert: 22.09.2012, 20:56
Hat sich bedankt: 2 Mal
Danksagung erhalten: 9 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von HenningK » 24.11.2020, 13:58

OK.

Bitte prüfe nochmal, ob die wirklich 3.53.34 ... installiert hast. Im logfile steht 3.51.6.20200420.

Das Funkmodul kannst du einfach testen. Du hast einen HM-LC-Sw1 - den müsstest du über die Homematic GUI schalten können.

Blanco24
Beiträge: 27
Registriert: 22.08.2020, 16:17
System: CCU und Access Point
Hat sich bedankt: 2 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von Blanco24 » 24.11.2020, 14:42

Das ist aber eigenartig, denn ich hab gar keinen HM-LC-Sw1. Gibt es eine andere Möglichkeit das Funkmodul zu prüfen?

Die CCU habe ich im Zuge der 64bit Redmatic Version geupdatet. Im letzten Log habe ich bereits die aktuellste Version.
Vielleicht hilft die Log Datei der Raspberrymatic weiter.
homematic-raspi-2020-11-22.log
(84.27 KiB) 4-mal heruntergeladen
Hier sieht man auch die ganzen Abstürze bzw. Neuverbindungen.

HenningK
Beiträge: 178
Registriert: 22.09.2012, 20:56
Hat sich bedankt: 2 Mal
Danksagung erhalten: 9 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von HenningK » 24.11.2020, 15:43

Im node-red log vom 21. stand:

Code: Alles auswählen

ccu": {
      "VERSION": "3.51.6.20200420",
      "PRODUCT": "raspmatic_rpi3",
      "PLATFORM": "rpi3-armv7l",
      "deviceTypes": [
         "HM-CC-TC",
         "HM-LC-Sw1-Pl",
         "HM-PB-2-WM",
         "HM-RC-P1",
         "HM-Sen-EP"
      ]
Kannst du nochmal das aktuelle Node-RED log senden?

Hastu du CUXD installiert?

Blanco24
Beiträge: 27
Registriert: 22.08.2020, 16:17
System: CCU und Access Point
Hat sich bedankt: 2 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von Blanco24 » 24.11.2020, 16:59

Ja, CuxD ist installiert. Hab da auch schon mit und ohne getestet - gleiches Ergebnis. Warum die Geräte aufgelistet sind, kann ich mir nicht erklären. Ich habe keinerlei HM Geräte. Nur das HM-Funkmodul im Raspberry Pi3 verbaut.

Anbei Nodered-log, HM-log & Firewalleinstellungen.
redmatic.2020-11-24T15_56_08.367Z.log
(42.16 KiB) 8-mal heruntergeladen
homematic-raspi-2020-11-24.log
(111.37 KiB) 7-mal heruntergeladen
Dateianhänge
Screenshot 2020-11-24 165744.png

HenningK
Beiträge: 178
Registriert: 22.09.2012, 20:56
Hat sich bedankt: 2 Mal
Danksagung erhalten: 9 Mal

Re: Node Red stürzt immer wieder ab

Beitrag von HenningK » 24.11.2020, 17:15

hmmm. In deinem Flow steht aber eine Stehlampe. Wie willst du die schalten?

Antworten

Zurück zu „RedMatic“