Anleitung zur Installation der CCU auf einem x86 system

OCCU für Betriebssysteme basierend auf Debian

Moderator: Co-Administratoren

quickmic
Beiträge: 496
Registriert: 20.01.2011, 14:39
Hat sich bedankt: 4 Mal
Danksagung erhalten: 4 Mal

Anleitung zur Installation der CCU auf einem x86 system

Beitrag von quickmic » 30.09.2017, 15:17

Anbei die Installationsanleitung:

Lauffaehig (getestet) mit LXC-Container, VM und natuerlich nativ auf Debian 9 (amd64). (Proxmox, QNAP und EsXi)
Plugin Installation fuer XML-Api, Cuxd und email ist inkludiert.

Ich habe das Script greundlich getestet, trotzdem sind Fehler nicht ausgeschlossen.

Speziellen Dank an Uwe fuer die Anpassung von cuxd auf x86 und Christian fuers Testen auf qnap!


EDIT 2018-01-27:
Bitte spielt die Backups beim Ersten Mal manuell ein! Danach kann auch die normale Backup-Funktion verwendet werden.
Mehr dazu auf Seite 2 des Threads

EDIT 2018-02-02:
Neue Anleitung im Anhang.

EDIT 2018-06-13:
2018-06-13 - ccu-install-script-mod1.txt
2018-06-11 - ccu-update-script-mod1.txt
Ich habe geswitcht auf install-scripts.
Die files auf .sh umbenennen, Rechte 777 vergeben und es sollte laufen.
Backup Einspielen/Erstellen ist gefixt, und noch viele weitere Probleme sind geloest.
Bei Migration trotzdem das Backup erstmalig von Hand Einspielen! -> Anleitung auf Seite 2 des Threads.
Das Updatescript sollte auch fuer vorherige Versionen klappen inkl. der Bugfixes. Trotzdem vorher lieber Backuppen.
Dateianhänge
2018-06-13 - ccu-install-script-mod1.txt
(11.31 KiB) 579-mal heruntergeladen
2018-06-11 - ccu-update-script-mod1.txt
(5.75 KiB) 213-mal heruntergeladen
2018-02-02 - ccu-install-mod2.txt
(12.97 KiB) 564-mal heruntergeladen
Zuletzt geändert von quickmic am 04.08.2018, 23:02, insgesamt 11-mal geändert.

ChristianF
Beiträge: 383
Registriert: 27.06.2014, 21:50

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von ChristianF » 30.09.2017, 22:58

Die Anleitung funktioniert hervorragend, einen riesen Dank an Michael!

Als Anmerkung: natürlich muss man, wenn man Funkdevices nutzen möchte, LAN-Gateways haben :)
370 Kanäle in 119 Geräten und 22 CUxD-Kanäle in 18 CUxD-Geräten (Stand 28.4.16)

Xilence2Play
Beiträge: 1
Registriert: 09.11.2017, 10:09

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von Xilence2Play » 09.11.2017, 12:21

Dass die Anleitung funktioniert kann ich auch bestätigen.
Diese läuft bei mir unter debian stretch QEMU innerhalb einer QNAP NAS.

Soweit so gut. Da ich in diesem Thema ganz frisch unterwegs bin, habe ich natürlich gleich ein Problem bzw. eher Fragen...:
Alle Addons (XMLapi, eMail sowie CuxD laufen. Das Exec Gerät konnte ich auch ohne Probleme erzeugen und auf Funktion testen.

Leider gibt es ein Problem, wenn ich versuche ein BackUp aus der Hardware CCU2 einzuspielen:
tar: usr/local/etc/config/addons/www/cuxd: Cannot open: file

Daraufhin ist folgender Auszug im syslog zu sehen:
cuxd[392]: Received SIGTERM signal.
cuxd[392]: CUx-Daemon stop(0)
cuxd[392]: unlink(/var/cache/cuxd_proxy.ini)
cuxd[392]: save paramsets(/www/addons/cuxd/cuxd.ps) size:587
cuxd[392]: sendbinrpc(127.0.0.1:2001) - write() Connection refused
homematic: stopped cux-daemon

Vermutlich fehlt einfach nur eine Änderung in der Konfiguration für den Port 2001, ich weiß aber nicht wo ich dort ansetzen soll.
Dazu habe ich meine cp_security.cgi angehängt.
netstat -tulpen zeigt mir keinen 2001 Port.

Weiter habe ich ständig diese Meldungen:
ccu[266]: [Timer-3] ERROR de.eq3.ccu.bidcos.dispatcher.BidCosRpcDispatcher - Could not register BidCos-RF_java
ccu[266]: [Timer-1] ERROR de.eq3.ccu.bidcos.dispatcher.BidCosRpcDispatcher - Could not register HmIP-RF_java

Hierbei gehe ich jedoch davon aus, dass sich dieses Problem von selbst erledigt, sobald ich ein Gateway eingerichtet habe?

Vielen Dank im Voraus!
Vor allem an die Anleitung und die Community.

MfG,

Jens F.
Dateianhänge
cp_security.txt
(47.46 KiB) 86-mal heruntergeladen

quickmic
Beiträge: 496
Registriert: 20.01.2011, 14:39
Hat sich bedankt: 4 Mal
Danksagung erhalten: 4 Mal

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von quickmic » 28.11.2017, 12:27

Hallo

Sorry, dass ich mich erst jetzt melde. War aber laengere Zeit im Ausland.

Das mit dem Einspielen des Backups ist leider manchmal problematisch.

Ich habe schnell mal bei mir gecheckt und das Problem liegt vermutlich daran, dass ein link fehlt.
"tar: usr/local/etc/config/addons/www/cuxd: Cannot open: file" sagt, dass versucht wird ins Verzeichnis (bzw. Link) einen Teil des Backups zu extrahieren.
Versuch mal folgendes:
checke ob der link existiert:
ls /usr/local/etc/config/addons/www/cuxd
wenn da nix kommt dann nochmal:
ln -s /www/addons/ /usr/local/addons

Die ports werden hier eingestellt:
/etc/config/InterfacesList.xml
meine schauen so aus:
cat /etc/config/InterfacesList.xml

Code: Alles auswählen

<?xml version="1.0" encoding="utf-8" ?>
<interfaces v="1.0">
        <ipc>
                <name>BidCos-RF</name>
                <url>xmlrpc_bin://127.0.0.1:2001</url>
                <info>BidCos-RF</info>
        </ipc>
        <ipc>
                <name>BidCos-Wired</name>
                <url>xmlrpc_bin://127.0.0.1:2000</url>
                <info>BidCoS-Wired</info>
        </ipc>
        <ipc>
                <name>VirtualDevices</name>
                <url>xmlrpc://127.0.0.1:9292/groups</url>
                <info>Virtual Devices</info>
        </ipc>
        <ipc>
                <name>CUxD</name>
                <url>xmlrpc_bin://127.0.0.1:8701</url>
                <info>CUxD</info>
        </ipc>
</interfaces>
bzw. hier:
nano /etc/config/rfd.conf

Wenn das port 2001 zu ist, kann es aber eher sein, das "rfd" nicht laeuft.
Schau mal nach mit:
ps -Alf

Da sollte dann folgendes kommen:
"/bin/rfd -d -f /etc/config/rfd.conf -l 5"

Wenn nicht, dann versuch mal manuell zu starten:
"/bin/rfd -d -f /etc/config/rfd.conf"

Wenn das nicht klappt, koennte sein das die "/etc/config/rfd.conf" fehlt. z.b. wegen des Backup-Problems

ThR
Beiträge: 11
Registriert: 05.09.2017, 03:14

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von ThR » 03.12.2017, 23:31

Xilence2Play hat geschrieben:
Weiter habe ich ständig diese Meldungen:
ccu[266]: [Timer-3] ERROR de.eq3.ccu.bidcos.dispatcher.BidCosRpcDispatcher - Could not register BidCos-RF_java
ccu[266]: [Timer-1] ERROR de.eq3.ccu.bidcos.dispatcher.BidCosRpcDispatcher - Could not register HmIP-RF_java
Hallo Jens,

hast du das Problem mittlerweile lösen können?
Ich hab die gleichen Fehler im log.

Gruß Thomas

Edit: Nachdem Lan-GW verbunden läuft es ohne Probleme
Zuletzt geändert von ThR am 10.12.2017, 01:24, insgesamt 1-mal geändert.

nicx
Beiträge: 273
Registriert: 18.05.2013, 22:31

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von nicx » 04.12.2017, 14:40

Hey das klingt echt super, ich warte schon lange auf eine x86 Umsetzung. Hat sich vielleicht schon jemand die Mühe gemacht das als Docker Image bereitzustellen? :)

nicx
Beiträge: 273
Registriert: 18.05.2013, 22:31

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von nicx » 05.12.2017, 13:17

nachtrag: habs nun selbst mal versucht zu dockerisieren, für alle interessierten: https://hub.docker.com/r/timokli/ccu2-docker/

Leider funktioniert es nicht, wenn ich die Weboberfläche aufrufe erhalte ich nur einen weissen Bildschirm und ein Icon auf das nicht zugegriffen werden kann. Wo könnte ich sinnvollerweise die Logs nach der Ursache durchforsten?

maplesteve
Beiträge: 1
Registriert: 17.12.2017, 21:17

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von maplesteve » 17.12.2017, 21:24

nicx hat geschrieben:Leider funktioniert es nicht, wenn ich die Weboberfläche aufrufe erhalte ich nur einen weissen Bildschirm und ein Icon auf das nicht zugegriffen werden kann. Wo könnte ich sinnvollerweise die Logs nach der Ursache durchforsten?
Hast Du mal Port 80 statt 8181 probiert? So wie ich das verstehe, fungiert der lighthttpd als Proxy von Port 80 auf den (internen) Port 8181. Ich habe nach der ersten Installation auch erst lange auf das blaue Icon geguckt; mit Port 80 ging es dann.

krissi
Beiträge: 75
Registriert: 15.05.2014, 15:13

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von krissi » 11.01.2018, 12:21

Danke für die Anleitung! Hab es gestern auf meinem NUC unter ESXI in einer VM zum laufen gebracht. Erster Eindruck -> DAS IST JA SAU SCHNELL :shock: Heute probiere ich dann das LAN Gateway einzubinden und das Backup einzuspielen. Mal sehen ob das genau so problemlos funktioniert. :)

quickmic
Beiträge: 496
Registriert: 20.01.2011, 14:39
Hat sich bedankt: 4 Mal
Danksagung erhalten: 4 Mal

Re: Anleitung zur Installation der CCU auf einem x86 system

Beitrag von quickmic » 20.01.2018, 08:30

Ich empfehle die Backups manuell einzuspielen und nicht ueber die Oberflaeche. Die Plugins wurde ich manuell nochmals konfigurieren.

Es sollte zwar auch so gehen, aber das zickt manchmal und ich kann das nicht sauber testen.

Gesperrt

Zurück zu „x86-CCU“