debmatic Updates

Debian/Ubuntu basierte CCU

Moderator: Co-Administratoren

Antworten
deimos
Beiträge: 2980
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

debmatic Updates

Beitrag von deimos » 03.09.2019, 23:41

Hi,

ich habe grade einen Stapel Updates in das testing apt Repository von debmatic hochgeladen:

- Unterstützung für den Rock Pi 4
- Bugfix für Probleme bei Start von Java Prozessen auf ARM64 Systemen
- Neu migriertes Addon: XML-API
- Update von CUxD Addon auf Version 2.3.3

Sofern keine Probleme auftauchen, werde ich die Änderungen in ca. 2 Wochen in das stable apt Repository übernehmen.

Viele Grüße
Alex

FKuypers
Beiträge: 38
Registriert: 09.03.2016, 21:24

Re: debmatic Updates

Beitrag von FKuypers » 05.09.2019, 07:00

Installation hat geklappt - läuft erstmal. Was mir sofort aufgefallen ist:
Homematic.png
Homematic.png (10.36 KiB) 463 mal betrachtet
Gruß,

Frank

deimos
Beiträge: 2980
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

Re: debmatic Updates

Beitrag von deimos » 05.09.2019, 20:37

Hi,

und grade kam noch etwas hinzu: Es gibt jetzt auch ein Plugin für Cloudmatic Connect.

Viele Grüße
Alex

tom2013
Beiträge: 27
Registriert: 14.02.2013, 09:43

Re: debmatic Updates

Beitrag von tom2013 » 10.09.2019, 21:09

Hi,
habe gerade eine neue Debmatic 3.47.15.32 Installation auf Raspi4 aufgesezt.
Alles lief schnell und problemlos. Danke dafür.

Nun habe ich gleichmal die neuesten Addons hinzugefügt.
CuxD ist noch in der Version 2.2.0, die neuere Version 2.3.3 wird noch nicht per Apt angeboten.

XMLAPI ließ sich installieren, scheint aber anders als meine bisherige manuelle Installation oder die normale CCU Installation zu funktionieren.
Meine IP_Symcon Variablen werden nicht mehr befüllt. Es werden keine Daten gefunden.

Ist das so gewollt?


Viele Grüße
tom2013

deimos
Beiträge: 2980
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

Re: debmatic Updates

Beitrag von deimos » 10.09.2019, 21:58

Hi,

nein, das ist nicht gewollt und ich konnte das bei mir auch beobachten, bei mir verhält sich XML API identisch zu einer CCU3. Wobei ich hier kein IP Symcon laufen habe, sondern ich habe mir manuell die XML Seiten angeschaut.
Was kommt denn, wenn du die XML Seiten manuell abrufst?

Viele Grüße
Alex

tom2013
Beiträge: 27
Registriert: 14.02.2013, 09:43

Re: debmatic Updates

Beitrag von tom2013 » 11.09.2019, 18:18

Hi Alex,

habe heute nochmal diese neue Installation gestartet.
Nun ist plötzlich alles ok.
Warum 2 Neustarts notwendig waren ..., na ja nun ist es doch alles wieder da.

Kann ich dann demnächst den CuxD 2.33 einfach aktualisieren oder muss ich vorher erst deinstallieren?

Viele Grüße

tom2013

deimos
Beiträge: 2980
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

Re: debmatic Updates

Beitrag von deimos » 11.09.2019, 22:24

Hi,
tom2013 hat geschrieben:
11.09.2019, 18:18
Kann ich dann demnächst den CuxD 2.33 einfach aktualisieren oder muss ich vorher erst deinstallieren?
Debian way, das kommt als Update per apt, es reicht dann ein "apt update && apt upgrade"

Viele Grüße
Alex

deimos
Beiträge: 2980
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

Re: debmatic Updates

Beitrag von deimos » 15.09.2019, 08:44

Hi,

die Updates sind jetzt auch alle im Stable apt Repository verfügbar.

Viele Grüße
Alex

tom2013
Beiträge: 27
Registriert: 14.02.2013, 09:43

Re: debmatic Updates

Beitrag von tom2013 » 15.09.2019, 11:48

Hallo Alex,

danke für die Info, Updates sind gelaufen.

Folgende Dinge sind aufgetreten:

Ablauf PuttY Installation: Update auf 3471533 und dann Update Cuxd 2.3.3

Rssid: --> nach Ende der Installation HB-RF-USB + RPI-RF-MOD nicht eingebunden, nur HM-CFG-LAN
RPI-RF-MOD --> LED blinkt schnell gelb

sudo systemctl start/stop debmatic.service
Systemstart --> HB-RF-USB + RPI-RF-MOD nun eingebunden --> LED stabil blau
Nur ein Duty-Cycle vorhanden obwohl HB-RF-USB + RPI-RF-MOD und HM-CFG-LAN, keine DC-Daten Anzeige im CuxD

Sys-Log:
************************************************************************
Sep 15 09:47:31 raspberrypi ReGaHss: WARNING: incorrect use of Variable() (use AlType()): Name=dom.GetObject(1334).Name();#012ValueType=dom.GetObject(1334).ValueType();#012integer Type=dom.GetObject(1334).Type();#012WriteLine(dom.GetObject(1334).Variable());#012Timestamp=dom.GetObject(1334).Timestamp();#012 [ExecAlarmDP():iseESPexec.cpp:10214]
Sep 15 09:47:31 raspberrypi ReGaHss: ERROR: ScriptRuntimeError: Name=dom.GetObject(1334).Name();#012ValueType=dom.GetObject(1334).ValueType();#012integer Type=dom.GetObject(1334).Type();#012WriteLine(dom.GetObject(1334).Variable());#012Timestamp=dom.GetObject(1334).Timestamp();#012 [ExecError():iseESPexec.cpp:12761]

Nach einer weiteren halben Stunde zeigten dann auch einige weitere Geräte wie AS2200 und WDS-100 ihre Daten.

PS: Zwischenzeitlich hatte ich mal den Verdacht, dass es besser wäre, nur debmatic und co zu aktualisieren und Rasbian-Buster stabil zu lassen.
Ich befürchtete das einige Ungereimtheiten auf die Aktualisierungen von Buster zurückzuführen seien.

Andererseits ist Buster für den Raspi4 noch nicht endgültig fertig wie es heißt?!

Viele Grüße
tom2013

Antworten

Zurück zu „debmatic“