Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Mave
Beiträge: 8
Registriert: 23.05.2017, 07:51

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von Mave » 03.10.2018, 13:28

Jens,

nachdem ich mir das Ab- und wieder Anlernen von 15 HmIP Geräten sparen wollte, habe ich ein direktes Update über die Web Oberfläche probiert, nachdem die alte Updatemethode fehlgeschlagen war.

Und siehe da. Es hat scheinbar funktioniert.

Das Update Fenster ist zwar stehen geblieben und war nach 20 min immer noch unverändert. Nach dem Löschen des Browsercaches und einem Aufruf der Web Oberfläche scheint jetzt aber alles ganz normal zu laufen.

Könnte es Probleme geben, weil das Update keine Abschlußmeldung gebracht hat?

Vielen Dank für Deine Unterstützung.

Benutzeravatar
jmaus
Beiträge: 5019
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 79 Mal
Kontaktdaten:

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von jmaus » 03.10.2018, 14:30

Mave hat geschrieben:
03.10.2018, 13:28
nachdem ich mir das Ab- und wieder Anlernen von 15 HmIP Geräten sparen wollte, habe ich ein direktes Update über die Web Oberfläche probiert, nachdem die alte Updatemethode fehlgeschlagen war.

Und siehe da. Es hat scheinbar funktioniert.
Versteh ich nicht. Du hattest doch im letzten Posts geschrieben du hast alle HmIP Geräte bereits abgelernt/gelöscht?!?

Keine gute Idee die wohl teil kaputte HmIP Konfiguration in das neue System zu übernehmen. Spätestens beim nächsten Abckup einspielen wird dich die Fehleruwieder ereilen.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

Mave
Beiträge: 8
Registriert: 23.05.2017, 07:51

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von Mave » 03.10.2018, 14:46

Sorry, wenn ich mich falsch ausgedrückt habe.

Ich habe mir den Ordner heruntergeladen und alle .dev Dateien entfernt, zu denen ich eine passende Seriennummer gefunden habe, bis die beiden oben genannten Dateien übrig geblieben sind.
Ich hatte das so verstanden, dass in diesem Verzeichnis eine oder mehrere .dev Dateien zuviel vorhanden sein müssten, die ich dann einfach nur löschen muss.

Nach dem erfolglosen Einspielen des Backups habe ich mein Sicherungsimage auf die SD-Karte zurückgespielt und das Update über die Web Oberfläche gestartet.

Ich würde mir wirklich gerne das Ab- und Anlernen sparen. Die ganzen Geräte sind in FHEM angelegt und ich hab keine Ahnung, ob nach dem erneuten Anlernen alles wieder läuft wie gewohnt. Zudem fehlen anschließend die ganzen Einstellungen der HmIP Geräte in RaspberryMatic.

Soll ich mal testen, ob jetzt ein Backup und ein Zurückspielen des Backups funktioniert?

Benutzeravatar
jmaus
Beiträge: 5019
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 79 Mal
Kontaktdaten:

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von jmaus » 03.10.2018, 15:22

Mave hat geschrieben:
03.10.2018, 14:46
Soll ich mal testen, ob jetzt ein Backup und ein Zurückspielen des Backups funktioniert?
Das würde ich tun ja. Meine Vermutung ist allerdings das es dann zu besagtem "apkx"-Fehler kommt. Und das bedeutet dann das eine oder mehrere Dateien nicht mit der 3.37.x korrekt funktionieren werden. Ich kann dir dann gerne sagen wie du prüfen kannst welche Datei das ist damit die zumindest dieses eine Gerät dann löschen und neu anlernen kannst damit auch in Zukunft alles korrekt funktioniert.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

verdao2016
Beiträge: 10
Registriert: 06.01.2018, 12:00

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von verdao2016 » 05.10.2018, 04:12

jmaus hat geschrieben:
03.10.2018, 15:22
Mave hat geschrieben:
03.10.2018, 14:46
Soll ich mal testen, ob jetzt ein Backup und ein Zurückspielen des Backups funktioniert?
Das würde ich tun ja. Meine Vermutung ist allerdings das es dann zu besagtem "apkx"-Fehler kommt. Und das bedeutet dann das eine oder mehrere Dateien nicht mit der 3.37.x korrekt funktionieren werden. Ich kann dir dann gerne sagen wie du prüfen kannst welche Datei das ist damit die zumindest dieses eine Gerät dann löschen und neu anlernen kannst damit auch in Zukunft alles korrekt funktioniert.
Das ist ein tolles Angebot von Jens.
Die genauen Geräte zu identifizieren würde mir bei ca. 30 IP Geräte sehr helfen.
Bitte wie man die "kaputten" Dateien gefunden werden können posten.
Und dafür bedanke mich schon im Voraus.

RobiMo
Beiträge: 1
Registriert: 05.10.2018, 12:33

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von RobiMo » 05.10.2018, 12:45

Hallo
ich hatte auch das Problem mit dem Update auf 3.37.XXX, das nach dem Update sich das Backup nicht mehr zurück spielen ließ. Genau die Fehlermeldung wie „Oben“ beschrieben.
Nach langen Suchen habe ich MEIN Problem gefunden. Das HomeMatic-Funkmodul HM-OCCU-SDK war defekt. Ausgetauscht und siehe da das Backup konnte ohne Fehlermeldung eingespielt werden und alle Geräte sind nun auch wieder da.
Den Fehler mit dem Funkmodul habe ich dadurch festgestellt, dass ich von Null wieder angefangen habe meine Geräte anzumelden. Funktionierte aber nicht. Fehlermeldung das kein Funkmodul vorhanden ist.
MFG RobiMo

verdao2016
Beiträge: 10
Registriert: 06.01.2018, 12:00

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von verdao2016 » 14.10.2018, 11:18

verdao2016 hat geschrieben:
05.10.2018, 04:12
jmaus hat geschrieben:
03.10.2018, 15:22
Mave hat geschrieben:
03.10.2018, 14:46
Soll ich mal testen, ob jetzt ein Backup und ein Zurückspielen des Backups funktioniert?
Das würde ich tun ja. Meine Vermutung ist allerdings das es dann zu besagtem "apkx"-Fehler kommt. Und das bedeutet dann das eine oder mehrere Dateien nicht mit der 3.37.x korrekt funktionieren werden. Ich kann dir dann gerne sagen wie du prüfen kannst welche Datei das ist damit die zumindest dieses eine Gerät dann löschen und neu anlernen kannst damit auch in Zukunft alles korrekt funktioniert.
Das ist ein tolles Angebot von Jens.
Die genauen Geräte zu identifizieren würde mir bei ca. 30 IP Geräte sehr helfen.
Bitte wie man die "kaputten" Dateien gefunden werden können posten.
Und dafür bedanke mich schon im Voraus.
Jens, wie können die IP Geräte identifiziert werden?
Danke.

FrankMatic
Beiträge: 24
Registriert: 29.12.2016, 23:23
Wohnort: Aachen

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von FrankMatic » 02.01.2019, 19:28

Hallo Zusammen,

möglicherweise habe ich eine Lösung gefunden ohne alle HMIP Geräte abzulernen.

Ich bin in das folgende Verzeichnis gegangen: /etc/config/crRFD/data
und habe die alten Dateien vom Typ: .ap und .apkx
gelöscht, bis nur zwei gleich benannte neueren Typs übrig waren.

Danach hat das Backup einspielen wieder funktioniert.

VG
Frank

Nussschnecke
Beiträge: 8
Registriert: 07.02.2015, 20:03
Wohnort: Schwabenland

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von Nussschnecke » 31.03.2019, 13:42

Hallo,
funktioniert diese Variante zuverlässig?
Ich habe dieses Problem immer noch und möchte es langsam los werden.

Danke und Grüße
Nussschnecke
RaspberryMatic mit ein paar Geräten - und sehr zufrieden!

Ritschi
Beiträge: 498
Registriert: 07.11.2012, 08:02
Wohnort: Schweiz, Graubünden

Re: Systemwechsel auf 3.37.x nicht möglich (*.apkx Datei fehlt)

Beitrag von Ritschi » 10.04.2019, 21:26

Hallo zusammen

Bei mir kam genau dieser Fehler, als ich das Backup auf mein Tinkerboard einspielen wollte, ohne dass ich die Funk-Modulplatine RPI-RF-MOD auf meinem Tinkerboard gesteckt hatte.

Funk-Modulplatine eingesteckt, neu versucht und siehe da, ich konnte das Backup einspielen.
Evtl. hilft meine Erfahrung jemandem.

Gruss
Ritschi
Raspberry-Matic, Mediola Gateway V3, Mediola Gateway V2, io. Broker, OWL-Energiemessung, Homebridge-homematic auf Mac

Antworten

Zurück zu „RaspberryMatic“