Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Markus!
Beiträge: 9
Registriert: 15.01.2017, 19:14

Re: Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Beitrag von Markus! » 05.02.2019, 12:28

Danke für das tolle Projekt.

Funktioniert dein Sketch 1:1 mit der Luani Hardware?

Benutzeravatar
Gelegenheitsbastler
Beiträge: 492
Registriert: 15.10.2017, 07:29
Hat sich bedankt: 1 Mal

Re: Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Beitrag von Gelegenheitsbastler » 05.02.2019, 12:44

Ich habe das Luani-Projekt als Basis genommen, aber den DC-Teil ein klein wenig umgestrickt und statt des ESP8266 (Wlan) ein C1101 Modul (868Mhz) verbaut. Insofern ist das nicht 1:1 vergleichbar. Du kannst auf den AVR zum Beispiel diesen Sketch aufspielen, um einen 2-Kanal HomeMatic Aktor zu erhalten:
HM-LC-Sw2-FM
https://github.com/jp112sdl/Beispiel_As ... -LC-Sw2-FM
Das Komplizierteste an der Hausautomatisation ist der WAF.™ ​

RaspberryMatic 3.45.7.20190511 auf Raspberry Pi 3B mit HomeMatic Funkmodul von ELV und RTC
FritzBox 7490 FW 7.01 mit Mesh
FritzRepeater 1750E FW 7.01 mit Mesh
FRITZ!DECT 200 (als CUxD Gerät eingebunden)
Etliche selbst gebaute Aktoren und Sender

Benutzeravatar
WRadebeul
Beiträge: 59
Registriert: 29.01.2018, 13:53

Re: Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Beitrag von WRadebeul » 10.04.2019, 23:14

Hallo,

habe endlich die Zeit gefunden das Projekt weiter zu bauen.
Das Auflöten des Atmega 328P AU hat recht gut geklappt, besser als erwartet.

Allerdings scheitere ich derzeit am Bootloader.

Ich verwende einen USBASP mit folgenden bootloader von TomMayor: https://github.com/TomMajor/AskSinPP/bl ... o_8MHz.hex
Der Anschluß an die Platine 3 erfolgt über die Pins des CC1101 (noch nicht aufgelötet) mit der folgenden Belegung:
platine 3.PNG
Beim Auslesen der Fuses:

Code: Alles auswählen

>avrdude.exe -c usbasp -p m328p -U lfuse:r:low_fuse_val.hex:h -U hfuse:r:high_fuse_val.hex:h
bekomme ich dann folgende FeFehlermeldung:

Code: Alles auswählen

avrdude.exe: error: program enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
             Double check connections and try again, or use -F to override
             this check.
Auch bei der Verwendung der Arduino Software bekam ich die Fehlermeldung

Code: Alles auswählen

Arduino: 1.8.6 (Windows 10), Board: "ATmega328/P/PB, Atmega328P, Yes (Normal Arduino Serial/USB Upload), 8MHz Internal Oscillator, LTO Enabled, 2.7v, Default, Default, Default"

C:\Users\xx\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino14/bin/avrdude -CC:\Users\xx\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino14/etc/avrdude.conf -v -patmega328p -cusbasp -Pusb -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xE2:m 

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\xx\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino14/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : usbasp
avrdude: Warning: cannot query manufacturer for device: No such file or directory
avrdude: Warning: cannot query product for device: No such file or directory
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'

avrdude done.  Thank you.

Fehler beim Brennen des Bootloaders.
Zuvor habe ich bei einem frischen Arduino Pro mini 3,3V 8MHz die Fuses erfolgreich setzen können.

Code: Alles auswählen

/avrdude -v -pm328p -cusbasp -Ulfuse:w:0xFF:m -Uhfuse:w:0xD2:m -Uefuse:w:0xFF:m
Ich vermute ich verwechsle vielleicht etwas und verwende den falschen Code. Der Atmega 328P AU hat einen intigrierten Quarz,
der Pro Mini hat einen externen Quarz.

Ist für mich die erste Verwendung eines Atmega 328P AU und eines bootloaders.

Ihr könnt mir sicher auf die Sprünge helfen was ich wohl falsch mache...
Raspberry, CUL 868, NeoCreator

Benutzeravatar
Gelegenheitsbastler
Beiträge: 492
Registriert: 15.10.2017, 07:29
Hat sich bedankt: 1 Mal

Re: Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Beitrag von Gelegenheitsbastler » 11.04.2019, 06:09

Ich kenne weder USBASP, noch arbeite ich mit dem verlinkten Bootloader. Daher kann ich nur mehr oder weniger raten.

Was hast Du unter "Werkzeuge - Board" ausgewählt?
Falls möglich, mach doch bitte mal ein Foto/Screenshot von Deinen dortigen Einstellungen.

Auf der Platine ist der optionale externe Oszillator nicht verbaut, weil er nicht notwendig ist.

edit:
Zeig doch bitte mal ein gut auflösendes Fotos von Deiner Platine. Vielleicht findet sich schon optisch eine mögliche Fehlerquelle.
Zuletzt geändert von Gelegenheitsbastler am 11.04.2019, 06:43, insgesamt 3-mal geändert.

deimos
Beiträge: 2956
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 33 Mal
Kontaktdaten:

Re: Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Beitrag von deimos » 11.04.2019, 06:27

Hi,

ich sehe hier drei Möglichkeiten:

Der ATmega ist eingestellt auf einen externen Quarz, bei fabrikneuen ist das nicht der Fall.

Lötfehler bzw. kalte Lötstelle an den Pins vom ATmega.

Verdrahtungsfehler, kann ich aber mangels genauer Kenntnis der Platine nicht sagen.

Am wahrscheinlichsten sehe ich zwei oder drei. Also Verdrahtung prüfen jnd alle Pins durchklingeln.

Viele Grüße
Alex

Benutzeravatar
WRadebeul
Beiträge: 59
Registriert: 29.01.2018, 13:53

Re: Nachbau HM-Geräte mit AVR und AskSinPP - Platine 3

Beitrag von WRadebeul » 11.04.2019, 09:28

Ok, danke.
werde das mal prüfen und berichten.
Raspberry, CUL 868, NeoCreator

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“