HB-OU-MP3-LED

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

jp112sdl
Beiträge: 2884
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 16.05.2019, 20:59

Garagenloeter hat geschrieben:
16.05.2019, 20:35

MP3 Player nicht angeschlossen.
kann es daran liegen?
Ja.

VG,
Jérôme

Garagenloeter
Beiträge: 172
Registriert: 04.07.2018, 21:52

Re: HB-OU-MP3-LED

Beitrag von Garagenloeter » 16.05.2019, 21:17

ah, ok.
wie bei den 18B20 sensoren.

danke

und wie ist das mit der LED?

Garagenloeter
Beiträge: 172
Registriert: 04.07.2018, 21:52

Re: HB-OU-MP3-LED

Beitrag von Garagenloeter » 16.05.2019, 21:45

MP3 Player und Neopixel angeschlossen.
gleiches Ergebnis.
Und alle RGB's leuchten rot.

Code: Alles auswählen

AskSin++ V4.1.0 (May 16 2019 20:27:33)
Address Space: 32 - 567
CC init1
CC Version: 14
 - ready
Enable PinPolling: 6 - 1
DFPlayer Init Error.
Verdrahtung mehrfach geprüft, alles OK.

jp112sdl
Beiträge: 2884
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 16.05.2019, 22:26

LED ist egal.

Code: Alles auswählen

DFPlayer Init Error.
Irgendwas mit MP3 Player. Keine SD Card drin?

VG,
Jérôme

Garagenloeter
Beiträge: 172
Registriert: 04.07.2018, 21:52

Re: HB-OU-MP3-LED

Beitrag von Garagenloeter » 16.05.2019, 22:34

SD Karte ist drin.
mit FAT32 formatiert und mit 4 MP3 bestückt. 0001 bis 0004.mp3

jp112sdl
Beiträge: 2884
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 16.05.2019, 22:54

Garagenloeter hat geschrieben:
16.05.2019, 21:45
Und alle RGB's leuchten rot.
Hast mal ein Foto vom Aufbau/Verdrahtung?

VG,
Jérôme

Garagenloeter
Beiträge: 172
Registriert: 04.07.2018, 21:52

Re: HB-OU-MP3-LED

Beitrag von Garagenloeter » 16.05.2019, 23:22

mach ich gerne, aber morgen...

jp112sdl
Beiträge: 2884
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 17.05.2019, 07:02

Alle LEDs werden rot geschaltet, wenn es Probleme beim Init gibt.
Ist also kein LED-Fehler, sondern nur die Signalisierung des DFPlayer Problems.

Code: Alles auswählen

if (!DFPlayer.Device.begin(DFSerial)) {
  DPRINTLN(F("DFPlayer Init Error."));
  FastLED.setBrightness(64);
  fill_solid(LED.Pixels, LED.PixelCount, CRGB::Red);
...
}
Und was der Player für ein Problem hat, gilt es herauszufinden...

Bei der DFPlayer-Lib sind auch Beispielsketche dabei. Du könntest auch mal versuchen, einen solchen zum Laufen zu bekommen

VG,
Jérôme

Jack01
Beiträge: 37
Registriert: 01.02.2017, 17:08

Re: HB-OU-MP3-LED

Beitrag von Jack01 » 17.05.2019, 09:38

Ich hatte das gleiche Problem mit dem DFPlayer Init Error. Habe ihn dann mit 5V versorgt (und Pegelwandler dazwischen gesetzt). Dann funktionierten die LEDs und ich konnte ihn auch über die Homematic CCU ansprechen. Leider bekomme ich immer noch keine Soundausgabe. Ich habe 2 Player getestet. Beide funktionieren im "Stand alone" Mode. Nur eben nicht in dieser Konfiguration. Da muß ich noch ein wenig suchen.
Laut Datenblatt soll der Player mit einer Spannung zwischen 3,2 und 5V funktionieren, wobei 4,2 V typisch sein soll (so interpretiere ich das mal).
DFPlayer Mini.PNG
Gruß

Hans-Jürgen
1 x CCU2 und 26 Geräte (5 x HomeBrew)
RaspberryMatic als Back-Up
Remote Control via TinyMatic und VPN

jp112sdl
Beiträge: 2884
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 17.05.2019, 09:50

Hast du die MP3 Dateien in einen Unterordner mp3 auf der SD Karte abgelegt und diese auch nach dem Schema 0001.mp3, 0002.mp3, ... benannt?

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“