Cuxd verliert Kommunikation

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

aha
Beiträge: 68
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Cuxd verliert Kommunikation

Beitrag von aha » 02.01.2021, 17:19

Habe cuxd erst seit einem halben Jahr im Einsatz, aber aus mir unerfindlichen Gründen heisst es immer wieder mal (ca alle 4-6 Wochen?) im der CCU, dass es eine Kommunikationsstörung zu meinem iPerl Hauswasserzähler gibt. Das ist halt das einzige Gerät das ich im Cuxd habe.

Da dies über Cuxd und wmbus läuft habe ich am Anfang einfache die ganze CCU neu gestartet. Die letzten zwei mal scheint ein Neustart des cuxd daemon allein ausgereicht zu haben.

Ich gehe deshalb momentan davon aus, dass es nicht die wmbus Funkverbindung ist, sondern der cuxd selbst der die Verbindung mit der CCU einstellt. Der Fehler zieht sich durch jede RaspMatic Version seit ich cuxd nutze.

Handelt es sich hierbei um ein bekanntes Problem? Was wird im Zweifel gebraucht, um die Ursache zu finden. Es ist denke ich 100% sicher, dass es wieder auftritt, es kann nur halt wochen dauern...

Software ist immer aktuell, also raspmatic 3.55 release sofort drauf. Cuxd release auch immer aktuell, aktuell 2.5.0. wobei es seir der installation von 2.5.0 dieses mal keine 4-6 wochen gedauert hat.

Benutzeravatar
uwe111
Beiträge: 4264
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 73 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von uwe111 » 02.01.2021, 20:21

aha hat geschrieben:
02.01.2021, 17:19
Ich gehe deshalb momentan davon aus, dass es nicht die wmbus Funkverbindung ist, sondern der cuxd selbst der die Verbindung mit der CCU einstellt. Der Fehler zieht sich durch jede RaspMatic Version seit ich cuxd nutze.

Handelt es sich hierbei um ein bekanntes Problem? Was wird im Zweifel gebraucht, um die Ursache zu finden. Es ist denke ich 100% sicher, dass es wieder auftritt, es kann nur halt wochen dauern...
Ja, manchmal stürtzt leider der im871a USB-Stick einfach ab und funktioniert dann erst wieder nach erneuter Initialisierung.
Dafür gibt es im CUxD den TTYMAXIDLE= Parameter. (z.B. TTYMAXIDLE=ttyUSB0:130 initialisiert ein an ttyUSB0 angeschlossenes Gateway nach 130 Minuten Inaktivität neu)

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.5, SSH KeyDir

aha
Beiträge: 68
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 04.01.2021, 08:58

Ok, kann ich als Würgaround einstellen.

Hast du diesen Bug dem Hersteller des Sticks gemeldet, damit er seine Firmware fixt?

Können wir den Beweis führen, dass der Stick nicht mehr reagiert und der Fehler nicht in Cuxd liegt? Das wird sicher das erste sein, dass die versuchen das Thema schnell von sich abzuwälzen.

mpcc
Beiträge: 639
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von mpcc » 04.01.2021, 18:05

Ich bin zwar der Meinung , dass wir das dem Hersteller schon mal
gemeldet hatten.
Da ich mir nicht 100% ig sicher bin , habe ich die Anfrage jetzt
noch mal gestellt ...

Info folgt ...
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

mpcc
Beiträge: 639
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von mpcc » 15.01.2021, 19:55

Sooooo wir haben den Hersteller noch mal kontaktiert
aber dort ist das so nicht bekannt ...

Einzige Möglichkeit wäre es mal die Firmware-Version des WMBus Sticks zu prüfen.
Veraltet wäre 1.2 die neueste ist 1.3

Die Firmware Version findest du auf der CUXD Seite.

Wenn dass aber eine V 1.3 schon ist bleibt nur die Lösung mit dem IDLE Mode
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

aha
Beiträge: 68
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 23.01.2021, 12:06

Hab in cuxd grschaut. Da heisst es FW1.3. Von daher ist es wohl aktuell.

Also müssen wir den Hersteller bitten seinen bug zu fixen.

Die verkaufen ihren stick meines wissens mit einer windows software, damit man geräte parametetrisieren kann. Da ist dann auch logisch, dass kein kunde seinen laptop wochenlang laufen lässt. In dessen folge tritt der fehler dort „nie“ auf.

mpcc
Beiträge: 639
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von mpcc » 23.01.2021, 12:58

aha hat geschrieben:
23.01.2021, 12:06
Also müssen wir den Hersteller bitten seinen bug zu fixen.
Das haben wir ja getan aber momentan weiß noch niemand wo der eigentliche Fehler steckt ...
Das kann sicher auch länger dauern und deshalb auch der Workaround.
Wenn der für dich keine Lösung ist , dann bitte den Stick zurückgeben.

Um die Ursache weiter einzugrenzen müsstest du weitere Sachen checken , denn deine Konfig
haben wir ja hier nicht.

1. Der Pearl ist dein einziges Gerät am WMBus ?
2. Hängen weitere USB Geräte am Raspi ?
3. Wie groß ist der Abstand zwischen Pearl und Stick ?
4. Aller wieviel Minuten sendet der Pearl ?
5. Beseitigt der Workaround das Problem ?
6. Sendet der Stick noch Daten im Terminalfenster wenn in der WEBUI keine Aktualisierung erfolgt ?
7. kannst du anfangen den Zeitraum von CUXD Restart bis zur Einstellung der Kommunikation zu loggen ?
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

aha
Beiträge: 68
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 24.01.2021, 22:12

mpcc hat geschrieben:
23.01.2021, 12:58
aha hat geschrieben:
23.01.2021, 12:06
Also müssen wir den Hersteller bitten seinen bug zu fixen.
Das haben wir ja getan aber momentan weiß noch niemand wo der eigentliche Fehler steckt ...
Das kann sicher auch länger dauern und deshalb auch der Workaround.
Wenn der für dich keine Lösung ist , dann bitte den Stick zurückgeben.

Um die Ursache weiter einzugrenzen müsstest du weitere Sachen checken , denn deine Konfig
haben wir ja hier nicht.

1. Der Pearl ist dein einziges Gerät am WMBus ?
2. Hängen weitere USB Geräte am Raspi ?
3. Wie groß ist der Abstand zwischen Pearl und Stick ?
4. Aller wieviel Minuten sendet der Pearl ?
5. Beseitigt der Workaround das Problem ?
6. Sendet der Stick noch Daten im Terminalfenster wenn in der WEBUI keine Aktualisierung erfolgt ?
7. kannst du anfangen den Zeitraum von CUXD Restart bis zur Einstellung der Kommunikation zu loggen ?
Ich bin willig, aber ahnunglos bei den Details...

1. ja, der stick wird ausschliesslich für den iperl genutzt. Andere wmbus geräte gibt es nicht im haus.
2. nur noch ein sehr kleiner 32gb stick für backups
3. ca. 6-7m. Eine 11,5cm gemauerte wand (4m entfernt) und doppelt beplanke GK Box um den Wasserzähler.
4. alle 60min + tolleranz
5. schwer zu sagen... dauert unter umständen 2 -3 monate, um dazu eine unsichere Aussage treffen zu können.
6. du meinst im cuxd fenster wo man normalerweise die einträge sieht? Nein, da kommt nichts mehr.
7. hast du einen tipp, wie?

mpcc
Beiträge: 639
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von mpcc » 31.01.2021, 20:36

->>> 7. kannst du anfangen den Zeitraum von CUXD Restart bis zur Einstellung der Kommunikation zu loggen ?

Du machst halt einen Restart und dann fällt die Kommunikation aus.
Es wäre jetzt halt gut zu wissen , ob die Zeit vom Restart bis zum Ausfall
immer dieselbe ist .... reicht ja erst mal in Tagen ....
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

aha
Beiträge: 68
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 14.02.2021, 09:07

Ich sag mal, nein. Heute um 00:30uhr firmware update vom raspmatic auf 3.55.10 gemacht, um 3:57 uhr kommunikationsstörung. Bisher lag das eher im 6 wochenbereich. Gerade laufen noch firmware updates von 9 brolls... weiss nicht ob die signale sich stören.

Antworten

Zurück zu „CUxD“