Gerät entfernt -> "internal error" in direkten Verknüpfungen

Fehler in Firmware und WebUI & Workarounds

Moderator: Co-Administratoren

hugomatic
Beiträge: 4
Registriert: 27.06.2018, 21:50

Gerät entfernt -> "internal error" in direkten Verknüpfungen

Beitrag von hugomatic » 27.06.2018, 22:00

Hallo zusammen,

ich habe in meiner CCU2 ein Gerät entfernt, für welches direkte Verbindungen konfiguriert waren. Nun scheint dieses Gerät zu fehlen und ich kann die direkten Verbindungen nicht mehr konfigurieren.

Folgende Fehlermeldung wird beim Aufrufen der direkten Verbindungen angezeigt:

sid=@uNbD678c20@
An internal error was detected in the service software. The diagnostics are being emailed to the service system administrator (root).
can't read "sender_type": no such variable
while executing
"set SENTRY(SENDER_TYPE) $sender_type"
(procedure "put_tablebody" line 129)
invoked from within
"put_tablebody"
(procedure "put_page" line 42)
invoked from within
"put_page"

Ein Backup habe ich leider nicht verfügbar.
Meine CCU2 läuft auf Version 2.27.7

Das Gerät welches noch in der CCU2 konfiguriert ist und zu dem die direkte Verbindung bestand kenne ich.

Tausend Dank für eure Lösungstips!
Grüße

Benutzeravatar
Sammy
Beiträge: 7019
Registriert: 09.09.2008, 20:47

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von Sammy » 27.06.2018, 22:45

Gerät einfach wieder an die CCU anlernen?
Links: CCU-Logik, Tipps für Anfänger, WebUI-Doku, Expertenparameter, virtuelle Aktorkanäle
Inventur vom 22.01.14: 516 Kanäle in 165 Geräten, 132 Programme, 270 Direkte Verknüpfungen
Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

dtp
Beiträge: 5332
Registriert: 21.09.2012, 08:09
Wohnort: Stuttgart

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von dtp » 29.06.2018, 13:10

Oder einfach die mit dem "Einfahrt in die Einbahnstraße verboten"-Schild markierte DV löschen und dann wieder eine neue anlegen.

hugomatic
Beiträge: 4
Registriert: 27.06.2018, 21:50

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von hugomatic » 29.06.2018, 19:46

Hallo danke für die Antworten,

da ich die direkten Verknüpfungen nicht mehr bearbeiten kann, kann ich die defekte Verbindung leider auch nicht löschen.

Das muss doch ein bekannter Bug sein, die direkten Verbindungen nicht mehr editierbar sind, wenn man ein Gerät löscht. Hier muss es doch Lösungen geben. Wundert mich auch, das der Fehler überhaupt möglich ist und nicht abgefangen wird...

Grüße

Benutzeravatar
Sammy
Beiträge: 7019
Registriert: 09.09.2008, 20:47

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von Sammy » 29.06.2018, 21:00

Zeig doch mal einen Screenshot von der Stelle, wo es hakt.
Links: CCU-Logik, Tipps für Anfänger, WebUI-Doku, Expertenparameter, virtuelle Aktorkanäle
Inventur vom 22.01.14: 516 Kanäle in 165 Geräten, 132 Programme, 270 Direkte Verknüpfungen
Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

hugomatic
Beiträge: 4
Registriert: 27.06.2018, 21:50

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von hugomatic » 02.07.2018, 21:36

Anbei der Screenshoot
Dateianhänge
2018-07-02 21_35_51-.jpg
Anbei der Screenshoot

Benutzeravatar
Sammy
Beiträge: 7019
Registriert: 09.09.2008, 20:47

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von Sammy » 02.07.2018, 22:43

Das kommt mir sehr bekannt vor. Ich komm momentan bloß nicht drauf, was die Lösung war oder wie passende Suchbegriffe lauten.

Entweder war es Avira Browserschutz, der aktiv war, oder einfach nur Browsercache löschen, oder eine Systemvariable mit Sonderzeichen wurde der Startseite zugefügt, oder ein Fehler im XML-File.
Vielleicht meldet sich ja noch jemand, der sich besser erinnert oder es direkt weiß. Keine Ahnung, ob mir der entscheidende Tipp oder Begriff noch wieder einfällt.

Gruß Sammy
Links: CCU-Logik, Tipps für Anfänger, WebUI-Doku, Expertenparameter, virtuelle Aktorkanäle
Inventur vom 22.01.14: 516 Kanäle in 165 Geräten, 132 Programme, 270 Direkte Verknüpfungen
Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

dtp
Beiträge: 5332
Registriert: 21.09.2012, 08:09
Wohnort: Stuttgart

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von dtp » 03.07.2018, 08:29

An die direkte Lösung dieses Problems kann ich mich leider auch nicht erinnern. Aber es hat per se erst mal nichts mit dem Löschen eines Gerätes bei bestehender DV mit einem anderen Gerät zu tun. Es sollte nämlich problemlos möglich sein, eine DV zu löschen, für die bereits eines der verknüpften Geräte gelöscht wurde. Hab ich selbst schon x-fach ohne Probleme durchgeführt. Und selbst, wenn man beide Geräte einer DV löscht, sollte sich die DV noch nachträglich löschen lassen, wenn ansonsten alles stimmt.

Im vorliegenden Fall scheint mir noch etwas anderes im Argen zu liegen.

alchy
Beiträge: 7649
Registriert: 24.02.2011, 01:34

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von alchy » 03.07.2018, 13:03

Inhalt von cgimail.* in /var/tmp oder /tmp posten wäre einen Versuch wert

Alchy

.................... Full
Ignoranz ist die Summe aller Maßnahmen die man ergreift, um bestehende Tatsachen nicht sehen zu müssen.

© Sandra Pulsfort (*1974)

Lies bitte die Logik von WebUI Programmen und die Tipps und Tricks für Anfänger.

Wichtig auch CUxD ersetzt System.exec. Die HM Script Doku (Downloadart Skripte) hilft auch weiter.
Zum Testen von Scripten den >> HomeMatic Script Executor << von Anli benutzen.

Benutzeravatar
AndiN
Beiträge: 2237
Registriert: 10.06.2015, 08:54
Wohnort: Hennef

Re: Gerät entfernt -> "internal error" in direkten Verknüpfu

Beitrag von AndiN » 03.07.2018, 14:46

Hallo zusammen,

war es das was ihr in Erinnerung hattet? Hilft das evtl. weiter?

Andi
Greenhorn

Letzter Reboot: 26.10.18 - FW Update // Uptime-Rekord: 65 Tage
Systeminfos: 171 Variablen, 85 Programme, 2810 Datenpunkte, 438 Kanäle, 126 Geräte (4x CUX28 (1 Timer, 1 Ping/Alive, 1 Exec, 1x CCU CPU))
Raspberry Firmware: 3.37.8.20181026
Addons: Drucken 1.2a - HQ WebUI 2.5.5 - XML-API 1.18 - CUx-Daemon 2.1.0 - E-Mail 1.6.8a - hm_pdetect 1.3 - VPN cloudmatic
System angebunden: 3 Roomba 650 Staubsauger - 1 Sprachausgabe via Home24 Media - Zentrale: Asus TF103 mit Home24 Tablet


Diverse Links

Antworten

Zurück zu „HomeMatic - bekannte Bugs“