RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

sissiwup
Beiträge: 265
Registriert: 10.03.2015, 10:54
Wohnort: Süd NDS
Hat sich bedankt: 1 Mal

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von sissiwup » 16.12.2018, 21:04

iberti hat geschrieben:
27.11.2018, 23:15
Bei mir sind alle Geräte verschwunden in Status und Bedienung - Geräte.

Alle Thermostate zeigen 0 an sowohl für Temperatur als auch für Luftfeuchte.

CUxDaemon zeigt folgendes:

Kein TTY-Device connected!

Nicht mit HomeMatic-CCU 127.0.0.1:8183 verbunden!

als RPC-Server(INIT) von 127.0.0.1:31999 (1237) angefordert!
Nicht als RPC-Server von der CCU angefordert!
Hast du da eine Lösung für?
MfG

Sissiwup

--------------------------------------------
CCu3,CCu2Gateway,RaspiGateway,LanGateway
--------------------------------------------

JoMass
Beiträge: 196
Registriert: 26.11.2016, 12:52
Hat sich bedankt: 3 Mal
Danksagung erhalten: 5 Mal

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von JoMass » 16.12.2018, 23:25

Sorry, weis nicht was schon alles passiert ist …

aber ich würde auf dem USB Stick eines der täglichen Backups der letzten 30 Tage auswählen und auf den PC laden

Neue SD Karte mit raspberrymatic flashen

Neu starten und Backup einspielen

=== einen Versuch wäre es wert !
JoMass
~150 Geräte; ~70 Programme FW: 3.51.6.20200621 – RaspberryPi4 als CCU - HISTORIAN V2.4.0 auf QNAP; Mediola AIO Creator NEO - RedMatic

Kurt aus Grosselfingen
Beiträge: 5
Registriert: 16.12.2018, 18:25

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von Kurt aus Grosselfingen » 17.12.2018, 10:32

iberti hat geschrieben: ↑Bei mir sind alle Geräte verschwunden in Status und Bedienung - Geräte.

Alle Thermostate zeigen 0 an sowohl für Temperatur als auch für Luftfeuchte. 

CUxDaemon zeigt folgendes:

Kein TTY-Device connected!

Nicht mit HomeMatic-CCU 127.0.0.1:8183 verbunden!

als RPC-Server(INIT) von 127.0.0.1:31999 (1237) angefordert!
Nicht als RPC-Server von der CCU angefordert!


CUL Stick nach dem start abziehen und wieder anstecken. Dann geht.

LG kurt
Zuletzt geändert von Kurt aus Grosselfingen am 17.12.2018, 14:28, insgesamt 1-mal geändert.
Raspberry Pi3 mit Raspberrymatic 3.41... gebootet von SSD, Cuxd mit nanoCUL für FS20 , Funkmodul RPI-RF-MOD, USB-Stick für Diagramme

edsch
Beiträge: 6
Registriert: 06.08.2018, 13:09

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von edsch » 17.12.2018, 14:03

Hallo zusammen,

ich bin seit Sommer 2018 Neueinsteiger mit Raspberry PI 3 B+ Charly, cull 433 Mhz, 16 HMIP Geräte, 11 Somfy Rolläden.

Wegen Unsicherheit habe ich mit dem Updaten auf 3.41 bis jetzt gewartet.
Jetzt wollte ich zur Sicherung ein Backup erstellen, was aber nicht funktioniert.
Wird das Backup in Download gesichert?
Meine aktuelle Firmware ist noch 2.35.16.20180826.
In der Aufforderung Backup erstellen wird folgendes angezeigt "${dialogSettingsSecurityMessageCreateSysBackupTitle}"

Für Hilfe wäre ich dankbar.

Danke vorab

Edwin

MikeEcho
Beiträge: 19
Registriert: 07.03.2018, 11:48

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von MikeEcho » 17.12.2018, 16:37

Hallo.
Ich habe heute einen Raspi3 frisch mit der aktuellen Version aufgesetzt. Mein Problem ist der SSH-Zugang:

SSH aktivieren klappt, aber ein SSH Passwort vergeben (auch trivial "1234") klappt nicht. Das Fenster mit "Die Einstellungen werden gespeichert" läuft endlos.

Gruss
Mike

NickHM
Beiträge: 2862
Registriert: 23.09.2017, 12:04
Hat sich bedankt: 16 Mal
Danksagung erhalten: 21 Mal

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von NickHM » 17.12.2018, 17:17

MikeEcho hat geschrieben:
17.12.2018, 16:37
Hallo.
Ich habe heute einen Raspi3 frisch mit der aktuellen Version aufgesetzt. Mein Problem ist der SSH-Zugang:

SSH aktivieren klappt, aber ein SSH Passwort vergeben (auch trivial "1234") klappt nicht. Das Fenster mit "Die Einstellungen werden gespeichert" läuft endlos.

Gruss
Mike
Da ich das jetzt hier schon von 2...3 Usern in verschiedenen Beiträgen gelesen habe und es in diesem Endlosbeitrag ggf. untergeht, würde ich dazu raten einen eigenen Beitrag dazu aufzumachen.

PS der Erfinder meint, das Problem sei schon gefixt
viewtopic.php?p=476793#p476793
Zuletzt geändert von NickHM am 17.12.2018, 17:28, insgesamt 1-mal geändert.

Benutzeravatar
jmaus
Beiträge: 5993
Registriert: 17.02.2015, 14:45
System: Alternative CCU (RaspberryMatic etc.)
Wohnort: Dresden
Hat sich bedankt: 16 Mal
Danksagung erhalten: 336 Mal
Kontaktdaten:

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von jmaus » 17.12.2018, 17:20

RaspberryMatic 3.51.6.20200621 @ ESXi mit ~180 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

MikeEcho
Beiträge: 19
Registriert: 07.03.2018, 11:48

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von MikeEcho » 17.12.2018, 19:38

NickHM hat geschrieben:
17.12.2018, 17:17

Da ich das jetzt hier schon von 2...3 Usern in verschiedenen Beiträgen gelesen habe und es in diesem Endlosbeitrag ggf. untergeht, würde ich dazu raten einen eigenen Beitrag dazu aufzumachen.

PS der Erfinder meint, das Problem sei schon gefixt
viewtopic.php?p=476793#p476793
Die Befürchtung hatte ich auch und habe ein eigenes Thema daraus gemacht, danke.

Leider löst der angegebene Thread mein Problem (noch) nicht.

Benutzeravatar
klana
Beiträge: 580
Registriert: 08.02.2015, 08:37

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von klana » 18.12.2018, 20:38

Hallo Zusammen,

ich hatte vor ein paar Tage schon mal zu meinem Problem etwas gepostet.viewtopic.php?f=65&t=47083&start=330#p475949)
Es geht darum, dass der Speicher immer weniger wird und nach ca. 8-10 Tagen die RM einfachen stehen bleibt.
Ich habe alle Programme welchen irgendwie größere Datenmengen nutze abgeschaltet (z.B. OpenWeather, DWD Unwetterwarnung...)
Trotzdem verliere ich weiter Speicher (ja ich weiß das der dynamisch reserviert und wieder frei gegeben wird) und es wird wohl bald soweit sein,
dass wieder alles hängt.

Also nach dem letzten Neustart von ca. 680.000 kb auf mittlerweile 148.000 kb runter.

Irgendwer noch eine Idee dazu?
Bin drauf und dran, die ganzen 158 Geräte und alles was dazu gehört komplett neu aufzusetzen, aber das ist halt eine Schweinearbeit :cry:

Gruß
Klana
IMG_5481.PNG
IMG_5508.PNG

PS: Der Speicher von CuxD bleibt immer schön gleich

Code: Alles auswählen

  USB 1-1 - (9514) [HUB] - Sun Dec  9 06:52:42 2018
  USB 1-1.1 - (ec00) [FF] - no driver - Sun Dec  9 06:52:42 2018
  USB 1-1.5 - Ultra Fit [STORAGE] - Sun Dec  9 06:52:42 2018
  Kein TTY-Device connected!

  Erfolgreich mit HomeMatic-CCU 127.0.0.1:8183 verbunden!

  als RPC-Server(INIT) von HomeMatic-CCU (1238) angefordert!

  Diese Web-Seite wurde aufgerufen von: 10.200.201.66

  CUxD-Uptime(2.2.0):              9 Tag(e) 13:47:56, 155640 Bytes belegt, Compiled Dec  5 2018 16:02:32
  CCU-Uptime(3.41.11.20181126):    9 Tag(e) 13:50:09, load-average: 0.02 0.02 0.00, 10s-cpu-load: 2.1%
  Speicher:  Total 994132k  Used 821920k  Free 172212k  (Cached 556880k)
  CPU(1): ARMv7 Processor rev 4 (v7l) [38.40 bogomips]
  CPU(2): ARMv7 Processor rev 4 (v7l) [38.40 bogomips]
  CPU(3): ARMv7 Processor rev 4 (v7l) [38.40 bogomips]
  CPU(4): ARMv7 Processor rev 4 (v7l) [38.40 bogomips]
  Linux version 4.14.80 ([email protected]) (gcc version 7.3.0 (Buildroot 2018.08.2-01643-g92b40b03-dirty)) #1 SMP PREEMPT Mon Nov 26 17:17:18 CET 2018
  aktive CCU-Prozesse: ReGaHss(1) rfd(1) hs485d(0) java(1)

  Filesystem: /                  ext4     (ro) Total     999320k  Used     562116k (56.2%)  Free     437204k (43.8%)
  Filesystem: /dev               devtmpfs (rw) Total     492456k  Used          0k ( 0.0%)  Free     492456k (100.0%)
  Filesystem: /dev/shm           tmpfs    (rw) Total     497064k  Used          0k ( 0.0%)  Free     497064k (100.0%)
  Filesystem: /tmp               tmpfs    (rw) Total     497064k  Used        112k ( 0.0%)  Free     496952k (100.0%)
  Filesystem: /run               tmpfs    (rw) Total     497064k  Used         84k ( 0.0%)  Free     496980k (100.0%)
  Filesystem: /var               tmpfs    (rw) Total     497068k  Used       2172k ( 0.4%)  Free     494896k (99.6%)
  Filesystem: /media             tmpfs    (rw) Total     497064k  Used          0k ( 0.0%)  Free     497064k (100.0%)
  Filesystem: /usr/local         ext4     (rw) Total    6123068k  Used     454148k ( 7.4%)  Free    5668920k (92.6%)
  Filesystem: /boot              vfat     (ro) Total     261868k  Used      39424k (15.1%)  Free     222444k (84.9%)
  Filesystem: /media/usb1        vfat     (rw) Total   15008256k  Used     359024k ( 2.4%)  Free   14649232k (97.6%)

  CCU-MAC:     B8:27:EB:FB:43:73
  HM-Config:   /etc/config/homematic.regadom(11951080) OK! - Tue Dec 18 18:54:30 2018
  CUxD-Config: /tmp/cuxd.ps.sav(1137) - D - Tue Dec 18 20:37:42 2018
               /usr/local/addons/cuxd/cuxd.ps(1143) - D - Tue Dec 18 11:57:42 2018
               /usr/local/addons/cuxd/cuxd.ps.bak(1154) - D - Tue Dec 18 00:57:42 2018
  Device-Log:  /media/usb1/log/devlog.txt(736505) - Tue Dec 18 20:39:28 2018
               /media/usb1/logarchive/(11 files)

  aktuelle Parameter: (* = bei Änderung Neustart erforderlich)

	*LISTENPORT      '8700'
	*HM-HOST         '127.0.0.1'
	*HM-SCRIPT-PORT  '' -> (8183)
	*HM-REGA-PORT    '' -> (31999)
	*RPCHOST         '127.0.0.1'
	*RPCPORT         '8701'
	 HTTP-REFRESH    '5'
	 TERMINALLINES   '25'
	 RCVLOGSIZE      '10000'
	 CUXINITCMD      'X21'
	 LOGFILE         ''
	 LOGLEVEL        ''
	 LOGSIZE         ''
	 LOGFILEMOVE     ''
	 DEVLOGFILE      '/media/usb1/log/devlog.txt'
	 DEVLOGSIZE      '1000000'
	 DEVLOGMOVE      '/media/usb1/logarchive/'
	 DEVLOGMOVE-HR   ''
	 DEVLOGEXPORT    ''
	 DEVTIMEFORMAT   '%Y-%m-%dT%X'
	 DEVDATAFORMAT   ''
	 DEVLOGOLDALIAS  '0'
	 SUBSCRIBE-RF    '1'
	 SUBSCRIBE-WR    '1'
	 AUTOSAVE        '1'
	 MOUNTCMD        ''
	 UMOUNTCMD       ''
	 BACKUPCMD       ''
	 SYSLOGMOVE      '/media/usb1/syslogarchive/'
	 SYSLOGMOVEDAILY ''
	 TH-DIR          ''
	 TH-DIR-FILTER   ''
	 ADDRESS-BUFFER  '120'
	 CLOUDMATIC_CMD  '/etc/config/addons/mh/cloudmatic'
	 WEBCAMCONFIG    '/usr/local/addons/cuxd/webcamconfig.ini'
	 WEBCAMSNAPSHOT  '/tmp/snapshots'
	 WEBCAMCACHE     '/tmp/webcams'
	 SYSLOGFILENAME  '/var/log/messages'
	 CUXD-CHARTS     '/etc/config/addons/www/cuxchart/index.html'
	 DFU_ERASE       './dfu-programmer $TARGET$ erase'
	 DFU_FLASH       './dfu-programmer $TARGET$ flash $HEXFILE$'
	 DFU_START       './dfu-programmer $TARGET$ start'


  Aktuelle Geräteeinstellungen - 3 Gerät(e), 35 Channel(s):

  	CUX2800001:1	state(1) timer(0s) set(08:31:00):0
	CUX2800001:2	state(1) timer(0s) set(16:50:00):0
	CUX2800001:3	state(1) timer(0s)
	CUX2800001:4	state(1) timer(0s)
	CUX2800001:5	state(1) timer(0s)
	CUX2800001:6	state(0) timer(0s)
	CUX2800001:7	state(0) timer(0s)
	CUX2800001:8	state(0) timer(0s)
	CUX2800001:9	state(0) timer(0s)
	CUX2800001:10	state(0) timer(0s)
	CUX2800001:11	state(0) timer(0s)
	CUX2800001:12	state(0) timer(0s)
	CUX2800001:13	state(1) timer(10162s) set(05:30:00/09:00:00/16:30:00/23:30:00):3 repeat
	CUX2800001:14	state(1) timer(0s) repeat CMD.system(60s,extra/timer.tcl BidCos-RF.MEQ0363084:1.STATE 1 0 0 $ONTIME$)
	CUX2800001:15	state(1) timer(0s) repeat CMD.system(60s,extra/timer.tcl BidCos-RF.LEQ0529290:1.STATE 1 0 0 $ONTIME$)
	CUX2800001:16	state(1) timer(0s) repeat CMD.system(60s,extra/timer.tcl BidCos-RF.MEQ0362407:1.STATE 1 0 0 $ONTIME$)
	CUX2801001:1	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT(cat /boot/VERSION)
			KEY-LONG CMD_LONG()
	CUX2801001:2	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:3	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:4	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:5	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:6	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:7	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:8	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:9	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:10	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:11	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:12	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:13	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:14	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:15	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX2801001:16	rmax(65535) t(3600s) p(0)
			KEY-SHORT CMD_SHORT()
			KEY-LONG CMD_LONG()
	CUX9002001:	mode(3) T h(0.40)
	CUX9002001:1	SET
	CUX9002001:2	SET


  Aktuelles Logging (/media/usb1/log/devlog.txt):

	 1.   LEQ0534622
	 2.   LEQ0534487


  gefundene Adressen (aktuelle zuerst 20:40:38):
Es ist nett, wichtig zu sein. Aber es ist wichtiger, nett zu sein.

Benutzeravatar
jmaus
Beiträge: 5993
Registriert: 17.02.2015, 14:45
System: Alternative CCU (RaspberryMatic etc.)
Wohnort: Dresden
Hat sich bedankt: 16 Mal
Danksagung erhalten: 336 Mal
Kontaktdaten:

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von jmaus » 18.12.2018, 21:08

klana hat geschrieben:
18.12.2018, 20:38
Trotzdem verliere ich weiter Speicher (ja ich weiß das der dynamisch reserviert und wieder frei gegeben wird) und es wird wohl bald soweit sein,
dass wieder alles hängt.
Also ich sehe aus deinen Daten nicht wirklich das da etwas kritisch ist:

Code: Alles auswählen

Speicher:  Total 994132k  Used 821920k  Free 172212k  (Cached 556880k)
Da steht zwar "Free 170MB" aber bei "Cached 556MB" solltest du eigentlich aufatmen. Zeig mal den Skript den du benutzt um dir den freien Speicher berechnen/anzeigen zu lassen.
RaspberryMatic 3.51.6.20200621 @ ESXi mit ~180 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Gesperrt

Zurück zu „RaspberryMatic“