Addons seit Update nicht mehr aufrufbar

Fehler in Firmware und WebUI & Workarounds

Moderator: Co-Administratoren

Antworten
SKB
Beiträge: 6
Registriert: 28.11.2018, 11:51

Addons seit Update nicht mehr aufrufbar

Beitrag von SKB » 28.11.2018, 12:14

Hallo,
habe mich jetzt auch mal hier angemeldet, da ichon länger RaspberryMatic auf dem Raspi einsetze.

Seit gestern - wo ich upgedated habe - kann ich zwar "Zusatzsoftware" aus der Systemsteuerung aufrufen,
jedoch kann ich keine Einstellungen mehr vornehmen oder neue Addons installieren.

Es kommt als Fehler folgendes:
Fehler.PNG
Fehler.PNG (18.5 KiB) 285 mal betrachtet
Deinstallieren kann man Addons leider auch nicht. Dort erscheint dieser Fehler:
Fehler.PNG
Auch die Versionen werden nicht mehr richtig angezeigt:
Fehler.PNG
Fehler.PNG (8.33 KiB) 285 mal betrachtet
Weiss hier jemand Rat?

Danke Euch :)
Zuletzt geändert von SKB am 28.11.2018, 12:29, insgesamt 1-mal geändert.

SKB
Beiträge: 6
Registriert: 28.11.2018, 11:51

Re: Addons seit Update nicht mehr aufrufbar

Beitrag von SKB » 28.11.2018, 12:29

Habe jetzt herausgefunden, dass der Verzeichnispfad wohl nicht mehr stimmt, wenn man von aussen kommt.

Ich komme über die Webseite https://hconnectvpn.deike.cc:8443/xxxxx/
Somit ist der komplette Pfad zum addon: https://hconnectvpn.deike.cc:8443/xxxxx/addons/[Add-On]
Die Seite der Zusatzsoftware leitet mich aber nur auf: https://hconnectvpn.deike.cc:8443/addons/[Add-On] weiter

Wenn ich nun ein Add-On konfigurierenn möchte, muss ich von extern immer den Pfad richtig mitgeben.
Das ist relativ nervig.

Auch kann man kein neues Update installieren, da der Pfad im Formular wohl auch nicht stimmt.

Was mich aber wundert, wieso die Versionen nicht richtig abgefragt werden.

ptweety
Beiträge: 146
Registriert: 07.01.2017, 16:48

Re: Addons seit Update nicht mehr aufrufbar

Beitrag von ptweety » 28.11.2018, 14:54

Diese Links riechen aber verdächtig nach Port-Forwarding. Ist dir bewusst, dass davon generell bei der CCU abgeraten wird?

SKB
Beiträge: 6
Registriert: 28.11.2018, 11:51

Re: Addons seit Update nicht mehr aufrufbar

Beitrag von SKB » 28.11.2018, 15:13

Diese Links beinhalten kein Port-Forwading!

Es geht hier ganz verlässlich um den HConnect-Remote-Service: https://hconnectweb.azurewebsites.net/
Lediglich deren VPN-Webserver "hört" auf dem Port.

dtp
Beiträge: 5427
Registriert: 21.09.2012, 08:09
Wohnort: Stuttgart

Re: Addons seit Update nicht mehr aufrufbar

Beitrag von dtp » 28.11.2018, 15:46

Wäre mal interessant zu erfahren, auf welche Firmware-Version du überhaupt aktualisiert hast. Und falls es die 3.41.x ist, dann könnte dein Problem mit den Firewall-Einstellungen in WebUI zu tun haben. Oder einfach mal hier reinschauen.

SKB
Beiträge: 6
Registriert: 28.11.2018, 11:51

Re: Addons seit Update nicht mehr aufrufbar

Beitrag von SKB » 28.11.2018, 16:19

Habe auf die Version 3.41.11.20181126 aktualisiert.

Antworten

Zurück zu „HomeMatic - bekannte Bugs“