HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

HMIP lokale Installation

Moderator: Co-Administratoren

arocker
Beiträge: 8
Registriert: 11.10.2019, 23:12

HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von arocker » 11.10.2019, 23:38

Hallo zusammen!

Ich habe mir eine Lüftungssteuerung für die Badlüftung gebaut mit den Komponenten HmIP-FSM zur Strommessung bei der Gastherme, HmIP-BSM für den Lichtschalter am Bad und ein HmIP-BSM vor dem Badlüfter.

Abhängig von Lichtschalter und Gastherme soll der Badlüfter gesteuert werden. Da ich eine Funktionsweise auch ohne laufende CCU (ich nutze piVCCU) sicherstellen möchte, habe ich die Komponenten mit Direktverknüpfungen miteinander verbunden. Das funktioniert auch soweit alles wie gewünscht.

Jetzt habe ich mal testhalber piVCCU runtergefahren und zunächst funktioniert weiterhin alles wie gewünscht. Ziemlich genau nach einer Stunde reagiert jedoch der HmIP-BSM am Lichtschalter nicht mehr. Genau genommen geht das Licht noch einmal an bei Betätigung des Schalters, danach scheint das Gerät überhaupt nicht mehr zu reagieren (weder Licht Ein/Aus über die interne Direktverknüpfung, noch die Lüftung). Ich kann das Gerät nur wieder aktivieren, wenn ich kurz die Sicherung abstelle.

Ich habe schonmal testhalber alle Geräte in den Werkzustand zurückversetzt und alles neu programmiert. Das hat aber nichts gebracht. Die Firmware-Version der HmIP-BSM habe ich auf die Version 1.12.6 aktualisiert, da in diesem Thread die Rede war von behobenen Problemen mit nicht reagierendem Aktor (viewtopic.php?f=58&t=48751). Der Fehler tritt aber weiterhin auf.

Hat jemand ein derartiges Phänomen schon mal beobachtet? Ich bin gerade unsicher, wie ich das Problem am besten weiter debuggen könnte.
Zuletzt geändert von alchy am 14.10.2019, 20:37, insgesamt 1-mal geändert.
Grund: verschoben aus HomeMatic IP Aktoren und Sensoren

Benutzeravatar
Roland M.
Beiträge: 4963
Registriert: 08.12.2012, 15:53
Wohnort: Graz, Österreich
Hat sich bedankt: 22 Mal
Danksagung erhalten: 98 Mal

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von Roland M. » 11.10.2019, 23:54

Hallo und willkommen im Forum!
arocker hat geschrieben:
11.10.2019, 23:38
Jetzt habe ich mal testhalber piVCCU runtergefahren und zunächst funktioniert weiterhin alles wie gewünscht. Ziemlich genau nach einer Stunde reagiert jedoch der HmIP-BSM am Lichtschalter nicht mehr. Genau genommen geht das Licht noch einmal an bei Betätigung des Schalters, danach scheint das Gerät überhaupt nicht mehr zu reagieren (weder Licht Ein/Aus über die interne Direktverknüpfung, noch die Lüftung). Ich kann das Gerät nur wieder aktivieren, wenn ich kurz die Sicherung abstelle.
In abgeschwächter Form habe ich das auch schon erlebt, hier ging es aber nur um ein paar Sekunden Schaltverzögerung, die beim Einschalten der Beleuchtung aber auch mehr als lästig waren (letztendlich habe ich noch einen AP hingestellt...).
Leider konnte ich damals nicht weiter forschen, ich habe aber eine Vermutung.
Schalte einmal das Routing in den Geräteeigenschaften ab, ich könnte mir vorstellen, dass das Gerät die CCU nicht mehr erreicht und daher versucht, erst ein Gerät mit aktiver Repeater-Funktion (z.B. HmIP-PSM) zu erreichen, sollte ein solcher tatsächlich erreichbar sein, setzt sich dieses Spielchen fort, bis das Gerät irgendwann wirklich zur Einsicht kommt, einen Verknüpfungspartner - die CCU - nicht mehr zu finden.

Wie gesagt nur eine Vermutung, aber einen Versuch wäre es Wert...


Roland
Zur leichteren Hilfestellung bitte unbedingt beachten:
  • Bezeichnung (HM-...) der betroffenen Geräte angeben (nicht Artikelnummer)
  • Kurzbeschreibung des Soll-Zustandes (Was soll erreicht werden?)
  • Kurzbeschreibung des Ist-Zustandes (Was funktioniert nicht?)
  • Fehlermeldungen genau abschreiben, besser noch...
  • Screenshots von Programmen, Geräteeinstellungen und Fehlermeldungen (direkt als jpg/png) einstellen!

-----------------------------------------------------------------------
1. CCU2 mit ~100 Geräten
2. CCU2 per VPN mit ~30 Geräten
3. CCU2 per VPN mit ~40 Geräten
CCU1, Test-CCU2, Raspi mit Funkmodul,...

arocker
Beiträge: 8
Registriert: 11.10.2019, 23:12

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von arocker » 12.10.2019, 00:07

Roland M. hat geschrieben:
11.10.2019, 23:54
Hallo und willkommen im Forum!
Danke!
Roland M. hat geschrieben:
11.10.2019, 23:54
Schalte einmal das Routing in den Geräteeigenschaften ab, ich könnte mir vorstellen, dass das Gerät die CCU nicht mehr erreicht und daher versucht, erst ein Gerät mit aktiver Repeater-Funktion (z.B. HmIP-PSM) zu erreichen, sollte ein solcher tatsächlich erreichbar sein, setzt sich dieses Spielchen fort, bis das Gerät irgendwann wirklich zur Einsicht kommt, einen Verknüpfungspartner - die CCU - nicht mehr zu finden.
Guter Tipp! Ich probiere es mal aus und melde mich, ob es funktioniert hat.

arocker
Beiträge: 8
Registriert: 11.10.2019, 23:12

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von arocker » 12.10.2019, 10:21

Das scheint in der Tat die Lösung gewesen zu sein! Ich habe jetzt die piVCCU über Nacht ausgehabt und es läuft nach wie vor problemlos.
Besten Dank nochmal für die schnelle und kompetente Hilfe! :D

Benutzeravatar
Roland M.
Beiträge: 4963
Registriert: 08.12.2012, 15:53
Wohnort: Graz, Österreich
Hat sich bedankt: 22 Mal
Danksagung erhalten: 98 Mal

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von Roland M. » 12.10.2019, 11:24

Hallo!

Danke für die Rückmeldung, freut mich, dass es funktioniert! :)


Roland
Zur leichteren Hilfestellung bitte unbedingt beachten:
  • Bezeichnung (HM-...) der betroffenen Geräte angeben (nicht Artikelnummer)
  • Kurzbeschreibung des Soll-Zustandes (Was soll erreicht werden?)
  • Kurzbeschreibung des Ist-Zustandes (Was funktioniert nicht?)
  • Fehlermeldungen genau abschreiben, besser noch...
  • Screenshots von Programmen, Geräteeinstellungen und Fehlermeldungen (direkt als jpg/png) einstellen!

-----------------------------------------------------------------------
1. CCU2 mit ~100 Geräten
2. CCU2 per VPN mit ~30 Geräten
3. CCU2 per VPN mit ~40 Geräten
CCU1, Test-CCU2, Raspi mit Funkmodul,...

alsk1
Beiträge: 148
Registriert: 31.10.2018, 18:09
Danksagung erhalten: 3 Mal

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von alsk1 » 12.10.2019, 17:45

Also kann man als Resümee ziehen, das wenn Routing aktiv, die Rückmeldung zu den Geräten nicht erfolgt das die CCU nicht erreichbar ist und somit die Direktverknüpfung greifen sollte?
Das würde ja bedeuten, das in diesem Falle der BSM denkt er hätte zur CCU gefunkt, obwohl der Empfänger nicht die CCU sondern ein Repeater ist.

Macht für mich von der Logik aber keinen Sinn, denn bei einer Direktverknüpfung funkt der BSM eigentlich seinen Partner an und die CCU lauscht nur mit bzw. setzt dann den Status der Aktoren in der WebUI. Demzufolge sollte die Funktion immer gegeben sein, egal ob die CCU erreichbar oder nicht.

Benutzeravatar
Roland M.
Beiträge: 4963
Registriert: 08.12.2012, 15:53
Wohnort: Graz, Österreich
Hat sich bedankt: 22 Mal
Danksagung erhalten: 98 Mal

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von Roland M. » 12.10.2019, 18:00

Hallo!
alsk1 hat geschrieben:
12.10.2019, 17:45
Macht für mich von der Logik aber keinen Sinn, denn bei einer Direktverknüpfung funkt der BSM eigentlich seinen Partner an und die CCU lauscht nur mit
Muss nicht zwangsweise sein, wenn es auch ein Programm auf der CCU gibt, das dieses Gerät anspricht, dann ist die CCU eben auch Partner. Und wenn nicht alle Partner erreicht werden, sucht man eben einen Weg.

So zumindest interpretiere ich es bis jetzt. Wie schon geschrieben, hatte ich keine Zeit, das - auch mit der entsprechenden Anzahl an möglichen Geräten! - zu testen und zu forschen. Bei mir gab's auch "nur" eine Verzögerung von 2 - 3 Sekunden. Aber versuche so, die Lamellenverstellung einer Jalousie wunschgemäß anzufahren! :twisted:


Roland
Zur leichteren Hilfestellung bitte unbedingt beachten:
  • Bezeichnung (HM-...) der betroffenen Geräte angeben (nicht Artikelnummer)
  • Kurzbeschreibung des Soll-Zustandes (Was soll erreicht werden?)
  • Kurzbeschreibung des Ist-Zustandes (Was funktioniert nicht?)
  • Fehlermeldungen genau abschreiben, besser noch...
  • Screenshots von Programmen, Geräteeinstellungen und Fehlermeldungen (direkt als jpg/png) einstellen!

-----------------------------------------------------------------------
1. CCU2 mit ~100 Geräten
2. CCU2 per VPN mit ~30 Geräten
3. CCU2 per VPN mit ~40 Geräten
CCU1, Test-CCU2, Raspi mit Funkmodul,...

arocker
Beiträge: 8
Registriert: 11.10.2019, 23:12

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von arocker » 13.10.2019, 12:47

arocker hat geschrieben:
12.10.2019, 10:21
Das scheint in der Tat die Lösung gewesen zu sein! Ich habe jetzt die piVCCU über Nacht ausgehabt und es läuft nach wie vor problemlos.
Besten Dank nochmal für die schnelle und kompetente Hilfe! :D
Hm, zu früh gefreut. Gestern im Laufe des Tages ging es dann doch wieder nicht. Warum es davor über Nacht nicht ausgefallen ist, kann ich nicht mehr nachvollziehen.

Habe daraufhin gestern noch etwas rumprobiert und auch bei allen anderen HmIP-Geräten das Routing deaktiviert. (Ich dachte eigentlich, das wäre eine "gute" Funktion, um die Empfangsqualität zu verbessern und hatte es einfach überall aktiviert.) Das hat aber auch nicht geholfen. Jetzt bin ich wieder beim Eingangs beschriebenen Phänomen. => Funktionsausfall nach ca. 1 Stunde.

Hat jemand noch eine Idee? Ich kann gerne auch ein paar Auszüge aus dem System einstellen, wenn Ihr mit sagt, was sinnvoll wäre.

Gluehwurm
Beiträge: 9706
Registriert: 19.03.2014, 00:37
Danksagung erhalten: 11 Mal

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von Gluehwurm » 13.10.2019, 12:59

arocker hat geschrieben:
13.10.2019, 12:47
... dachte eigentlich, das wäre eine "gute" Funktion, um die Empfangsqualität zu verbessern und hatte es einfach überall aktiviert ...
Hattest Du dich mal mit den Grundlagen des Themas beschäftigt ? Hast Du Gerät/e die als ""Router" dienen können ?
... ein paar Auszüge aus dem System einstellen ...
Was ist wie verknüpft ? Einstellung der virtuellen Kanäle ?
... wenn Ihr mit sagt, was sinnvoll wäre ...
Vielleicht alles, was irgendwie dazu beiträgt, das nachstellen zu können.

Gruß
Bruno

arocker
Beiträge: 8
Registriert: 11.10.2019, 23:12

Re: HmIP-BSM: Direktverknüpfungen gehen nicht mehr nach Abschalten CCU

Beitrag von arocker » 13.10.2019, 14:36

Gluehwurm hat geschrieben:
13.10.2019, 12:59
Hattest Du dich mal mit den Grundlagen des Themas beschäftigt ? Hast Du Gerät/e die als ""Router" dienen können ?
Ich habe gerade nochmal im WebUI-Handbuch nachgelesen. Ich habe kein entsprechendes Gerät, das als Router dienen könnte. Das scheint jedoch auch (nachdem ich Tests mit und ohne gesetztem Routing-Häkchen gemacht habe und es unabhängig davon zur Fehlersituation kommt) nicht der Grund für das Problem zu sein.
Gluehwurm hat geschrieben:
13.10.2019, 12:59
Was ist wie verknüpft ? Einstellung der virtuellen Kanäle ?
Vielleicht alles, was irgendwie dazu beiträgt, das nachstellen zu können.
Ok, dann mal ein erster Aufschlag die beiden Screenshots anbei.

Das sind sämtliche Direktverknüpfungen für die drei bei dieser Steuerung genutzten HmIP-Geräte. CCU-Programme sind für die drei Geräte nicht vorhanden.

Kurz zur Idee der Konfiguration:
  • "BadezimmerLichtschalter" (HmIP-BSM) schaltet das Licht an und aus über die Geräte-interne Direktverknüpfung (die ersten beiden im Screenshot)
  • Über die Direktverknüpfungen 3+4 wird die Verknüpfung mit dem HmIP-BSM der Lüftungssteuerung hergestellt (Kanal 4), jeweils mit Zeitverzögerung
  • Über die Direktverknüpfungen 5+6 kann ich den Lüfter zusätzlich manuell direkt ein oder ausschalten (ebenfalls Kanal 4 der Lüftung)
  • Mit der 7. Direktverknüpfung kommt der Messwert vom HmIP-FSM-Gerät vor der Gastherme an die Badezimmerlüftung (Kanal 6). Wenn dort Strom verbraucht wird, soll die Lüftung auf keinen Fall laufen.
  • Auf dem 2. Screenshot ist die Konfiguration der virtuellen Kanäle zu sehen. Geschaltet werden soll, wenn Kanal 4 aktiv ist, aber nicht Kanal 6.
Das funktioniert wie gesagt soweit alles wie gewünscht, so lange die CCU läuft.
20191013_Direktverknuepfungen.jpg
20191013_virtuelle_Kanaele.jpg

Antworten

Zurück zu „HomeMatic IP mit CCU“