NullPointerException beim setzten der Temperatur im Heizkörperthermostat in openhab

openHAB - open Home Automation Bus

Moderator: Co-Administratoren

Antworten
LoGYnaCY
Beiträge: 2
Registriert: 30.10.2019, 17:19

NullPointerException beim setzten der Temperatur im Heizkörperthermostat in openhab

Beitrag von LoGYnaCY » 30.10.2019, 19:00

Hallo zusammen,

ich habe ein Problem mit meinen Homematic IP Heizkörperthermostaten. Wenn ich die SOLL Temperatur eines Heizkörperthermostats in openHAB ändere, bekomme ich immer eine NullPointerException. Ich hab das Item manuell in Visual Studio Code wie folgt angelegt:

Number setPointTemperaturHeizung "Soll Temperatur Heizung [%.2f °]" <temperature> {channel="homematic:HmIP-eTRV-2:XXXXX#SET_POINT_TEMPERATURE"}

Wenn ich aber z.B. den Status des Fensters des Heizkörperthermostats ändere, funktioniert dies Problemlos. Die Soll und Ist Temperatur werden auch richtig in openHAB angezeigt.


Vielen Dank für eure Hilfe im voraus
Dateianhänge
openhab.log
openhab.log
(2.81 KiB) 19-mal heruntergeladen
events.log
events.log
(221 Bytes) 20-mal heruntergeladen

hoedlmoser
Beiträge: 205
Registriert: 19.01.2015, 07:42
Hat sich bedankt: 17 Mal
Danksagung erhalten: 8 Mal

Re: NullPointerException beim setzten der Temperatur im Heizkörperthermostat in openhab

Beitrag von hoedlmoser » 30.10.2019, 20:29

LoGYnaCY hat geschrieben:
30.10.2019, 19:00
Number setPointTemperaturHeizung "Soll Temperatur Heizung [%.2f °]" <temperature> {channel="homematic:HmIP-eTRV-2:XXXXX#SET_POINT_TEMPERATURE"}
siehe https://github.com/eclipse/smarthome/issues/6802

tl;dr: probier mal [%.1f °C]
RaspberryMatic 3.49.17.20191225 on Charly with Pi 3B+ and Aurel Groundplane binded by openHAB 2.5.0

LoGYnaCY
Beiträge: 2
Registriert: 30.10.2019, 17:19

Re: NullPointerException beim setzten der Temperatur im Heizkörperthermostat in openhab

Beitrag von LoGYnaCY » 30.10.2019, 20:53

Vielen Dank für die schnelle Antwort. Hat funktioniert! :D

Antworten

Zurück zu „openHAB“