RedMatic lässt sich nicht starten

Node-RED als CCU3/RaspberryMatic Addon, WebApp, HomeKit, ...

Moderator: Co-Administratoren

Antworten
Kletterfreund
Beiträge: 46
Registriert: 10.06.2015, 11:21
System: Alternative CCU (RaspberryMatic etc.)
Wohnort: bei Hannover

RedMatic lässt sich nicht starten

Beitrag von Kletterfreund » 10.11.2019, 22:00

Hallo, ich bekomme RedMatic nicht zum laufen. :x
Mein System: piVCCU 3.47.22-32 auf Odroid C2, Redmatic 5.2.1.
Hier ein Auszug aus dem Log:

{
"ccu": {
"VERSION": "3.47.22",
"PRODUCT": "ccu3",
"PLATFORM": "rpi3"
},
"redmatic": "5.2.1",
"nodejs": null,
"ain2": "3.0.0",
"node-red": "1.0.2",
"node-red-contrib-theme-midnight-red": "1.0.8",
"npm": "6.13.0",
"node-red-contrib-ccu": "3.1.2",
"node-red-contrib-combine": "1.8.1",
"node-red-contrib-sun-position": "0.5.0",
"node-red-dashboard": "2.17.1",
"node-red-node-email": "1.7.1",
"node-red-node-rbe": "0.2.5",
"redmatic-led": "1.1.0",
"redmatic-webapp": "0.3.1"
}
Illegal instruction

Was muss verändert werden?
piVCCU3 auf Rock Pi4b mit 256GB NVMe SSD und HB-RF-USB-TK (neuers Funkmodul) und Node-RED
Testsystem1: piVCCU3 auf Raspi 4 mit HB-RF-USB-TK (altes Funkmodul) und Node-RED (Backup)
Testsystem2: Debmatic auf Raspi 3 mit HB-RF-USB-TK (altes Funkmodul)
Testsystem3: RaspberryMatic auf Raspi 3 mit HB-RF-USB-TK (altes Funkmodul)

hobbyquaker
Beiträge: 3885
Registriert: 12.07.2009, 20:01
Hat sich bedankt: 17 Mal
Danksagung erhalten: 128 Mal
Kontaktdaten:

Re: RedMatic lässt sich nicht starten

Beitrag von hobbyquaker » 16.11.2019, 13:36

Das deutet darauf hin das Node.js nicht zur Plattform passt. Kannst Du mal die Ausgabe von

Code: Alles auswählen

uname -a
im piVCCU Container zeigen?

Kletterfreund
Beiträge: 46
Registriert: 10.06.2015, 11:21
System: Alternative CCU (RaspberryMatic etc.)
Wohnort: bei Hannover

Re: RedMatic lässt sich nicht starten

Beitrag von Kletterfreund » 08.12.2019, 22:45

Nach dem Update auf 5.2.4 lief die RedMatic auch nicht.

{
"ccu": {
"VERSION": "3.47.22",
"PRODUCT": "ccu3",
"PLATFORM": "rpi3"
},
"redmatic": "5.2.4",
"nodejs": null,
"ain2": "3.0.0",
"node-red": "1.0.3",
"node-red-contrib-theme-midnight-red": "1.0.14",
"npm": "6.13.2",
"node-red-contrib-ccu": "3.1.2",
"node-red-contrib-combine": "1.8.1",
"node-red-contrib-sun-position": "0.5.4",
"node-red-dashboard": "2.19.1",
"node-red-node-email": "1.7.2",
"node-red-node-rbe": "0.2.5",
"redmatic-led": "1.1.0",
"redmatic-webapp": "0.3.1"
}
Illegal instruction

uname -a ergibt:
Linux odroidc2 4.18.8-odroidc2 #264 SMP PREEMPT Wed Sep 19 12:35:18 CEST 2018 aarch64 aarch64 aarch64 GNU/Linux

uname -a im pivccu Container:
Linux ccu3-webui 4.18.8-odroidc2 #264 SMP PREEMPT Wed Sep 19 12:35:18 CEST 2018 aarch64 GNU/Linux
piVCCU3 auf Rock Pi4b mit 256GB NVMe SSD und HB-RF-USB-TK (neuers Funkmodul) und Node-RED
Testsystem1: piVCCU3 auf Raspi 4 mit HB-RF-USB-TK (altes Funkmodul) und Node-RED (Backup)
Testsystem2: Debmatic auf Raspi 3 mit HB-RF-USB-TK (altes Funkmodul)
Testsystem3: RaspberryMatic auf Raspi 3 mit HB-RF-USB-TK (altes Funkmodul)

hobbyquaker
Beiträge: 3885
Registriert: 12.07.2009, 20:01
Hat sich bedankt: 17 Mal
Danksagung erhalten: 128 Mal
Kontaktdaten:

Re: RedMatic lässt sich nicht starten

Beitrag von hobbyquaker » 15.12.2019, 14:22

Ich befürchte da muss ich Dich enttäuschen, auf dem Odroid wirst das nicht zum laufen bekommen. Bei der Nutzung von piVCCU rate ich aber sowieso grundsätzlich von RedMatic ab, installier besser einfach Node-RED+node-red-contrib-ccu in einem weiteren Container.

Kletterfreund
Beiträge: 46
Registriert: 10.06.2015, 11:21
System: Alternative CCU (RaspberryMatic etc.)
Wohnort: bei Hannover

Re: RedMatic lässt sich nicht starten

Beitrag von Kletterfreund » 16.12.2019, 23:40

Habe ich nun im anderen Container installiert, wie verbinde ich das alles?
piVCCU3 auf Rock Pi4b mit 256GB NVMe SSD und HB-RF-USB-TK (neuers Funkmodul) und Node-RED
Testsystem1: piVCCU3 auf Raspi 4 mit HB-RF-USB-TK (altes Funkmodul) und Node-RED (Backup)
Testsystem2: Debmatic auf Raspi 3 mit HB-RF-USB-TK (altes Funkmodul)
Testsystem3: RaspberryMatic auf Raspi 3 mit HB-RF-USB-TK (altes Funkmodul)

Christoph22
Beiträge: 38
Registriert: 10.03.2018, 20:36
Hat sich bedankt: 1 Mal
Danksagung erhalten: 2 Mal

Re: RedMatic lässt sich nicht starten

Beitrag von Christoph22 » 17.12.2019, 12:24


Antworten

Zurück zu „RedMatic“