Funk-Kombisensor (HM-WDS100-C6-O-2) Anlern- oder RaspberryMatic-Probleme

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
Australier
Beiträge: 5
Registriert: 02.02.2018, 19:20

Funk-Kombisensor (HM-WDS100-C6-O-2) Anlern- oder RaspberryMatic-Probleme

Beitrag von Australier » 20.01.2020, 18:35

Seit ca. 3 Jahren nutze ich einen Funk-Kombisensor des o.g. Typs und dieser hat gut 2 Jahre problemlos funktioniert. Danach verlor er häufiger die Funkverbindung, weshalb ich ihn mehrfach neu anlernte (inkl. Ablernen, Rücksetzen Werkszustand im WebUI und auch direkt am Gerät). Die beiden Skripte für "Regen heute" und "Regen gestern" wurden allerdings niemals wieder beim erneuten Anlernen erstellt. Als dann nach ca. einem weiteren halben Jahr die Batterien des Sensors immer schneller leer wurden (zuerst ca. nach einem Monat, danach nach ca. 2 Wochen) hielt ich den Sensor für defekt.

Vor ca. 1,5 Wochen habe ich mir einen neuen Funk-Kombisensor gekauft, der allerdings das identische Verhalten zeigt, d. h. beim Anlernen werden die beiden Skripte nicht angelegt und die Batterien zeigen nur noch eine Spannung von 1,0 V an. Mein Anruf bei EQ3 war mehr oder weniger erfolglos, man bot an mir einen neuen Sensor zuzuschicken, bei der Angabe meiner CCU schob man es jedoch auf die Zentrale.

Ich verwende auf einem Tinkerbird S, die vorletzte Version von RaspiMatic (3.47.22.20191130), doch auch schon die Vorgängerversion ab ca. Q1 2019 zeigten dieses Verhalten.

Ich vermute, in den Tiefen meines Systems sind irgendwo noch ein paar Code-Fragmente von meinem vor 3 Jahren Angelenten Funk-Kombisensor enthalten, die vom System nicht gelöscht wurden und beim erneuten Anlernen des Funk-Kombisensors dann zu Fehlern führten.

Wenn dem so wäre, wie und vor allem wo könnte ich diese finden und löschen? Mit SSH auf den Tinkerbird und dann in welchem Verzeichnis wonach suchen oder werden evtl. noch andere Alternativen gesehen?

An- und Ablernen mit und ohne zurücksetzen in den Werkszustand, sowohl am Gerät, als auch in der WebUI habe ich mind. 20-mal erfolglos durchgeführt, bin etwas ratlos und für mich klingt die Möglichkeit, das Code-Fragmente vom erstmaligen Anlernen die Ursache sind, am plausibelsten. Was denkt ihr?

Beste Grüße
Australier

Hütte
Beiträge: 317
Registriert: 08.02.2017, 11:08
Hat sich bedankt: 5 Mal
Danksagung erhalten: 21 Mal

Re: Funk-Kombisensor (HM-WDS100-C6-O-2) Anlern- oder RaspberryMatic-Probleme

Beitrag von Hütte » 22.01.2020, 14:54

Wähle mal in der Programmansicht ganz unten den Button "Systeminterne Programme einblenden" aus. Dann bekommst du auch die automatisch generierten Programme, die beim Anlernen eventuell erzeugt werden, ebenfalls angezeigt.
Bestandteil den Programm-Names ist die Seriennummer des entsprechenden Gerätes, aber auch eine Zahl, die wohl eher "zufällig" vom System festgelegt wird. Wenn also das Ab- und neu Anlernen nicht sauber funktioniert hat, dann hast du unter Umständen mehrere solcher Programme mit derselben Seriennummer des Gerätes.
Wenn du den Sensor ablernst (mit Werksreset), dann sollten diese zugehörigen Programme auch verschwinden. Wenn nicht, dann kannst du sie dort löschen - oder auch erst einmal auf inaktiv setzen. Aber vorher mal in die Programme schauen, ob da eventuell systeminterne Systemvariablen benutzt werden. Wie man allerdings diese SV gelöscht bekommt, wenn sie vom System nicht automatisch saber gelöscht werden, kann ich dir im Moment auch nicht sagen, ich hatte bei mir diesen Fall zum Glück noch nicht.

Australier
Beiträge: 5
Registriert: 02.02.2018, 19:20

Re: Funk-Kombisensor (HM-WDS100-C6-O-2) Anlern- oder RaspberryMatic-Probleme

Beitrag von Australier » 22.01.2020, 20:15

Hallo Hütte, Danke für deine Antwort. Leider habe ich keine selbsterzeugte Programme im Kontext des Funk-Kombisensors, auch nicht als interne Programme. Dort sind Programme mit der von Dir beschriebenen Bildungsregel zu finden, allerdings weder mit einem Teil zur Seriennummer des alten oder des neuen Funk-Kombisensors. Programme mit der Bezeichnung "Regen heute" und "Regen gestern" hatte ich bei meinem ersten Funk-Kombisensor einmal gehabt, jetzt jedoch nicht mehr. Diese hatte ich gelöscht, in der Hoffnung damit die Kommunikationsprobleme zu beseitigen, durch ein erneutes "sauberes" Anlernen. Das Anlernen hatte auch geklappt, die Kommunikationsprobleme waren weg, jedoch die beiden Skripte wurden nicht angelegt. Nach einigen Monaten kam dann der signifikant hohe Batterieverbrauch dazu. :shock:

Australier
Beiträge: 5
Registriert: 02.02.2018, 19:20

Re: Funk-Kombisensor (HM-WDS100-C6-O-2) Anlern- oder RaspberryMatic-Probleme

Beitrag von Australier » 15.02.2020, 14:31

Hallo zusammen, ich konnte mein Problem mit dem Funk-Kombisensor leider nicht lösen. Ich habe mir deshalb die IP-Variante des Funk-Kombisensor (Wettersensor PRO) besorgt und damit funktioniert nun alles wie gewünscht, die selbsterzeugten Programme sind dort vorhanden. Dies nur zur Info an alle die vor dem gleichen Problem stehen.

Antworten

Zurück zu „RaspberryMatic“