Programmteil - Beschattung löst nicht aus

Einrichtung, Anschluss und Programmierung der HomeMatic CCU

Moderator: Co-Administratoren

nils50122
Beiträge: 23
Registriert: 12.09.2019, 08:30
Hat sich bedankt: 8 Mal

Programmteil - Beschattung löst nicht aus

Beitrag von nils50122 » 21.05.2020, 19:50

Hallo,

ich habe ein Programm welches die aktuelle Helligkeit eines Bewegungsmelder außen (ich weiß nicht ideal) abfragt und je nach aktuellem Helligkeitswert die Beschattung einer Rollade auslösen oder auch wieder rückgängig machen soll.

Der erste Programmteil läuft einwandfrei im angegebenem Zeitfenster von 09:00 Uhr - 21:00 Uhr, die Rollade fährt auf 25% wenn der Helligkeitswert von 11.000 überschritten ist. Die Systemvariable "Beschattung xxx" wird dann ebenfalls auf aktiv gesetzt.

Allerdings will der zweite Programmteil "Sonst, wenn" absolut nicht auslösen.
Ich habe schon folgende Dinge probiert und bin so langsam mit meinen Ideen am Ende.

- Zeitspanne auf "nur prüfen" gesetzt
- CCU_im_Reboot rausgenommen, was eigentlich quatsch ist, da es sonst überall auch funktioniert.
- Programm neu angelegt
- Programmteil ab "Sonst, wenn" in ein komplett neues Programm ausgegliedert, auch dies will nicht auslösen.

Alle Bedingungen sind meiner Meinung nach erfüllt.
- Es ist im Zeitraum 09:00 Uhr - 21:00 Uhr
- Die CCU befindet sich nicht im Reboot
- Die Helligkeit ist aktuell bei 3000
- Die SV automatische Beschattung ist auf an
- Die SV Beschattung ist aktuell auf aktiv

Was fehlt denn nun noch, dass das Programm endlich die Rolladen wieder auf 100% fährt?
Programm.PNG

MichaelN
Beiträge: 143
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 19 Mal
Danksagung erhalten: 3 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von MichaelN » 21.05.2020, 20:20

Der sonst Zweig wird genau dann durchlaufen,
Wenn es 9 Uhr ist
Wenn der Sensor die 8000 lux unterschreitet

Wenn zu diesen beiden Zeitpunkten die anderen Bedingungen nicht erfüllt sind, dann wird keine Aktion ausgelöst.

Protokollierst du alle diese Parameter z.b mit Historian? Dann kannst du das sehr leicht kontrollieren.
LG, Michael.

Benutzeravatar
robbi77
Beiträge: 9760
Registriert: 19.01.2011, 19:15
System: CCU
Wohnort: Landau
Hat sich bedankt: 44 Mal
Danksagung erhalten: 132 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von robbi77 » 21.05.2020, 20:20

Die SV CCU reboot bringt in dem Programm genau was?

Ich würde die Abfrage der SV Beschattung aktiv mal weg lassen.
Helligkeit hat sich von >8000 auf <8000 geändert?
Programm löschen und neu anlegen.

🤷‍♂️
Bei Risiken und Nebenwirkungen fragen Sie den Elektriker Ihres geringsten Mißtrauens!
http://www.eq-3.de/service/downloads.html
Tips und Tricks für Anfänger: viewtopic.php?t=22801
Programmlogik: viewtopic.php?f=31&t=4251
Webui-Handbuch: https://www.eq-3.de/Downloads/eq3/downl ... h_eQ-3.pdf
Script und Linksammlung: viewtopic.php?f=26&t=27907
Troll des Forums ...

MichaelN
Beiträge: 143
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 19 Mal
Danksagung erhalten: 3 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von MichaelN » 21.05.2020, 20:23

Ganz brutale Methode : Sensor Bedingung auf "Aktualisierung"
LG, Michael.

nils50122
Beiträge: 23
Registriert: 12.09.2019, 08:30
Hat sich bedankt: 8 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von nils50122 » 22.05.2020, 10:55

MichaelN hat geschrieben:
21.05.2020, 20:20
Der sonst Zweig wird genau dann durchlaufen,
Wenn es 9 Uhr ist
Wenn der Sensor die 8000 lux unterschreitet

Wenn zu diesen beiden Zeitpunkten die anderen Bedingungen nicht erfüllt sind, dann wird keine Aktion ausgelöst.

Protokollierst du alle diese Parameter z.b mit Historian? Dann kannst du das sehr leicht kontrollieren.
Verständnisfrage:
Löst der sonst Zweig nur aus, wenn es Punkt 9:00 Uhr ist UND der Sensor dann die 8000 Lux unterschreitet?
Ich bin bisher davon ausgegangen, dass egal in welchen Zeitraum von 09:00 Uhr - 21:00 Uhr geprüft wird ob der Sensor die 8000 Lux unterschreitet.
Ist dies korrekt? Ich habe in anderen Threads gelernt Zeitraum "nur prüfen" funktioniert nicht.

Matsch
Beiträge: 666
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 8 Mal
Danksagung erhalten: 61 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von Matsch » 22.05.2020, 11:39

nils50122 hat geschrieben:
22.05.2020, 10:55
Ich bin bisher davon ausgegangen, dass egal in welchen Zeitraum von 09:00 Uhr - 21:00 Uhr geprüft wird ob der Sensor die 8000 Lux unterschreitet.
Ist dies korrekt?
Ja

nils50122
Beiträge: 23
Registriert: 12.09.2019, 08:30
Hat sich bedankt: 8 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von nils50122 » 22.05.2020, 11:46

Problem gelöst.

Der Wert "aktuelle ungefilterte Helligkeit wird nur sehr unregelmäßig übertragen.
Mit dem Wert "Helligkeit" klappt das Programm einwandfrei.

Matsch
Beiträge: 666
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 8 Mal
Danksagung erhalten: 61 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von Matsch » 22.05.2020, 11:55

Ungefilterte Helligkeit wäre sowieso nicht gut, da würde bei jeder Wolke der Rollladen rauf- und runterfahren.

MichaelN
Beiträge: 143
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 19 Mal
Danksagung erhalten: 3 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von MichaelN » 22.05.2020, 12:27

nils50122 hat geschrieben:
22.05.2020, 10:55
Löst der sonst Zweig nur aus, wenn es Punkt 9:00 Uhr ist UND der Sensor dann die 8000 Lux unterschreitet?
Ich bin bisher davon ausgegangen, dass egal in welchen Zeitraum von 09:00 Uhr - 21:00 Uhr geprüft wird ob der Sensor die 8000 Lux unterschreitet.
Ist dies korrekt? Ich habe in anderen Threads gelernt Zeitraum "nur prüfen" funktioniert nicht.
Wenn Du um 9 Uhr hoch fahren willst, wenn zu diesem Zeitpunkt <8000Lx sind, dann musst Du "zu Zeitpunkten auslösen" einstellen
Willst Du aber, das er im Zeitfenster zwischen 9-21 bei <8000Lx hoch fährt, dann ist Zeit prüfen richtig

Und um nochmal zu konkretisieren: es wird nicht zwischen 9-21 Uhr ständig geprüft, ob Lx<8000 ist, sondern das Programm wird nur genau dann durchlaufen, wenn Lx die 8000 unterschreitet. Genau dieses eine Mal (bzw. mehrmals, wenn es durch Helligkeitsschwankungen mehrfach von >8000 auf <8000 wechselt). Und wenn dann noch zwischen 9-21 Uhr ist, dann wird die Aktion auch durchgeführt.
LG, Michael.

Matsch
Beiträge: 666
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 8 Mal
Danksagung erhalten: 61 Mal

Re: Programmteil - Beschattung löst nicht aus

Beitrag von Matsch » 22.05.2020, 13:05

Möglicherweise will er aber beides!? Triggerung bei Beginn des Zeitraums UND bei Änderung der Schwelle?
Wäre mir plausibel.

Allerdings ist mir nicht bekannt, dass ein "prüfen" des Zeitraums nicht funktionieren soll. Jedenfalls hatte ich damit noch keine Probleme.
In diesem Fall hier würde ich im SONST-WENN-Pfad ohnehin den Zeitraum auf "prüfen" setzen, da die gleiche Triggerbedingung bereits im ersten WENN enthalten ist und so das Programm unnötigerweise zweimal getriggert und durchlaufen wird.

Antworten

Zurück zu „HomeMatic Zentrale (CCU / CCU2 / CCU3 / Charly)“