Sonnensteuerung klappt nicht

Allgemeines zur HomeMatic Haussteuerung

Moderator: Co-Administratoren

mepe
Beiträge: 5
Registriert: 28.06.2020, 14:08
System: CCU

Sonnensteuerung klappt nicht

Beitrag von mepe » 28.06.2020, 14:32

Hallo Zusammen,

als blutiger Neueinsteiger Versuch ich mich zunächst mal mit einfachen Programmen. Um so verärgerter und verzweifelter bin ich, wenn so eine einfach aussehende Sache nicht klappt.

Die einfach Aufgabe lautet:

Die Rollladen im Süden und Westen sollen über eine Variable "Sonne Süd" und "Sonne West" bei Werten des Lichtsensors größer 14T Lux runter, bzw. bei kleiner als 9,5T Lux hoch fahren. Das kann jeder Schalter mit Lichtsensor, nur meine Homematic nicht!?

Die Rollladen im Süden sollen bei 14000 Lux auf 60% runter fahren. Dazu wird eine Variable Sonne Süd auf WAHR gesetzt.
Das soll nur in der Zeit zwischen 9 und 16:15 Uhr erfolgen.
Bildschirmfoto 2020-06-28 um 14.11.16.png
Klappt! :-)

Ein weiteres Programm startet bei Änderung der Variabele Sonne Süd und fährt die Rollladen auf 60%
Bildschirmfoto 2020-06-28 um 14.22.25.png
Klappt! :-)

Da ja immer wieder Wolken durchs Land ziehen und ich das Haus nicht dunkel haben will, sollen die Behänge bei kleiner/gleich 9,5T Lux wieder hoch fahren. 5 Minuten soll das Ereignis warten, ob die Wolken sich nicht doch noch verziehen und es heller als 9,5T Lux wird.
Bildschirmfoto 2020-06-28 um 14.11.41.png
klappt nicht! :-(
Zumindest fast nicht. Nehme ich die Verzögerung raus, gehts.

Wie muß es es aussehen, damit es klappt?

Vielen Dank und einen schönen Rest Sonntag!

Gruß Meinhard

MichaelN
Beiträge: 393
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 34 Mal
Danksagung erhalten: 29 Mal

Re: Sonnensteuerung klappt nicht

Beitrag von MichaelN » 28.06.2020, 15:22

Zumindest fast nicht. Nehme ich die Verzögerung raus, gehts.
Hast Du doch selber schon festgestellt: den Haken bei Retrigger raus, sonst startet die Verzögerung immer wieder neu und kommt nie zur Ausführung.

btw: ob es so viel besser ist, das die Rollos nur alle 5 Minute hoch und runter fahren... Ich habe da Verzögerungen von 20-50 Minuten drin

Matsch
Beiträge: 762
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 11 Mal
Danksagung erhalten: 68 Mal

Re: Sonnensteuerung klappt nicht

Beitrag von Matsch » 28.06.2020, 15:26

Benutze doch einfach zum Öffnen den Durchschnittswert der Helligkeit und nicht den ungefilterten Wert. Der Mittelwert sinkt ja nur langsam, da hast du deine gewollte Verzögerung, im Zusammenhang mit der Schwelle.
Zudem kannst du die Zeitkonstante der Mittelwertbildung in der Gerätekonfiguration modifizieren.

mepe
Beiträge: 5
Registriert: 28.06.2020, 14:08
System: CCU

Re: Sonnensteuerung klappt nicht

Beitrag von mepe » 28.06.2020, 16:18

In der Wartezeit kann sich die Helligkeit doch nochmal zur Einschaltschwelle verändern. Daher soll ja jedesmal wenn der Wert unterschritten wird das Programm mit seinen 5min neu starten, denn dann sollen die Rollladen doch nicht hoch fahren, sondern auf 60% bleiben. Oder wieder Denkfehler?

Matsch
Beiträge: 762
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 11 Mal
Danksagung erhalten: 68 Mal

Re: Sonnensteuerung klappt nicht

Beitrag von Matsch » 28.06.2020, 16:21

Wenn sich die Helligkeit später noch mal ändert (steigt), steigt doch auch der Mittelwert mit an und kann also nicht das Öffnen auslösen.
So richtig verstehe ich deine Frage jetzt nicht.

Im Falle der Verwendung des Mittelwerts brauchst du im Programm überhaupt keine Verzögerung mehr, das macht die Mittelwertbildung im Sensor ja schon.
Zuletzt geändert von Matsch am 28.06.2020, 16:29, insgesamt 1-mal geändert.

MichaelN
Beiträge: 393
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 34 Mal
Danksagung erhalten: 29 Mal

Re: Sonnensteuerung klappt nicht

Beitrag von MichaelN » 28.06.2020, 16:22

Dann greift doch wieder dein erstes Programm und setzt die Variable sofort, was den Trigger stoppt.

Btw: ich würde keine Sonderzeichen für Objekt Namen verwenden

mepe
Beiträge: 5
Registriert: 28.06.2020, 14:08
System: CCU

Re: Sonnensteuerung klappt nicht

Beitrag von mepe » 28.06.2020, 17:22

Matsch hat geschrieben:
28.06.2020, 16:21
Im Falle der Verwendung des Mittelwerts brauchst du im Programm überhaupt keine Verzögerung mehr, das macht die Mittelwertbildung im Sensor ja schon.
Wo soll denn der Mittelwert her kommen?
Bildschirmfoto 2020-06-28 um 17.21.09.png

mepe
Beiträge: 5
Registriert: 28.06.2020, 14:08
System: CCU

Re: Sonnensteuerung klappt nicht

Beitrag von mepe » 28.06.2020, 17:25

MichaelN hat geschrieben:
28.06.2020, 16:22
Dann greift doch wieder dein erstes Programm und setzt die Variable sofort, was den Trigger stoppt.
Verstehe ich das richtig, dass die Wertänderung einer Variable den Trigger zu dieser Stoppt, egal aus Programm der ausgelöst wurde?

Die Sonderzeichen helfen derzeit noch, die Programme schneller zu sortieren. Ändere ich später noch.

Matsch
Beiträge: 762
Registriert: 30.05.2019, 11:37
Wohnort: Chemnitz
Hat sich bedankt: 11 Mal
Danksagung erhalten: 68 Mal

Re: Sonnensteuerung klappt nicht

Beitrag von Matsch » 28.06.2020, 17:35

mepe hat geschrieben:
28.06.2020, 17:22
Wo soll denn der Mittelwert her kommen?
Man kann den Zeitmaßstab in deinem Diagramm nicht sehen, ich vermute aber, du stellst einen ganzen Tag dar?
Dir geht es doch aber um zeitliche Verzögerungen von 5 min?
Die kannst du doch in diesem Maßstab gar nicht aus dem Diagramm herauslesen! Mach mal eine Vergrößerung, so dass man 5 min klar erkennen kann.
Zudem werden intern die Werte zwar aller 30s ermittelt, aber nur aller rd. 2,5 min gesendet. Allein schon dadurch hast du eine Verzögerung der Werte.
Hinzu kommt, dass diese WebUI-Diagramme ziemlicher Schrott sind und die Kurve durch Interpolation und Verrundung oft nichts mit der Wirklichkeit zu tun hat. Bitte nicht sklavisch aus diesen Bildern Feinheiten erkennen wollen.

Ich habe den Ringspeicher auf Maximum gesetzt (=30, das entspricht einer Mittelwertbildung über die letzten 15 min) und habe Verzögerungen, die je nach Helligkeitssprung mindestens bei 5...10 min liegen.
Natürlich muß man auch die Schwellen entsprechend legen, das hat ja auch Einfluß darauf.

MichaelN
Beiträge: 393
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 34 Mal
Danksagung erhalten: 29 Mal

Re: Sonnensteuerung klappt nicht

Beitrag von MichaelN » 28.06.2020, 18:01

mepe hat geschrieben:
28.06.2020, 17:25
MichaelN hat geschrieben:
28.06.2020, 16:22
Dann greift doch wieder dein erstes Programm und setzt die Variable sofort, was den Trigger stoppt.
Verstehe ich das richtig, dass die Wertänderung einer Variable den Trigger zu dieser Stoppt, egal aus Programm der ausgelöst wurde?
Richtig

Antworten

Zurück zu „HomeMatic allgemein“